1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VRRP+MSTP Design

Discussion in 'Routing & Switching' started by djh3ll, Sep 13, 2011.

  1. djh3ll

    djh3ll New Member

    1
    0
    1
    Hello there,

    I have a little issue with my new network topology and configuration.

    Here is my topology :

    I have two L3 switches, which are routing my network. I am using VRRP in Active-Passive mode for routing redundancy, where SW1 is master for all vlans (So if one from router/switches will fail, other one will behave like master router). I have many VLANs on network, but for example i will use just two, VLAN 10 and VLAN 20.

    To the first switch is connected access switch by one line. Which has just changed. I added second connection from access switch to the core switch, so from each access switch i have 2 connections to the core switches (SW3 to SW1, SW3 to SW2, ...) BUT! with this, there is LOOP in my topology, because i have also connection between SW1 and SW2.

    View attachment 2405

    To the switches SW1 and SW2 is connected blade server (in this example it is named "pc client") with Active-Passive link (this failover is controller by xenserver) and i need all vlans on this connection.

    To the access switch i have connected PC (in trunk) with vlans 10 and 20 and i need pc to be able to communitace with blade server (also in case of some device failure).

    What i need to solve/configure :


    I need to solve somehow loop in my network (best solution will be MSTP for me, because of „vlan load balancing“)
    So VRRP+MSTP on this topology. In case of MSTP i want use half vlans on one connection and half vlans on second connection (load balance).

    Most of failures what can happend are described on picture 2.

    View attachment 2406

    I really stucked on this for month now, can someone help me please with this ?

    Thank you

    Regards,
    JD
     
    Last edited: Sep 13, 2011
  2. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    What do you need help with? As you have mentioned, you will have spanning-tree which will sort the loop, and you are also going to load-balance across the uplinks on a per-vlan basis...
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  3. cisco lab rat

    cisco lab rat Megabyte Poster

    660
    62
    116
    Try this, I have done the below from the top of my head so there might be a typo or two, but I will talk you through it

    SWITCH 1
    Here you have the two routed interfaces that will be the gateways for your clients, SW1 will be the master router for VLAN 10 the backup for VLAN 20, look at the priorites (Default 100)

    SW1
    interface vlan 10
    ip 10.1.1.1 255.255.255.0
    vrrp 10 ip 10.1.1.10
    vrrp 10 priority 254
    no shut

    interface vlan 20
    ip 20.1.1.1 255.255.255.0
    vrrp 20 ip 20.1.1.11
    vrrp 20 priority 200
    no shut

    SWITCH 2
    Here you have the two routed interfaces that will be the gateways for your clients, SW2 will be the master router for VLAN 20 the backup for VLAN 10, look at the priorites (Default 100)

    SW2
    interface vlan 10
    ip 10.1.1.2 255.255.255.0
    vrrp 10 ip 10.1.1.10
    vrrp 10 priority 200
    no shut

    interface vlan 20
    ip 20.1.1.2 255.255.255.0
    vrrp 20 ip 20.1.1.11
    vrrp 20 priority 254
    no shut

    SW1 and SW2 have identical MST configs, I have made SW1 the IST ROOT for INSTANCE 1 and IST 0 and SW2 the ROOT for INSTANCE 2 using the ROOT PRIMARY command (There is another way using the priority command)

    SW1(config)#spanning-tree mode mst
    SW1(config)#spanning-tree mst configuration
    SW1(config-mst)#instance 1 vlan 10
    SW1(config-mst)#instance 2 vlan 20
    SW1(config-mst)#exit
    SW1(config)#spanning-tree mst 1 root primary
    SW1(config)#spanning-tree mst 0 root primary

    SW2(config)#spanning-tree mode mst
    SW2(config)#spanning-tree mst configuration
    SW2(config-mst)#instance 1 vlan 10
    SW2(config-mst)#instance 2 vlan 20
    SW2(config-mst)#exit
    SW1(config)#spanning-tree mst 2 root primary

    Make sure that all the links between all the switches are set manually trunk and turn off DTP

    SWx(config)#interface range fastEthernet 0/x - y X = start of range y= End of range
    SWx(config-if-range)#switchport trunk encapsulation dot1q encap must be selected first, if your switch supports multiple encap modes
    SWx(config-if-range)#switchport mode trunk
    SWx(config-if-range)#switchport nonegotiate
    SWx(config-if-range)#switchport trunk allowed vlan all allow all vlans across


    NOTES: The Master vrrp routr for a given VLAN must also be the ROOT for that vlan

    Hope this helps, again this is from the top of my head so watch out for typos, but it is a straight forward vanilla config. I will look at this in more detail later but for now get you core network sorted.

    Cheers

    Joe
     
    Last edited: Sep 13, 2011
    Certifications: Yes I pretty much am!!
    WIP: Fizzicks Degree
    GiddyG likes this.
  4. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    Haha i missed the key word "configure" in his post....didn't realise he wanted someone to show him the whole config.

    Good job Joe!
     
    Certifications: CCENT, CCNA
    WIP: CCNP

Share This Page

Loading...