1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

trunks for phones voip

Discussion in 'Routing & Switching' started by insurin, May 12, 2009.

  1. insurin

    insurin Bit Poster

    My current setup for switch ports for phones with computers hanging off the phone is

    interface FastEthernet0/31
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 23
    switchport mode trunk
    switchport voice vlan 10
    spanning-tree portfast

    I have been told that this is the old method and the new way should read like

    interface FastEthernet0/31
    switchport access vlan 23
    switchport mode access
    switchport voice vlan 10
    spanning-tree portfast

    Both ways work fine. However, reading the top method again, the port is set to be a trunk. Let’s say I have configured 24 ports this way so they are all trunks with dot1q. The first 23 are phones with computers hanging off them and port 24 is the actual trunk port to another switch or back to the core. Does this mean that for every bit of traffic the switch receives that is not in its mac table or destined for other vlans will be flooded/propagated out of every port? Of course it cannot get anywhere for ports 1 - 23 but for port 24 it would be sent out the trunk port as normal.

    If this is the case, does this mean that I am generating extra traffic on 23 ports unnecessarily?

    Given that most of my configs for phones is configured like this, I am hoping to improve throughput by reconfiguring to the second method.
  2. mentman

    mentman Bit Poster

    You could configure allowed vlans on that trunk.

    Then only broacasts/floods will be sent out the trunks for the vlans that you allow, your access vlan and voice vlan.
    Certifications: CCNA, CCENT, ITE, 642-812 BCMSN
    WIP: 642-901 BCSI
  3. danielno8

    danielno8 Gigabyte Poster

    ^ this

    for the phone ports use the command

    switchport trunk allowed vlan vlanid

    However, i'd go to the new method personally.
    Certifications: CCENT, CCNA
  4. Fergal1982

    Fergal1982 Petabyte Poster

    mmmmmmmm brainy necroposting goodness!
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present

Share This Page