1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server 2008 R2 Static IP Issue

Discussion in 'Virtual Computing' started by camadi46, Jul 21, 2011.

  1. camadi46

    camadi46 Bit Poster

    26
    0
    24
    Hi everyone,
    First of all, I am new to servers but I obviously want to improve.
    I installed Server 2008 R2 on VM Virtual Box, create a domain, installed DHCP, DNS, configured the server. When I set a static IP I don't have any internet access.
    I looked on the status page of my router and the DHCP on the router assigns IPs from 192.168.1.64 to 192.168.1.253, Default Gateway is 192.168.1.254, DNS is 194.72.9.34 and 62.6.40.178. I tried assigning an IP address outside the router's DHCP range but no luck.
    ipconfig /all on the server with "Obtain IP automatically" and "Obtain DNS automatically" comes up with: 10.0.2.15 (Preferred), Subnet 255.255.255.0, Default Gateway and DHCP server 10.0.2.2 and DNS 192.168.1.254,.
    What static IP address, Default Gateway and DNS should I use in order to have internet access and be able to make other virtual PCs part of the domain?
    Thank you very much.
     
    Certifications: A+, MCP
    WIP: 70-680
  2. DC Pr0Mo

    DC Pr0Mo Kilobyte Poster

    265
    6
    41
    I've never used Virtual Box, but I assume it is the same as Virtual PC, first off your server needs to be on the same network as your routers lan 192.168.1.0/24, and default gateway should point to your router 192.168.1.254/24, you said you setup DHCP on the server, is the range 10.0.2.0/24 ?

    Also you may need to associate your virtual network adapter to your PC/laptops network card/wireless card. I would uninstall DHCP on your server, and set the server nic card to DHCP (This is not advised in the sense that a server should have a static ip, but you can change that later) This will confirm you virual adapter is associated with your pc/laptops nic card and will also confirm you are getting the correct ip configuration from your DHCP/Router.

    **EDIT**

    Point the servers dns IP to itself 127.0.0.1, and set a forwarder to your router.
     
    Last edited: Jul 21, 2011
    Certifications: MCDST | BSc Network Computing
    WIP: 70-291 | 70-293 | 70-294 | 70-297
  3. DC Pr0Mo

    DC Pr0Mo Kilobyte Poster

    265
    6
    41
    Also, when setting up a client to join to the domain, you can set the clients ip address to dynamic but make sure you point its dns settings to your servers IP address.

    TBH my above soultion is not ideal, but will at least get you up and running!
     
    Certifications: MCDST | BSc Network Computing
    WIP: 70-291 | 70-293 | 70-294 | 70-297
  4. jiggy

    jiggy Nibble Poster

    96
    6
    27
    you probably have the network card set to NAT in VirtualBox. Change it to bridged mode and it should work ok.
     
    Certifications: MCSE
    WIP: ABC's
  5. Modey

    Modey Terabyte Poster

    2,397
    99
    154
    You will need two virtual NIC's on your server. You can still run DHCP no problem on your VM but you will need to ensure that the primary NIC (with a static address) is set to a private (or local) networking mode in the networking settings on the VM Host. That way it isolates it from your home network. Then bridge the second virtual adapter so it can see your home network. That adapter will then allow you internet access on the server. If you then wanted clients joined to the server to be able to get on the internet as well, then setup RRAS on the server. You would also probably have to setup DNS forwarders if you did that.
     
    Certifications: A+, N+, MCP, MCDST, MCSA 2K3, MCTS, MOS, MTA, MCT, MCITP:EDST7, MCSA W7, Citrix CCA, ITIL Foundation
    WIP: Nada
  6. camadi46

    camadi46 Bit Poster

    26
    0
    24
    Thanks a lot guys. I set my network adapter to Bridged, set a static IP and it works now. I will setup my second network adapter asap.
    I have to figure out DNS forwarders and RRAS next. Any advice on those two would be much appreciated as well.
    Thanks again for your help. Spot on!
     
    Certifications: A+, MCP
    WIP: 70-680

Share This Page

Loading...