1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Only default VLAN has Internet access (Packet Tracer simulation)

Discussion in 'General Cisco Certifications' started by NetInter, Apr 23, 2013.

  1. NetInter

    NetInter New Member

    4
    0
    1
    15.jpg

    I've created network simulation with PT (my skills are really weak). Everything was ok and all PC's had no problems with automatic DHCP IP configuration (set on router) and etc. until I decided create two VLAN's on Cisco Switch. When I added all PC's to those VLANS - DHCP doesn't work anymore on them, no access to HTTP on those PC's. I simply only created VLANs, added ports, and made trunk mode from switch to router interface. Thats it. Obvious I need to configure something, maybe someone can help me with this :( ?

    Btw if I remove PC from created VLAN's, it works fine on default VLAN.
     
  2. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Did you create a subinterface with tagging on the router, assuming it's router-on-a-stick you're trying?
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  3. NetInter

    NetInter New Member

    4
    0
    1
    I dont think so. This is my full router configuration:

    Router>ena
    Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#int fa 0/0
    Router(config-if)#ip add
    Router(config-if)#ip address dhcp
    Router(config-if)#no shut
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    Router(config-if)#exit
    Router(config)#hostname VMVT_mrs
    VMVT_mrs(config)#int vlan 20
    VMVT_mrs(config-if)#ip add 192.168.0.1 255.255.255.0
    VMVT_mrs(config-if)#int range fa 0/0/0 - 3
    VMVT_mrs(config-if-range)#switchport access vlan 20
    %LINK-5-CHANGED: Interface Vlan20, changed state to up
    % Access VLAN does not exist. Creating vlan 20
    VMVT_mrs(config-if-range)#no shut
    %LINK-5-CHANGED: Interface FastEthernet0/0/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0/0, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
    %LINK-5-CHANGED: Interface FastEthernet0/0/1, changed state to up
    %LINK-5-CHANGED: Interface FastEthernet0/0/2, changed state to up
    %LINK-5-CHANGED: Interface FastEthernet0/0/3, changed state to up
    VMVT_mrs(config-if-range)#exit
    VMVT_mrs(config)#ip dhcp pool vartotojai
    VMVT_mrs(dhcp-config)#network 192.168.0.0 255.255.255.0
    VMVT_mrs(dhcp-config)#default-router 192.168.0.1
    VMVT_mrs(dhcp-config)#dns-server 10.10.10.2
    VMVT_mrs(dhcp-config)#exit
    VMVT_mrs(config)#ip dhcp excluded-address 192.168.0.1
    VMVT_mrs>ena
    VMVT_mrs#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    VMVT_mrs(config)#access-list ? [komandos pabaigoje naudojant „?“ galima pasitikrint galimas tolesnias opcijas]
    <1-99> IP standard access list
    <100-199> IP extended access list
    VMVT_mrs(config)#access-list 1 ?
    deny Specify packets to reject
    permit Specify packets to forward
    remark Access list entry comment
    VMVT_mrs(config)#access-list 1 permit ?
    A.B.C.D Address to match
    any Any source host
    host A single host address
    VMVT_mrs(config)#access-list 1 permit 192.168.0.0 ?
    A.B.C.D Wildcard bits
    <cr>
    VMVT_mrs(config)#access-list 1 permit 192.168.0.0 0.0.0.255
    VMVT_mrs(config)#ip nat inside ?
    source Source address translation
    VMVT_mrs(config)#ip nat inside source ?
    list Specify access list describing local addresses
    static Specify static local->global mapping
    VMVT_mrs(config)#ip nat inside source list ?
    <1-199> Access list number for local addresses
    WORD Access list name for local addresses
    VMVT_mrs(config)#ip nat inside source list 1 ?
    interface Specify interface for global address
    pool Name pool of global addresses
    VMVT_mrs(config)#ip nat inside source list 1 interface ?
    Ethernet IEEE 802.3
    FastEthernet FastEthernet IEEE 802.3
    GigabitEthernet GigabitEthernet IEEE 802.3z
    Serial Serial
    VMVT_mrs(config)#ip nat inside source list 1 interface fa 0/0

    VMVT_mrs(config)#int vlan 20
    VMVT_mrs(config-if)#ip nat inside
    VMVT_mrs(config-if)#int fa 0/0
    VMVT_mrs(config-if)#ip nat outside
    VMVT_mrs(config-if)#end
    VMVT_mrs#copy running-config startup-config
     
  4. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
    NetInter likes this.
  5. NetInter

    NetInter New Member

    4
    0
    1
    Thank you for explanation :)
     
  6. NetInter

    NetInter New Member

    4
    0
    1
    Ok so now after that "router on stick" thing I can ping and send packets from one VLAN to another, but still have problems to set DHCP and connect DNS server. As I understant I have to configure NAT, but wich interface should be inside - I mean Fa0/1, or as inside interfaces I should configure subinterfaces Fa0/1.10 and Fa0/1.20, Im bit confused at this point :)
     
  7. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    ip helper-address

    That's what you need :)
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless

Share This Page

Loading...