1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Incorrect autocomplete info in Outlook

Discussion in 'Software' started by mcbro, Jul 12, 2010.

  1. mcbro

    mcbro Byte Poster

    136
    0
    23
    Hello

    I have a problem with the auto complete information in Outlook.
    I have a user for example Bob Smith who was orignally setup as Bob Smithe. This was changed on his first day. I made bob.smith his default email and left bob.smithe as an alternative address.

    The problem is auto complete displays the information as Bob Smith <bob.smithe>
    This happens for people who have never sent to him before so it doesnt seem to be an issue with the nk2 file.(also tried deleting the entry in the nk2 file downloading the address book but the problem reappears)

    I have deleted the alternative email so no where does it say bob.smithe in exchange system manager or his AD object.

    Any ideas where the incorrect spelling is being stored?
    Exchange 07, Outlook 03
     
    Certifications: MCITP:EA, CCNA
  2. michael78

    michael78 Terabyte Poster

    2,085
    29
    141
    Sorry if I have misread this but have you tried deleting it from the outlook cache. When you start typing his name in and it appears right click on it to highlight the name and then press delete. This should remove it. As long as you have removed it from Exchange (by the looks of it you have) it should fix it but might still appear in the Outlook cache. To check that email doesn't exist somewhere have you tried emailing it to see if it bounces back then you will be able to see if it's been removed altogether.
     
    Certifications: A+ | Network+ | Security+ | MCP | MCDST | MCTS: Hyper-V | MCTS: AD | MCTS: Exchange 2007 | MCTS: Windows 7 | MCSA: 2003 | ITIL Foundation v3 | CCA: Xenapp 5.0 | MCITP: Enterprise Desktop Administrator on Windows 7 | MCITP: Enterprise Desktop Support Technician on Windows 7
    WIP: Online SAN Overview, VCP in December 2011
  3. michael78

    michael78 Terabyte Poster

    2,085
    29
    141
    Might be set as a secondary email address for him.
     
    Certifications: A+ | Network+ | Security+ | MCP | MCDST | MCTS: Hyper-V | MCTS: AD | MCTS: Exchange 2007 | MCTS: Windows 7 | MCSA: 2003 | ITIL Foundation v3 | CCA: Xenapp 5.0 | MCITP: Enterprise Desktop Administrator on Windows 7 | MCITP: Enterprise Desktop Support Technician on Windows 7
    WIP: Online SAN Overview, VCP in December 2011
  4. mcbro

    mcbro Byte Poster

    136
    0
    23
    Thanks for the reply Slypie.

    The issue isnt with the stored auto complete information as it appears incorrect for users that havent emailed him before.

    I have deleted the second address although i dont get a bounce back.
     
    Certifications: MCITP:EA, CCNA
  5. michael78

    michael78 Terabyte Poster

    2,085
    29
    141
    Do you have more than 1 Exchange server? If so might be it hasn't replicated the change yet.
     
    Certifications: A+ | Network+ | Security+ | MCP | MCDST | MCTS: Hyper-V | MCTS: AD | MCTS: Exchange 2007 | MCTS: Windows 7 | MCSA: 2003 | ITIL Foundation v3 | CCA: Xenapp 5.0 | MCITP: Enterprise Desktop Administrator on Windows 7 | MCITP: Enterprise Desktop Support Technician on Windows 7
    WIP: Online SAN Overview, VCP in December 2011
  6. mcbro

    mcbro Byte Poster

    136
    0
    23
    Nope just the one.
     
    Certifications: MCITP:EA, CCNA
  7. alicat

    alicat Nibble Poster

    77
    1
    17
    Have you tried redownloading the address book? Do your staff work on cached mode?
     
    Certifications: BA, ISEB Software Testing, N+, MCP
    WIP: 70-646
  8. mcbro

    mcbro Byte Poster

    136
    0
    23
    Hi Alicat

    Yes and Yes
     
    Certifications: MCITP:EA, CCNA
  9. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    It's the Outlook Nickname file

    look HERE
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  10. mcbro

    mcbro Byte Poster

    136
    0
    23
    How does that account for the users who have never sent to him, who when i tested it with their account Outlook created a new auto complete entry with the incorrect spelling?!

    I am going to have another look at this tomorrow (hopefully it will magically fix over night):rolleyes:
     
    Certifications: MCITP:EA, CCNA
  11. mcbro

    mcbro Byte Poster

    136
    0
    23
    The issue is the same today.

    Does anyone know where the autocomplete infomation is pulled from?
    Ive double checked the mailbox in Exchange Management Console and it doesnt have the incorrect spelling anywhere!
     
    Certifications: MCITP:EA, CCNA
  12. Fergal1982

    Fergal1982 Petabyte Poster

    4,196
    171
    211
    Have you double checked the AD account? There's a few places (from what I recall) that you had to change:

    1) Search for the user in AD U&C, right click, rename - check the display name, logon name, etc are all correct.
    2) I think there is a tab in the properties form which contains an Exchange Alias - make sure this is also correct.
    3) Check the First, Last, & Display name fields on the account.

    If its also showing for people who have never done it then its likely in one of these places I would say. That said, try creating a brand new user, and see how it displays for them. That will identify if its a user setting, or a setting coming from AD/Exchange.
     
    Certifications: ITIL Foundation; MCTS: Visual Studio Team Foundation Server 2010, Administration
    WIP: None at present
  13. mcbro

    mcbro Byte Poster

    136
    0
    23
    Hi Fergal

    After your reply i double checked everything in Exchange and AD and both had the correct spelling. So i did some further Googling and found this thread http://social.technet.microsoft.com...s/thread/c604eecf-be03-4577-9519-2c7bea80388d.

    Followed the advice edited the Legacy entry in AD and its worked!
     
    Certifications: MCITP:EA, CCNA

Share This Page

Loading...