1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP with sharing!

Discussion in 'Software' started by Jellyman_4eva, Mar 12, 2006.

  1. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    OK,

    I am working on a XP Home machine, just patching it etc and needed access to a folder on it remotely..

    So I went to share it, and this box appears..

    http://www.practicallynetworked.com/sharing/xp/filesharing/filesharing03.gif

    Now I am surprised at this considering its a XP Home and we all know how insecure they are... so I enable sharing and share the folder, however I now cannot get the system back to this "secure" state!!!

    How do I disable remote access!!

    Any ideas?
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  2. simongrahamuk
    Honorary Member

    simongrahamuk Hmmmmmmm?

    6,199
    125
    199
    This any help?

    :blink
     
  3. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    Hi,

    Thanks for the reply but unfortunately not. As I am running XP Home, I cannot disable the Simple File Sharing..

    Nor do I want to, I just want to "disable remote access" again, like it says in the screenshot!

    Basically I need to figure out how sharing a folder changes the system, then reverse it...
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  4. simongrahamuk
    Honorary Member

    simongrahamuk Hmmmmmmm?

    6,199
    125
    199
    Right Click My Computer, Properties, Remote?
     
  5. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    Hi,

    Remote Assistance is not enabled and never has been!!!

    Windows firewall also has not been on the whole time...

    How stupid is this huh!
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  6. _omni_

    _omni_ Megabyte Poster

    647
    10
    62
    so do you want to disable (remote desktop) or (any network access)?

    remote desktop would be through the remote tab of system properties, network access would be through (local) group policy.
     
    Certifications: MCSE 2003, MCSA:M
  7. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    Hi,

    I am fully aware of how to disable remote access so please do not worry about that..

    The basic scenario is I went to share a folder on this machine... obviously nothing had been shared before on it and I was presented with the display of the pic found in my first post...

    If I attempted to use another machine on the same LAN to access the machine via a \\Acer, all I get is a prompt for the username and password (The username greyed out with guest entered - due to the fact its XP Home)... if I enter the correct password for the guest account (Which I changed when I first setup the machine using the "net user guest password" on the command line).. it just keeps returning the login box.. thus denying remote access just like it says in the pic...

    I then share a folder on the machine, not using the wizard, just sharing it, I do my stuff, then I unshare the folder... however the sharing menu does not return to the screen in my first post... and the machine is no longer denying remote access because if I attempt to go to it via another machine on the LAN, I enter the guest credentials and it shows me the printers and scheduled tasks...

    So how do I make it so it denies remote access... I have tried changing the guest password again, and disabling the server service but neither of these have helped...
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  8. _omni_

    _omni_ Megabyte Poster

    647
    10
    62
    disabling the guest account should work. then take a look at the Security Options (Network Access: *) policies.

    dunno if these options are on XP Home though.

    edit: wait, so is the problem that users can access the computer, or do you just want to unshare that particular folder?
     
    Certifications: MCSE 2003, MCSA:M
  9. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    Hi,

    Group Policy is not available to edit in XP Home, neither is disabling the Guest account... (You can disable a local guest login but not a network one)

    Basically when I first set it up, it was mega secure, and now I have shared and then unshared a folder it is less secure because people can actually log into it.. (Yes I know all they can see is Scheduled Tasks and Printers but that is not the point)!

    Do you understand just how frustrating this is!!
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  10. _omni_

    _omni_ Megabyte Poster

    647
    10
    62
    http://support.microsoft.com/kb/300489/
     
    Certifications: MCSE 2003, MCSA:M
  11. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    Surely that screen you posted in the original posting was saying that you haven't set up any networking?

    So to get back to that you need to remove all the networking I would have thought.

    Once networking is setup you get a similar, but different box whenever you try to share something.

    Or have I missed something along the way?

    Edit: I've just noticed that this is part of ICS - so the rules are different there. How about removing ICS althogether and then re-doing it?

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  12. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Have a lok see at this LINKY to see if it is what you are after.
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  13. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    Hey AJ that is also not what I am looking for.. I think I am just going to have to play with it and see if I can reverse it all..

    Omni, I believe that Microsoft statement is vague and misleading...

    "The guest account is disabled on Windows XP" I believe means you cannot login to the machine with it (i.e. In XP Home's case it removes the guest entry from the Welcome screen). Obviously if you login as an Administrator on XP Professional you can use computer management to enable/disable the guest account.. With XP Home to simply get to the Administrator you need to be in Safe Mode... (i.e. you cannot login to the Administrator account in XP Home from a normal startup - basically the Administrator is not available as an entry on the Welcome screen either...)..

    But I believe you can not disable the guest account on an XP Home machine, simply because that is what XP Home uses as its basis for sharing... Maybe I am wrong, I do not have the machine with me to go into safe mode, login as Administrator and disable the Guest account.... I shall get it back and try it and let you know...

    EDIT: Maybe disabling the guest account is the answer

    http://support.microsoft.com/kb/281248/en-us

    And maybe it does come disabled by default (Although I do not remember it doing this) and maybe when I clicked share the folder it simply enables the guest account??
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots
  14. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Ahh My Bad

    Re-read you post and realised you on about XP Home

    sorry mate, if it was Pro the this is the routine:

    • Start the Microsoft Management Console (MMC) Local Security Policy snap-in (Start, Control Panel, Administrative Tools, Local Security Policy).
    • Expand the Local Policies branch.
    • Select Security Options.
    • Double-click "Network access: Sharing and security model for local accounts."
    • Select "Classic - local users authenticate as themselves", and click OK.
    Now share the folder
    • Open up the sharing and security tab (Right-click on the folder to share and select Sharing and Security...).
    • Share the folder over the network (Click on Share this folder)
    • Add users that can gain access to the folder (Click Permissions)
    • To only enable certain users remove everyone.
    • Add specific users (click Add, Advanced, Find Now)
      • to add all users on the computer select Authenticated Users
      • to select multiple users at the same time hold down Ctrl
    • Click OK and then select the amount of access to be granted to each user.
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  15. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    8,871
    167
    256
    Have you removed file and printer sharing and any other unnecessary protocols from your LAN properties? That would help :D

    I don't use XP Home here at home but I would have thought that if you turn the built in firewall on and configure it to include your local area network. You would prevent anyone from connecting to it's resources :rolleyes:
     
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  16. Jellyman_4eva

    Jellyman_4eva Byte Poster

    213
    4
    34
    I went back to this machine running XP Home... and ran

    net user guest /active:no

    And it did return the sharing settings to their original state as per the picture in my first post...

    Thanks to everyone who helped..!
     
    Certifications: MCDST, MCITP-EDST/EDA/EA/SA/ MCSA 2K3/2K8, MCSE+M 2K3/2K8, ISA/TMG, VCP3/4, CCNA, Exchange, SQL, Citrix, A+, N+, L+, Sec+, Ser+, JNCIA-SSL, JNCIS-SSL
    WIP: Lots

Share This Page

Loading...