1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help routing DSL through (2) 2501's serially. Please help me

Discussion in 'Routing & Switching' started by cvg, Dec 11, 2006.

  1. cvg

    cvg New Member

    7
    0
    25
    I have (2) Cisco 2501's and I need some help routing my ADSL dsl connection thru Router-A to Router-B. I have a 1900 switch too. My dsl router connects to Ethernet0 on the 2501-A and I am able to receive an internal ip address. I was able to find the configuration to dhcp from dsl router to Router-A take place.

    Ethernet0 172.16.1.10 YES DHCP up up

    Serial0 unassigned YES manual down down

    Serial1 unassigned YES NVRAM administratively down down



    Here is the configuration I found, however it was for a 2514 instead.



    Current configuration : 1074 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186 207.69.188.185
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache

    interface Ethernet1
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    no ip route-cache
    no ip mroute-cache

    interface Serial0
    no ip address
    no ip route-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip http server
    ip classless
    !
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end



    I tried to jeryrig this config to where the configurations ethernet0 would be my serial0, but no luck there.




    Here are my "sh run"'s for both 2501's

    Router-A

    Current configuration : 989 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterA
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    !

    interface Serial0
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    clock rate 1000000
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    !
    ip http server
    ip classless
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end






    Sh run Router-B

    Current configuration : 766 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterB
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !


    !
    interface Ethernet0
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    no ip route-cache
    !
    interface Serial0
    ip address 192.168.1.2 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    router rip
    network 10.0.0.0
    network 192.168.1.0
    !
    no ip http server
    no ip classless
    !
    !
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    Can you tell me if there is anything you would change? Thanks.
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE
  2. NetEyeBall

    NetEyeBall Kilobyte Poster

    279
    10
    45
    I am going to hook this up this weekend and will post my configs for you.
     
    Certifications: CCNA, A+, N+, MCSE 4.0, CCA
    WIP: CCDA, CCNP, Cisco Firewall
  3. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    cvg,

    Do you have: 1) a DCE serial cable and 2) a DTE serial cable?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  4. cvg

    cvg New Member

    7
    0
    25
    Thanks NetEyeBall, I would appreciate that a lot !

    And yes R.H.Lee, I have all the right cables. Thanks again.
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE
  5. simongrahamuk
    Honorary Member

    simongrahamuk Hmmmmmmm?

    6,199
    125
    199
    Does your DSL Modem run DHCP? I notice that your Router A has DHCP configured on it also. It may be worth setting the DSL router to a static address if this is the case.

    8)
     
  6. cvg

    cvg New Member

    7
    0
    25
    The DSL router run dhcp and cant do static. I noticed when I log into the dsl router that it shows the individual mac addresses of the different interfaces I plug the router into via ethernet along with the lan ip address too.
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE
  7. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    In the configs listed you have no effective routing set up. One router is running rip, but that is useless since the other router has no routing protocol configured. More importantly, there are no static routes configured.

    RouterA needs a default route to the Internet and a static route pointing back to RouterB for 10.0.0.0/24. Also, RouterA does not need to be running DHCP server service. RouterB needs a default route pointing to RouterA. This assumes the two routers have no problem communicating over the serial interfaces. First of all, confirm connectivity between the two routers, than add in the default and static routes. After that, you can experiment with various routing protocols if you want, but at a minimum you will need static routes for connectivity to the Internet.

    Also, there are plenty of small things to clean up in the configs, but first get basic connectivity functioning correctly.

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  8. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    cvg,

    Question:
    1. What are the names for the routers?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  9. cvg

    cvg New Member

    7
    0
    25
    RouterA and RouterB
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE
  10. cvg

    cvg New Member

    7
    0
    25
    Spice_Weasel

    Here is my setup

    Hello

    With this configuration I am able to ping anything I want from the remote computer. I have removed the 1900 switch from the equation and ran a crossover cable from E0 on the receiving router (Router-B) just to rid of any suspiciouns that it may be causing a problem..


    Router-A (This is the router attached to the dsl modem)

    Current configuration : 1096 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterA
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    !
    !
    !
    interface Serial0
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    clock rate 500000
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    transport input all
    line vty 0 4
    login





    Here is Router-B (This is the router that is being routed to from A)


    Current configuration : 763 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterB
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 10.0.0.1 255.255.255.0
    no ip route-cache
    !
    interface Serial0
    ip address 192.168.1.2 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 0.0.0.0 0.0.0.0 Serial0
    !
    !
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end



    Now the Lan Ip address on my DSL router is 172.16.0.254 and it give out ip addresses like 172.16.1.10, 172.16.1.11,172.16.1.12 etc..

    When I tried to put a static route to this ip address 172.16.0.254, I was not able to ping to it, so I took it out. Thanks.
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE
  11. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    cvg,

    Questions:
    1. Is your DSL modem also a DHCP server?
    2. Which serial port of RouterA is connected to which serial port of RouterB?
    3. Which router's serial port is the DCE side of the serial cable connected to?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA
  12. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    cvg, here are some quick changes for your config:

    RouterA:
    int s0
    ip nat inside

    access-list 1 permit 10.0.0.0 0.0.0.255


    remove the existing default routes and replace with:

    ip route 0.0.0.0 0.0.0.0 dhcp

    Above default route will use gateway ip supplied from dhcp server. If that does not work, use:

    ip route 0.0.0.0 0.0.0.0 <ip address of dhcp server>
    (for example, ip route 0.0.0.0 0.0.0.0 172.16.1.1)
    or
    ip route 0.0.0.0 0.0.0.0 e0
    Above route basically says, "Shove packets to unknown destinations out e0"

    Also, add a route pointing back to your internal lan:

    ip route 10.0.0.0 255.255.255.0 192.168.1.2

    RouterB:
    Remove:
    ip route 0.0.0.0 0.0.0.0 Serial0

    That should give you basic connectivity. Your pc on network 10.0.0.0/24 should be able to ping RouterA and reach the Internet. The access-list 1 determines what traffic is nat'ed. For example, from RouterB, type:
    ping 132.246.168.148
    The ping should fail as it will not be nat'ed by routerA
    Type:
    ping 132.246.168.148 sou e0
    And it should succeed as it will be nat'ed.

    Also, you can add the following to RouterB:
    int e0
    ip tcp adjust-mss 1492

    This will ensure the correct mss for tcp sessions.
    If there are still problems post back with more info.

    As I mentioned, there are lots of things to add/change in the config, but get basic connectivity first.


    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  13. cvg

    cvg New Member

    7
    0
    25
    Spice_Weasel

    Thank you so very much for your reply.

    I got an email from an individual who already had an existing configuration. This is what he sent. Except his deal was 2x2514's


    Router A - this is the router that connects to the DSL router via ethernet...


    Current configuration : 1270 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterA
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool insideDHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 207.69.188.186
    !
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface Ethernet0
    description Facing the ISP
    ip address dhcp
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    !
    interface Ethernet1
    no ip address
    no ip route-cache
    !
    interface Serial0
    description Facing my LAN
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    no ip route-cache
    no ip mroute-cache
    clock rate 500000
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    !
    ip nat inside source list 1 interface Ethernet0 overload
    ip http server
    ip classless
    ip route 10.0.0.0 255.0.0.0 Serial0
    !
    !
    access-list 1 remark RFC1918 non-routable address space
    access-list 1 permit 192.168.0.0 0.0.255.255
    access-list 1 permit 172.16.0.0 0.15.255.255
    access-list 1 permit 10.0.0.0 0.255.255.255
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end






    Here is Router-B (This router is connected via Serial0 to Router-A's Serial0 running HDLC not PPP...)



    Current configuration : 726 bytes
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname RouterB
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0
    no ip address
    no ip route-cache
    no ip mroute-cache
    !
    interface Ethernet1
    ip address 10.0.0.1 255.255.255.0
    no ip route-cache
    !
    interface Serial0
    ip address 192.168.1.2 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip route-cache
    shutdown
    !
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    !
    !
    !
    line con 0
    line aux 0
    transport input all
    line vty 0 4
    login


    He also gave me this below and it's for adding more routers via serial interface...


    A)

    router ospf 100
    network 192.168.1.0 0.0.0.255 area 0
    default-information originate always
    !

    B)

    router ospf 100
    network 192.168.1.0 0.0.0.255 area 0
    network 192.168.2.0 0.0.0.255 area 1
    redistribute connected subnets
    !

    C)

    router ospf 100
    network 192.168.2.0 0.0.0.255 area 1
    redistribute connected subnets


    He told me to just follow that format, and if I do decide to, then to leave the existing configuration alone and just implement OSPF. I have tried this with 3 routers using 12.3 and went to add another that was running 12.1 and the 12.1 ios router didn't work. So Ill need to upgrade that one. Thanks again for your help. I appreciate it...
     
    Certifications: A+,Network+, I-net+, MCP
    WIP: CCIE

Share This Page

Loading...