1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forbidden printers

Discussion in 'General Microsoft Certifications' started by Andre, Oct 18, 2004.

  1. Andre

    Andre Nibble Poster

    52
    0
    14
    I have w2000 server with shared printer named Printer1

    on my windows Xp workstation I was trying to acces this printer via http://server_name/printers but I got error stating:
    How can/where can I grant myself acces/rights to the printer?
    On both computers I work as an administrator. In printers security tab I've got: administators, power users and everyone and still I cannot get access ? WHY

    regards
    andre
     
    Certifications: A+
    WIP: 70-270, 70-290, Network+
  2. flex22

    flex22 Gigabyte Poster

    1,679
    0
    69
    I'll have a go at this one I think, eh why not.

    Well you may have admin right on both machines, but so what.
    Your accessing this server via it's share.

    If you have admins, power users, and everyone group in the security tab, these are probably the 'local' admins, power users, and everyone group.

    When you set the permissions on the share, make sure you assign the admin on you windows xp machine access rights to the printer.

    Because the admin on the XP machine probably isn't a domain admin account, it doesn't automatically have rights to all shared resources.

    Anyway I tried :rolleyes:
     
  3. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    could it be because your trying to access a web share?

    try

    \\server_name\printers

    that might be more up your street

    or just goto \\server_name\ and browse to the 'Printers and Faxes' folder (i think its pritners and faxes)

    find printer 1

    right click and hit 'connect'

    that should install the printer onto your xp machine
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  4. Andre

    Andre Nibble Poster

    52
    0
    14
    well that is the problem
    I can connect to the printer using \\server_name\printer_name and I have full rights but I just cannot via http

    and by the way both computers are in workgroup
     
    Certifications: A+
    WIP: 70-270, 70-290, Network+
  5. nugget
    Honorary Member

    nugget Junior toady

    7,796
    71
    224
    Try setting the permissions to Authenticated Users to see if that makes a difference.
     
    Certifications: A+ | Network+ | Security+ | MCP (270,271,272,290,620) | MCDST | MCTS:Vista
    WIP: MCSA, 70-622,680,685
  6. Luton Bee

    Luton Bee Kilobyte Poster

    365
    0
    36
    It's the permissions of the printers virtual website that you need to check. The directory permission on the printers "website" should be set to integrated windows authentication.
     
    Certifications: MCSE, MCSA, MCP, A+, Network+ C&G ICT
    WIP: CCNA
  7. Andre

    Andre Nibble Poster

    52
    0
    14
    nop still doesn't work. In act of desperation I added all available users gave them full rights. i've tried both authentication method (anonymouse access and integrated windows authentication.
    well I've even assigned all users to the printer and to the windows/web/printers directory and guess what - error 403 forbidden

    Any ideas? what is wrong ?
     
    Certifications: A+
    WIP: 70-270, 70-290, Network+
  8. Luton Bee

    Luton Bee Kilobyte Poster

    365
    0
    36
    Are there any other websites on this server? Can you access those? The 403 error points to it being permissions or settings within IIS rather that the printer(s) themselves.



    Er, I think!!!!!!
     
    Certifications: MCSE, MCSA, MCP, A+, Network+ C&G ICT
    WIP: CCNA
  9. Jakamoko
    Honorary Member

    Jakamoko On the move again ...

    9,915
    60
    229
    Initial thoughts were what Phoenix said, but youve obviously tries that. So...

    1.) I dont suppose its an https: url you need ? or specifying a particular port ?

    2.) Has this just been the case since the addition of a service pack ?


    Other than that, will think a bit more on this for you .....:hhhmmm


    EDIT: @Luton - the http:// url is pointing to the web interface on the printer, as opposed to the server isn't it? Or am I shamefully wrong once again ... :oops:
     
    Certifications: MCP, A+, Network+
    WIP: Clarity
  10. Luton Bee

    Luton Bee Kilobyte Poster

    365
    0
    36
    http://servername/printers points to the printers website on a server that has IIS installed and shared printers defined. When you enter this url you should be presented with a list of printers defined on the machine, complete with links to manage, view and install (locally) such printers. The website is created by default and authentication is windows integrated by default, but like any site in IIS can be changed.
     
    Certifications: MCSE, MCSA, MCP, A+, Network+ C&G ICT
    WIP: CCNA
  11. Jakamoko
    Honorary Member

    Jakamoko On the move again ...

    9,915
    60
    229
    My bad, as per usual - sorry Luton, no offence m8 :oops:
     
    Certifications: MCP, A+, Network+
    WIP: Clarity
  12. Andre

    Andre Nibble Poster

    52
    0
    14
    i found the problem, it was build-in XP firewall when I switched it off everything started working

    amazing [​IMG]

    so no how to set it up with firewall on .... hmm let me check

    but that's mabey tomorrow
     
    Certifications: A+
    WIP: 70-270, 70-290, Network+
  13. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    im guessing check port 80
    and look for whatever ports the http based printer goes on

    just out of curiosity
    why do you need the printer accessable via a web server? :)
    its not something i see all too commonly
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  14. Jakamoko
    Honorary Member

    Jakamoko On the move again ...

    9,915
    60
    229
    You could always download ZoneAlarm, thatwill let you configure indivivual ports easily, which as far as I'm aware (not really looked tho) the Windows firewall doesn't allow.

    <prepares to be proved wrong twice in the same post>
     
    Certifications: MCP, A+, Network+
    WIP: Clarity
  15. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Sorry Gav but you can open ports on the XP firewall with SP 2 installed.Double click the firewall icon, click exceptions tab, click add port and tell it which port you want to open :biggrin
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  16. SimonV

    SimonV Petabyte Poster Administrator

    6,616
    149
    228
    You can open posts on SP2's firewall but not sure pre SP2.

    EDIT: AJ got there before me by milliseconds. :biggrin
     
    Certifications: MOS Master 2003, CompTIA A+, MCSA:M, MCSE
    WIP: Keeping CF Alive...
  17. Luton Bee

    Luton Bee Kilobyte Poster

    365
    0
    36
    The pre SP2 firewall only protects you internet (or public) connection not a LAN one.

    For the F/W in SP2 you can use the security centre in control panel to conifgure or GPO's.
     
    Certifications: MCSE, MCSA, MCP, A+, Network+ C&G ICT
    WIP: CCNA
  18. AndyL

    AndyL Nibble Poster

    92
    0
    21
    There are some very brave people in here! People who have the nerve to install XP SP2!!
     
    Certifications: MCSE 2000,2K3,MCSA:M 2000, MCSA 2K3
    WIP: Painting the doorframes.
  19. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    5,726
    175
    221
    Why is that Andy?
    I have run SP2 since Infosec 2004 back in March (i think it was march) and that was a beta
    not a single problem

    also assisted in deploying it to over 500 clients at a secondary school, again not a single problem
    I dont know what the paranoia is about it to be honest
     
    Certifications: MCSE, MCITP, VCP
    WIP: > 0
  20. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Same here Phoenix, I think we will deply SP2 over our network fairly soon, but bit by bit. :biggrin
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................

Share This Page

Loading...