1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EIGRP Issue

Discussion in 'Routing & Switching' started by eric54, Jan 30, 2009.

  1. eric54

    eric54 New Member

    6
    0
    6
    I have set up a home lab running 3 2600 routers and 1 2950 switch. EIGRP is configured on all of the routers and all interfaces are up yet no neighbours have formed. I have run debug and can see that no hello's, ack's etc are being sent. Any suggestions as to why this is?
     
  2. keconnect sparky

    keconnect sparky Nibble Poster

    78
    5
    34
    Have you tested connectivity from router to router to check this is possible first? (i.e just run a ping across each of the end points? ...if the links are serial check you have layer2 connectivity first before troubleshooting at the IP layer). Might just be you have made a typo or fat fingered an IP address or something simple

    Failing that;
    Are each of the routers you want to form a neighbour with in the same AS number?
    Also are any other routing protocols with a better admin distance running on the routers?

    Or Could you paste parts of the config about the networks you want to form neighbours with from the routers?
     
    Certifications: MCP, CCENT, CCNA, CCNA-S
    WIP: CCNP (ROUTE)
  3. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    Yeah, it'd help to see your config.
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  4. eric54

    eric54 New Member

    6
    0
    6
    Thanks for replies. Have pasted configs below. Hope they help

    hostname r2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.1.76 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    ip address 172.17.1.1 255.255.0.0
    encapsulation frame-relay
    no ip mroute-cache
    logging event subif-link-status
    logging event dlci-status-change
    no keepalive
    frame-relay interface-dlci 102
    !
    router eigrp 1
    network 172.17.0.0
    no auto-summary
    !
    no ip http server
    ip classless


    hostname r3
    !
    boot-start-marker
    boot-end-marker
    !
    !
    clock timezone GMT 0
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.77 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 172.16.1.1 255.255.0.0
    encapsulation frame-relay
    no keepalive
    clock rate 128000
    frame-relay interface-dlci 103
    !
    interface BRI0/0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    router eigrp 1
    network 172.16.0.0
    no auto-summary
    !
    no ip http server
    ip classless
     
  5. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    Your Ethernet interfaces aren't participating in EIGRP. Add those networks to your EIGRP instance.
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  6. eric54

    eric54 New Member

    6
    0
    6
    D'oh! Thanks.
     

Share This Page

Loading...