1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Desperate help needed with Cisco 877W

Discussion in 'Hardware' started by cyberdog, Jul 29, 2010.

  1. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    Hi,
    I am trying to configure a Cisco 877W router. I have it connected to a computer and I can access the SDM Express wizard. However I can only get as far as the WAN setup, it then just hangs and will go no further.
    Can anyone help please, I have been trying for weeks now.

    Thanks
    Dave.:(:(:(
     
  2. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    Download Putty from here

    The follow my instructions on from this link click me

    If you do everything apart from using the complete access lists as I specified, use the ones below:

    ip nat inside source list NAT interface Dialer1 overload

    ip access-list extended LANTraffic
    permit ip 192.168.0.0 0.0.0.255 any reflect tcptraffic
    permit ip 192.168.1.0 0.0.0.255 any reflect tcptraffic
    evaluate tcptraffic

    ip access-list extended NAT
    permit ip 192.168.0.0 0.0.0.255 any
    permit ip 192.168.1.0 0.0.0.255 any

    ip access-list extended outside-in
    permit icmp any any
    permit ip any any
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  3. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    Hi craigie,

    Thanks for your assistance. Can we just go back a little. I have a telnet session running and the first thing it has asked is for me to change the username and password.

    The screen shows “ yourname#. After this I have entered “ username <myuser> privilege 15 secret 0 <mypassword>”.

    It comes back with invalid input detected. Am I entering this correctly.
    :oops::oops:
     
  4. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    I made an assumption that you knew how to use the Cisco IOS.

    It is going to be really hard for you to configure it using the CMD without any experience mate.

    To make changes you need to go into configure terminal mode.

    My Router#>config t (Press Enter)

    Then type the following

    username <Type Username> privilege 15 secret <Type Password> (Press Enter)

    You also need to put in place an enable password by typing the following:

    enable secret <Enable Password> (Press Enter)
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  5. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    Hi,

    the screen shows yourname#

    Anything i enter after this is shown asan invalid input.
     
  6. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    Mate, I have told you what to type above. But hear it is again

    My Router#>config t (Press Enter)

    Then type the following

    username <Type Username> privilege 15 secret <Type Password> (Press Enter)

    You also need to put in place an enable password by typing the following:

    enable secret <Enable Password> (Press Enter)
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  7. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    Sounds like it is in an initial config mode.

    at the prompt just type a name as your username and hit enter see if it takes it. Or hit ? and press enter see what the options are.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  8. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    When i type in a username it states
    "unknown command or computer name, or unable to find computer address"

    When i enter ? i get a mult page exec commands list
     
  9. danielno8

    danielno8 Gigabyte Poster

    1,305
    48
    92
    copy and paste the list....to me it seems it's in the right mode if your getting command.....are you sure you typed "conf t" then hit enter, so you got the prompt:

    hostname(config)#
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  10. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    OK,
    From the yourname prompt i have entered <configure> which in the commands list states "enter configuration mode.
    It then asks:

    config from terminal, memory, or network (terminal)
    It then asked Host or network configuration file

    Given that i have the router and computer connected via a cat5 cable, what should i select for these questions.:oops:
     
  11. ChrisH1979

    ChrisH1979 Byte Poster

    225
    9
    37
    press "t"
     
    Certifications: MCITP:SA, MCSA, MCTS:Win 7, Application Infrastructure
    WIP: MCITP:EA
  12. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    OK, it now says enter configuration commands, one per line. End with CNTL/Z. The prompt has also changed to
    yourname(config)#.

    This is going to sound really stupid, but what do I do now.:oops:

    I am going to use it on a B.T. ADSL line, with wireless enabled as the basic config to start with.
     
    Last edited: Jul 30, 2010
  13. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    With the help of an idiots guide from the cisco website, I did the basic config of the router.
    However when I restart the router, I get the “username” prompt but it does not recognise the username and password that I configured in the basic setup.
    Any help please
    :oops:
     
  14. ChrisH1979

    ChrisH1979 Byte Poster

    225
    9
    37
    You will have to google how to reset the password now ;)
     
    Certifications: MCITP:SA, MCSA, MCTS:Win 7, Application Infrastructure
    WIP: MCITP:EA
  15. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    Hi,
    Resetting the password is not a problem. What I can`t understand is why does it not recognise the one I used when I did the basic config using the blue terminal lead.
     
  16. billyr

    billyr Kilobyte Poster

    262
    20
    35
    Did you save your new config before you restarted the device ? If not it will return to the default of username cisco password cisco.

    to save your configs type copy run start.
     
    Certifications: CCNP, CCSI, MCSE W2k/W2k3, MCITP_SA
    WIP: Taking it easy for a while.
  17. cyberdog

    cyberdog Bit Poster

    22
    0
    2
    Oops, er, NO.
    It`s always the small things that cause the most trouble.

    Thanks :ohmy:ohmy
     
  18. lordanderson

    lordanderson New Member

    2
    0
    1
    Hello everyone,
    I am new to cisco devices. I change DLink router with Cisco 877w and it can't connect to the internet

    after configuring it with SDM/Cisco Configuration Assistant. please, i need help urgently. bellow are my internet seeting and my router settings.
    help Plsssssssssssssssssssssssssss

    SETTINGS FROM ISP:
    * ISP name: O2 Broadband

    * Multiplexing method: LLC-Based

    * VPI: 0

    * VCI: 101

    * Username: n/a

    * Password: n/a

    * Static IP: 188.220.69.20

    * Subnet Mask: 255.255.248.0

    * Default Gateway: 188.220.40.1

    * DNS servers: 87.194.255.154
    87.194.255.155

    * NAT: enable

    SETTINGS FROM MY CISCO 877w:

    LORD#sh run
    Building configuration...

    Current configuration : 4717 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname LORD
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200 warnings
    enable secret 5 $1$o8D7$9IfytChh0t3yJUbkq5iDp1
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-45584425
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-45584425
    revocation-check none
    rsakeypair TP-self-signed-45584425
    !
    !
    crypto pki certificate chain TP-self-signed-45584425
    certificate self-signed 01
    3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 34353538 34343235 301E170D 31303038 31373038 34363435
    5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53
    2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D343535 38343432
    3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100D3B8
    B2F9D42F FE2D1865 EE760324 38B03DEA CAB8D9EE B6D4DDED 63589DCE DDFC7055
    C17F6381 1CAD9C70 0BB8C51A F7649294 448887AB 9A9E90ED A7345AD1 602449D4
    CB456F2A 4E4D3135 00931FDE 39EA5C50 B6BB7C75 CFE896C4 68BBB08E 41AC0A14
    73DCCCC9 BDC95534 FDC4FADF 4C659F8D 70CDA905 03314380 CD1F9238 9CC90203
    010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603 551D1104
    1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D 301F0603
    551D2304 18301680 142BA3D9 33302863 A253D15A C9351E50 DA414CE6 9A301D06
    03551D0E 04160414 2BA3D933 302863A2 53D15AC9 351E50DA 414CE69A 300D0609
    2A864886 F70D0101 04050003 8181006E D3A7A65B C8962F67 8BC61B8C 87147ECE
    63AA977C 91C85BF5 DFF1DA8F ACB45C69 7B1F604A DA05C913 91CDECC9 2A9C21FC
    468F84A2 6A339062 C6F25FFE 843D074B FBFD79D3 C72074D1 51288168 E4E0342B
    93E2A857 36D4D2A1 75E97992 72CC9968 1E70812E 0175C445 9A825A90 4F50D2EC
    5B033F9B 61CA442B 89D31E2F BADEBF
    quit
    dot11 syslog
    ip source-route
    !
    !
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2
    !
    !
    ip cef
    no ip domain lookup
    ip domain name lordanderson.com
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    username lord privilege 15 secret 5 $1$Ha6F$NxC/xCQCKDGQZH58k8UhY.
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    bridge irb
    !
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    ip address 188.220.69.20 255.255.248.0
    pvc 0/101
    encapsulation aal5mux ip
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    shutdown
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    54.0
    station-role root
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    no ip address
    ip tcp adjust-mss 1452
    bridge-group 1
    !
    interface Vlan2
    no ip address
    bridge-group 2
    !
    interface Vlan83
    no ip address
    bridge-group 83
    !
    interface Vlan99
    no ip address
    bridge-group 99
    !
    interface BVI1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    ip tcp adjust-mss 1452
    !
    interface BVI2
    no ip address
    !
    interface BVI83
    no ip address
    !
    interface BVI99
    no ip address
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 188.220.40.1
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    bridge 2 protocol ieee
    bridge 2 route ip
    bridge 83 protocol ieee
    bridge 83 route ip
    bridge 99 protocol ieee
    bridge 99 route ip
    banner login ^C
    -----------------------------------------------------------------------

    -----------------------------------------------------------------------
    ^C
    !
    line con 0
    login local
    no modem enable
    speed 19200
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    end

    LORD#
     

Share This Page

Loading...