1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

configuring catalyst 3560G switch problem

Discussion in 'Voice' started by angelinascott, Jul 7, 2008.

  1. angelinascott

    angelinascott New Member

    5
    0
    25
    The 3560 switch is configured as shown below. Note: Interfaces that are not used have been left out.
    Version information is also below.
    My question is why does the show policy-map interface vlan 201 not show any packets ? (output shown below). It is clear that the QoS is working from the show mls qos interface fa0/4 output - also shown below.

    SW2#sh run
    Building configuration...

    Current configuration : 2949 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname SW2
    !
    !
    no aaa new-model
    system mtu routing 1500
    vtp domain CISCO
    vtp mode transparent
    ip subnet-zero
    no ip domain-lookup
    !
    !
    mls qos map policed-dscp 32 to 16
    mls qos map policed-dscp 40 to 32
    mls qos
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    vlan 201-202
    !
    class-map match-all IP_TRAFFIC
    match access-group 100
    class-map match-all INPUT_INTERFACES
    match input-interface FastEthernet0/13 - FastEthernet0/15
    !
    !
    policy-map POLICE_64K
    class INPUT_INTERFACES
    police 64000 8000 exceed-action policed-dscp-transmit
    policy-map POLICE_32k
    class INPUT_INTERFACES
    police 32000 8000 exceed-action policed-dscp-transmit
    policy-map VLAN201_POLICY
    class IP_TRAFFIC
    set precedence 5
    service-policy POLICE_64K
    policy-map VLAN202_POLICY
    class IP_TRAFFIC
    set precedence 4
    service-policy POLICE_32k
    !
    !
    !
    interface FastEthernet0/4
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/13
    switchport trunk encapsulation dot1q
    switchport mode trunk
    mls qos vlan-based
    !
    interface FastEthernet0/14
    switchport trunk encapsulation dot1q
    switchport mode trunk
    mls qos vlan-based
    !
    interface FastEthernet0/15
    switchport trunk encapsulation dot1q
    switchport mode trunk
    mls qos vlan-based
    !
    !
    interface Vlan201
    no ip address
    service-policy input VLAN201_POLICY
    !
    interface Vlan202
    no ip address
    service-policy input VLAN202_POLICY
    !
    ip classless
    ip http server
    ip http secure-server
    !
    !
    access-list 100 permit ip any any
    ----------------------------------
    SW2#sh ver
    Cisco IOS Software, C3560 Software (C3560-ADVIPSERVICESK9-M), Version 12.2(35)SE1, RELEASE SOFTWARE (fc1)
    Copyright © 1986-2006 by Cisco Systems, Inc.
    Compiled Tue 19-Dec-06 10:54 by antonino
    ------------------------------------------

    SW2#sh policy-map int vlan 201
    Vlan201

    Service-policy input: VLAN201_POLICY

    Class-map: IP_TRAFFIC (match-all)
    0 packets, 0 bytes
    offered rate 0 bps, drop rate 0 bps
    Match: access-group 100

    Service-policy : POLICE_64K

    Class-map: INPUT_INTERFACES (match-all)
    0 packets, 0 bytes
    offered rate 0 bps, drop rate 0 bps
    Match: input-interface FastEthernet0/13 - FastEthernet0/15

    Class-map: class-default (match-any)
    0 packets, 0 bytes
    offered rate 0 bps, drop rate 0 bps
    Match: any
    0 packets, 0 bytes
    rate 0 bps

    Class-map: class-default (match-any)
    0 packets, 0 bytes
    offered rate 0 bps, drop rate 0 bps
    Match: any
    0 packets, 0 bytes
    rate 0 bps
    SW2#
    -------------------------------------------
    SW2#sh mls qos interface fa0/4 statistics
    FastEthernet0/4

    dscp: incoming
    -------------------------------

    0 - 4 : 265 0 0 0 0
    5 - 9 : 0 0 0 0 0
    10 - 14 : 0 0 0 0 0
    15 - 19 : 0 94 0 0 0
    20 - 24 : 0 0 0 0 0
    25 - 29 : 0 0 0 0 0
    30 - 34 : 0 0 186 0 0
    35 - 39 : 0 0 0 0 0
    40 - 44 : 219 0 0 0 0
    45 - 49 : 0 0 0 0 0
    50 - 54 : 0 0 0 0 0
    55 - 59 : 0 0 0 0 0
    60 - 64 : 0 0 0 0
    dscp: outgoing
    -------------------------------

    0 - 4 : 265 0 0 0 0
    5 - 9 : 0 0 0 0 0
    10 - 14 : 0 0 0 0 0
    15 - 19 : 0 94 0 0 0
    20 - 24 : 0 0 0 0 0
    25 - 29 : 0 0 0 0 0
    30 - 34 : 0 0 186 0 0
    35 - 39 : 0 0 0 0 0
    40 - 44 : 219 0 0 0 0
    45 - 49 : 0 0 0 0 0
    50 - 54 : 0 0 0 0 0
    55 - 59 : 0 0 0 0 0
    60 - 64 : 0 0 0 0
     
    Certifications: CCVP
    WIP: CCIE Voice Labs
  2. FS Lisa

    FS Lisa New Member

    1
    0
    1
    Hi angelinascott,

    I came across a similar issue recently myself on a 3560.

    The 3560 reference guide says that show policy-map interface cannot be relied upon to show the stats

    http://www.cisco.com/en/US/docs/swi...ase/12.2_20_se/configuration/guide/swqos.html

    Table 31-15:
    show policy-map [policy-map-name [class class-map-name]]

    Display QoS policy maps, which define classification criteria for incoming traffic.
    Note Do not use the show policy-map interface privileged EXEC command to display classification information for incoming traffic. The interface keyword is not supported, and the statistics shown in the display should be ignored.

    Like you I used the show mls qos interface statistics.
     

Share This Page

Loading...