1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CIPC registers but won't associate -dn's

Discussion in 'Voice' started by Septima77, Mar 12, 2009.

  1. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    My Cisco IP Communicator auto-registers with the CME but 2 things are not right:
    1 After registration show ephone indicates the CIPC is an unknown phone and
    2 The programmed ephone-dn's will not associate with the phone and no numbers are showing next to the line buttons.

    Here is my configuration:
    2611xm>en
    Password:
    2611xm#sh run
    Building configuration...

    Current configuration : 1936 bytes
    !
    ! No configuration change since last restart
    !
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 2611xm
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    !
    ip dhcp excluded-address 192.168.1.1 192.168.1.50
    !
    ip dhcp pool VOICE
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.2
    dns-server 4.2.2.2
    option 150 ip 192.168.1.2
    !
    ip audit notify log
    ip audit po max-events 100
    ip ssh break-string
    no ftp-server write-enable
    !
    no crypto isakmp enable
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.0
    speed auto
    full-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    ip address 192.168.2.1 255.255.255.0
    speed auto
    full-duplex
    !
    ip classless
    !
    ip http server
    no ip http secure-server
    !
    control-plane
    !
    telephony-service
    max-ephones 3
    max-dn 5
    ip source-address 192.168.1.2 port 2000
    create cnf-files version-stamp 7960 Mar 01 2002 05:59:33
    max-conferences 4
    !
    ephone-dn 1
    number 1001
    !
    ephone-dn 2
    number 1002
    !
    ephone-dn 3
    number 1003
    !
    ephone-dn 4
    number 1004
    !
    ephone 1
    mac-address 0021.8510.255B
    button 1:1 2:2 3:3 4:4
    pin 0000

    !
    alias exec s show ip interface brief
    !
    line con 0
    password cisco
    logging synchronous
    line aux 0
    line vty 0 4
    password cisco
    logging synchronous
    login
    !
    ntp master
    ntp server 193.79.237.14
    ntp server 193.67.79.202
    !
    end
    2611xm#
    2611xm#
    00:10:03: %IPPHONE-6-REG_ALARM: 25: Name=SEP00218510255B Load= 2.0.1.1 Last=Init
    ialized
    00:10:03: %IPPHONE-6-REGISTER: ephone-1:SEP00218510255B IP:192.168.1.51 Socket:1
    DeviceType:Phone has registered.

    2611xm#sh ephone

    ephone-1 Mac:0021.8510.255B TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:192.168.1.51 1034 Unknown 30016 keepalive 2 max_line 0

    2611xm#

    What am I not doing right?
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  2. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    My Network Module NM-2V is faulty; I suspect that is causing my problems.
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  3. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Okay, finally made some progress in a simple task: configuring CME and registering the CIPC.

    Reason why it would not work before is incompatible IOS en CIPC versions. I have changed my IOS to a 12.4 version and CIPC version 2.1. The 12.3 version I used before does not feature ephone type CIPC.

    My setup: C2611xm router with 128MB DRAM and 32MB flash. PC Window XP (32bit).
    PC is connected to the router with a crossover cable to Fa0/0 (ip 192.168.1.2 /24).
    Since the minimum recommended flash size is 64MB I had to improvise: used SolarWinds TFTP server on the same PC where I installed CIPC.

    Extracted all necessary files to the Root Folder of the TFTP server. Flat directory, no folders used.
    Then I used the telephony-services setup feature to configure. Option 150 set to 192.168.1.51 (=my pc)

    After creating the cnf-files I had a look at my tftp-bindings:
    Router#show telephony-service tftp-bindings
    tftp-server system:/its/SEPDEFAULT.cnf
    tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
    tftp-server system:/its/XMLDefault.cnf.xml alias XMLDefault.cnf.xml
    tftp-server system:/its/ATADefault.cnf.xml
    tftp-server system:/its/XMLDefaultCIPC.cnf.xml alias SEP00218510255B.cnf.xml
    tftp-server system:/its/netherlands/7960-tones.xml alias Netherlands/7960-tones.xml
    tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml
    tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml
    tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml
    tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml

    and copied the following files from DRAM to flash and TFTP (since I am not using the router as a TFTP server)

    Router#copy system:/its/SEPDEFAULT.cnf flash
    Router#copy system:/its/XMLDefault.cnf.xml flash
    Router#copy system:/its/XMLDefaultCIPC.cnf.xml flash
    Router#copy system:/its/XMLDefaultCIPC.cnf.xml tftp
    Address or name of remote host []? 192.168.1.51
    Destination filename [XMLDefaultCIPC.cnf.xml]?
    .!!
    854 bytes copied in 3.016 secs (283 bytes/sec)
    Router#copy system:/its/SEPDEFAULT.cnf tftp
    Address or name of remote host []? 192.168.1.51
    Destination filename [SEPDEFAULT.cnf]?
    !!
    59 bytes copied in 0.012 secs (4917 bytes/sec)
    Router#copy system:/its/XMLDefault.cnf.xml tftp
    Address or name of remote host []? 192.168.1.51
    Destination filename [XMLDefault.cnf.xml]?
    Router#sh run | s ephone
    max-ephones 5
    ephone-dn 1 dual-line
    number 1001
    ephone-dn 2 dual-line
    number 1002
    ephone-dn 3 dual-line
    number 1003
    ephone-dn 4 dual-line
    number 1004
    ephone-dn 5 dual-line
    number 1005
    ephone 1
    mac-address 0021.8510.255B
    type CIPC
    button 1:1 2:2 3:3 4:4 5:5
    ephone 2
    ephone 3
    ephone 4
    ephone 5

    Started CIPC and it immediately registered and associated the lines and button. Sweet.

    Since I extracted the desktop and ring files to the root folder of the TFTP server I can also change the background and ring tones settings in the CIPC. (and added the CTU24 ringtone just for fun 8))

    I have ordered a new NM-2V module (+2FXS + 2FXO) from the UK and hope to make my first calls somewhere next week.
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP

Share This Page

Loading...