1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't see other PC in wireless network.

Discussion in 'Networks' started by mattgrey, Oct 29, 2006.

  1. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    Hardware:

    Laptop using Linksys PCMCIA wireless adaptor. Running Windows XP Home SP2

    PC, with USB wireless adaptor running Windows XP home SP2

    Linksys wireless router WAG354G connected to internet.

    Setup:

    Both PC and Laptop are wirelessly connected to router and can access internet OK.

    Both have Bullguard V7 installed.

    Both have Windows firewall disabled.

    Problem.

    On both PC and Laptop I have gone through network wizard and setup and a network to share various folders. However neither computer can see the other. Under network my network places on both computers there is nothing.

    I have disabled bullguard and reboot both computers to no avail.

    Both are set on the same workgroup name.

    On each there a shared folders, namely my documents and an entire drive on the desktop.

    HELP!:rolleyes: Probably something very simple causing this but I can't find it. Have googled around and just references to turn off firewalls, run winzard etc etc...

    Any ideas really appreciated.
     
    Certifications: none yet!
    WIP: A+
  2. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Can you ping the PC by I.P and name when using the laptop?

    Also when you are on the laptop goto start>run and type
    \\<pc name> (change the name for the actual name of your PC).

    Do you get a prompt for a username and password?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  3. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    OK, from the laptop cmd prompt.

    ping 192.168.1.66
    request timed out
    request timed out

    \\desktop

    gives a syntax error, guess I am typing something wrong here:rolleyes: ?
     
    Certifications: none yet!
    WIP: A+
  4. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    apologies..

    \\desktop at the cmd gives 'the network location cannot be reached'
     
    Certifications: none yet!
    WIP: A+
  5. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Ok, if you cant ping the desktop then that is a problem. If both can get on the internet then it looks like they are on the same subnet else the router\gateway would not work. Can you run an ipconfig /all on both machines and post here?

    Also try tracert 192.168.1.66 on the laptop, where does the trace bomb out? 8)
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  6. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    From the laptop



    C:\>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : LAPTOP
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : domain_not_set.invalid

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
    rnet NIC
    Physical Address. . . . . . . . . : 00-0A-E4-56-DD-18

    Ethernet adapter Wireless Network Connection 3:

    Connection-specific DNS Suffix . : domain_not_set.invalid
    Description . . . . . . . . . . . : Wireless-G Notebook Adapter v.5.0
    Physical Address. . . . . . . . . : 00-14-BF-D8-1E-5A
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.64
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Disabled
    Lease Obtained. . . . . . . . . . : 29 October 2006 12:07:52
    Lease Expires . . . . . . . . . . : 30 October 2006 12:07:52

    C:\>
     
    Certifications: none yet!
    WIP: A+
  7. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    From the PC



    C:\>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : DESKTOP
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : domain_not_set.invalid

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : domain_not_set.invalid
    Description . . . . . . . . . . . : RT73 USB Wireless LAN Card
    Physical Address. . . . . . . . . : 00-0E-2E-88-B1-1B
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.66
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    Lease Obtained. . . . . . . . . . : 29 October 2006 12:01:57
    Lease Expires . . . . . . . . . . : 30 October 2006 12:01:57

    C:\>
     
    Certifications: none yet!
    WIP: A+
  8. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    tracert still running, so far timed out on all attempts


    edit, now finished, all timed out
     
    Certifications: none yet!
    WIP: A+
  9. Weemez

    Weemez Kilobyte Poster

    372
    1
    0
    I really dont know too much but is

    "Client for microsoft networks" ticked in the network properties?

    Apologies if im stating the obvious its just that was my mistake when i did this!:oops:
     
    Certifications: HNC Computing A+ N+ ICND1
    WIP: ICND2
  10. mattgrey

    mattgrey Nibble Poster

    74
    0
    0

    Yeah, it is ticked. No need to apologise, I'm sure it is something obvious, I just can't find what!
     
    Certifications: none yet!
    WIP: A+
  11. Weemez

    Weemez Kilobyte Poster

    372
    1
    0
    Think this may be what you have already mentioned but have you gone into

    my computer:

    right-click C: drive and allowed sharing?
     
    Certifications: HNC Computing A+ N+ ICND1
    WIP: ICND2
  12. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    I take it the the Linksys router is the DHCP source?

    Is it possible to type route print at the command line on the laptop and post it here?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  13. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    On the PC I have enabled sharing on D:, this is the drive I want to be avaliable. It shows it as a shared drive, but still cannot see it from the laptop.
     
    Certifications: none yet!
    WIP: A+
  14. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    Not too sure about the terminology, but if I am following you here....I intend that all data goes between the 2 computers via the router, not direct between the two?




    C:\>route print
    ===========================================================================
    Interface List
    0x1 ........................... MS TCP Loopback interface
    0x2 ...00 0a e4 56 dd 18 ...... Realtek RTL8139 Family PCI Fast Ethernet NIC - P
    acket Scheduler Miniport
    0x3 ...00 14 bf d8 1e 5a ...... Wireless-G Notebook Adapter v.5.0 - Packet Sched
    uler Miniport
    ===========================================================================
    ===========================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric
    0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.64 25
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    192.168.1.0 255.255.255.0 192.168.1.64 192.168.1.64 40
    192.168.1.64 255.255.255.255 127.0.0.1 127.0.0.1 40
    192.168.1.255 255.255.255.255 192.168.1.64 192.168.1.64 40
    224.0.0.0 240.0.0.0 192.168.1.64 192.168.1.64 40
    255.255.255.255 255.255.255.255 192.168.1.64 2 1
    255.255.255.255 255.255.255.255 192.168.1.64 192.168.1.64 1
    Default Gateway: 192.168.1.1
    ===========================================================================
    Persistent Routes:
    None

    C:\>
     
    Certifications: none yet!
    WIP: A+
  15. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Yeah, you are on the right track

    You need to configure I.P routing....

    Edit: I just checked my server and it has I.P routing enabled (you can see you dont have this enabled in your ipconfig /all), is there an option for this in the Linksys box?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  16. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    Presumably this is a workgroup, not a domain?

    Why have you disabled NetBIOS over TCP/IP? Its a fallacy that you have to disable NetBIOS over TCP/IP because its a security risk - certainly you should do this if the NIC concerned is directly connected to the Internet, but sitting behind (what I presume) is a NAT router, this isn't necessary. Without NetBIOS over TCP/IP, network neighbourhood won't work. Try enabling this in the properties of your NIC.

    Also, try connecting to the default admin share of the drive concerned (\\DESKTOP\D$)
     
    Certifications: A few
    WIP: None - f*** 'em
  17. mattgrey

    mattgrey Nibble Poster

    74
    0
    0
    rrrrrrrriiight:oops: :rolleyes:



    ermm, huh...configure IP routing....sounds like one for google:D !
     
    Certifications: none yet!
    WIP: A+
  18. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    LOL!

    Not at all mate, its nice and simple.

    Go into the properties of the network card, double-click the entry named 'Internet Protocol (TCP/IP)', click the 'Advanced' button, then under the tab marked 'WINS', check the 'Enable NetBIOS over TCP/IP' box.

    WARNING - NEVER, EVER do this on a NIC that is directly connected to the internet. NEVER!
     
    Certifications: A few
    WIP: None - f*** 'em
  19. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    As Zeb has pointed out the folowing part of the ipconfig /all is causing the problem.

    NetBIOS over Tcpip. . . . . . . . : Disabled
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  20. Weemez

    Weemez Kilobyte Poster

    372
    1
    0
    Can i ask guys is this because NetBIOS can track other computers by name as opposed to IP?

    Just to confirm why this is done.

    Thanks
     
    Certifications: HNC Computing A+ N+ ICND1
    WIP: ICND2

Share This Page

Loading...