CertForums.com IT Certification Forum Homepage
Results 1 to 7 of 7

water cooled system - pump stopped working

You are viewing a topic in the Hardware forum part of the Computing Support Forums category.

  • Share:
  1. #1
    Byte Poster Rachael_B's Avatar
    Posts
    65
    Join Date
    12 May 2008
    Age
    31
    Liked
    0 times
    Rep Power
    5

    water cooled system - pump stopped working

    InfoSec and IT Certification Training All Access
    Hello

    I'm posting this on behalf of a friend so apologies if this a bit vague.

    A quick question really, he has a water cooled system (doesnt know the make) and he has said its stopped pumping the water round so the temp of the pc gets too high and it shuts down. Hes not sure if its the generator or the pump - Is there anyway of testing this to determine which is causing the problem? I'm not familiar with water cooling so any advice would be much appreciated.

    Thanks

    Rachael

  2. Posts
    666
    Join Date
    6 June 2003
    Location
    Somewhere in Germany
     

  3. #2
    Terabyte Poster grim's Avatar
    Posts
    1,345
    Join Date
    23 Jul 2007
    Location
    Herts
    Liked
    0 times
    Rep Power
    13
    generator ?

    for starters you should be able to feel and hear the pump going, you might even see tiny bubbles circulating.

    also check the waterblock is still attached correctly and not come loose

    Grim

  4. #3
    Terabyte Poster twizzle's Avatar
    Posts
    1,829
    Join Date
    16 Jan 2006
    Location
    norfolk
    Country
    UK Country Flag
    Age
    40
    Liked
    1 times
    Rep Power
    22
    It depends on the type of pump. Is it inside the reservoir or is it fitted seperate? If its a seperate pump you should be able to drain th esystem and then remove the pump and test it in the sink. Be careful when doing this as it does need to be connected to a 12v supply and electric and water dont mix well.

    If its in the reservoir then you will need to see if you can feel any vibration from the pump. Another option would be to add a very small amount of food dye to the water and see if it gets pumped around.

    I take it there is water still in teh system and he hasn't just run out?

  5. #4
    Byte Poster Rachael_B's Avatar
    Posts
    65
    Join Date
    12 May 2008
    Age
    31
    Liked
    0 times
    Rep Power
    5
    Hello and thanks for the responses

    Yep there is still water in the system. He said what the pump (fitted seperate) is still vibrating a little (he doesnt know if its vibrating any more or less than it was before) but there is now a slight high pitched whine that wasnt there before. The water isnt being move around at all.

    Is it likely the pump is needs to be replaced?

    Thanks

    Rachael

  6. #5
    Moderator Bluerinse's Avatar
    Posts
    9,415
    Join Date
    29 Jun 2003
    Location
    The Gold Coast, QLD Australia
    Country
    Australia Country Flag
    Liked
    7 times
    Rep Power
    77
    If it's vibrating, it's getting power.

    Yes, it would seem the pump has failed.

  7. #6
    Terabyte Poster twizzle's Avatar
    Posts
    1,829
    Join Date
    16 Jan 2006
    Location
    norfolk
    Country
    UK Country Flag
    Age
    40
    Liked
    1 times
    Rep Power
    22
    Can he not fit a flow indicator into the system? I know i would if i had a water cooled PC. most WC kits have them nowadays. That way he would know if waters being pumped. I still say take it out and try it.

  8. #7
    Terabyte Poster grim's Avatar
    Posts
    1,345
    Join Date
    23 Jul 2007
    Location
    Herts
    Liked
    0 times
    Rep Power
    13
    check for blockages and kinks in the tubing

    when you say theres water in the system, it should all be water. is there any air bubbles bigger than tiny little froth bubbles ?

    Grim

Similar Threads

  1. System hangs
    By nugget in forum Hardware
    Replies: 19
    Last Post: 06-May-2008, 06:11 PM
  2. HELP! New System Overheating!
    By Neil in forum Hardware
    Replies: 56
    Last Post: 30-Nov-2007, 11:10 PM
  3. Synaptics Keypad stopped working
    By Boycie in forum Software
    Replies: 12
    Last Post: 16-Apr-2007, 04:54 PM
  4. System Restore Not Working
    By Tyler D in forum Software
    Replies: 8
    Last Post: 14-Jan-2007, 09:38 PM