1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows 7 RC1 Internet problems!

Discussion in 'Software' started by philbenson, May 18, 2009.

  1. philbenson

    philbenson Byte Poster

    Well there was me just a few days ago about to write a glowing report about Windows 7 RC1 (build 7100). I was on the brink of commenting how encouraging it is to see a pre-release version of Windows already apparently superior to the product it is succeeding.

    But then it happened. While working on my PC last Saturday I noticed that there was a yellow triangle with dreaded black ! sign stamped over the Network icon in the system tray. Sure enough, no Internet. For the sake of brevity I have since tried all the usual lines of diagnosis that you would normally try for such a problem but without success. The Network diagnostic tool reports it is a problem with the DNS server. I interpreted this as it couldn't communicate with my router but PINGing the routers IP address returned four packets instantly.

    I did set a manual IP configuration but Windows then returned an error that DHCP was not enabled. By re-enabling DHCP I did seem to get the Internet back for that session but after the PC was rebooted the problem came back.

    Anyone got any idea apart from re-installing Windows?
    Certifications: MCP, MCP+I, MCSE, MCSA, MCTS
    WIP: CCNA(?)
  2. zebulebu

    zebulebu Terabyte Poster

    What does IPConfig say? What are you using as a DNS server? Is this wireless or wired? Have you got a firewall running anywhere between the machine and your DNS server?
    Certifications: A few
    WIP: None - f*** 'em
  3. philbenson

    philbenson Byte Poster

    IPconfig gives me the right info (IP, SM, no DG and as my DNS server).

    The router is a Netgear wireless ADSL router with normal connectivity features. My other PC and laptop are receiving the Internet fine wirelessly. My Windows 7 test PC is connected via copper but I can PING the router fine.

    I tried switching the Windows firewall off but this made no difference. There are no other firewalls or packet filters being used. When I first installed W7 just over a week ago the Internet worked fine, it is only just over the weekend that these problems have developed.

    I have also tried configuring IP info manually and entering a DG as the router IP address but this did nothing either. I know nothing is guaranteed to work seamlessly with pre-release software and so I'm just curious to know if anyone else trialling this version of Windows has had any similar experiences.
    Certifications: MCP, MCP+I, MCSE, MCSA, MCTS
    WIP: CCNA(?)
  4. danielno8

    danielno8 Gigabyte Poster

    why would you not need a DG?

    can you access the routers config page?
    Certifications: CCENT, CCNA
  5. ThomasMc

    ThomasMc Gigabyte Poster

    Have you tried the Diagnose button on your LAN Status dialog box
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  6. dales

    dales Terabyte Poster

    Yes Im abit confused at the no DG as well, what about trying to set yours dns in the router to opendns servers just to rule out isp dns funkyness
    Certifications: vExpert 2014+2015+2016,VCP-DT,CCE-V, CCE-AD, CCP-AD, CCEE, CCAA XenApp, CCA Netscaler, XenApp 6.5, XenDesktop 5 & Xenserver 6,VCP3+5,VTSP,MCSA MCDST MCP A+ ITIL F
    WIP: Nothing
  7. hugorilho

    hugorilho Byte Poster

    I'm having Internet problems as well. Windows 7 (installed on a VM) does not install the VM Workstation virtual NIC driver. i've tryed some suggestions on this forums such as adding a new network adapter but nothing worked. Anyone experiencing the same thing?
    Certifications: MCDST
  8. Theprof

    Theprof Petabyte Poster Premium Member

    That's interesting... I haven't seen any problems with the internet on windows 7 since I installed it on May 5th.... maybe something to do with the TCP/IP stack?
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
  9. ThomasMc

    ThomasMc Gigabyte Poster

    Wasn't there a problem in vista where IPv6 would screw your net a little too
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)
  10. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    Hmmm, haven't tried it yet but considering all was working well, with the same settings previously. it would seem that any action you take now, ie using opendns servers, is going to be a workaround.

    it would be interesting to know if system restore resolves the connectivity issue, and if so.. if you look at the IPCONFIG.. would there be any difference? my guess is no. this is a bug or a virus :eek:
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  11. philbenson

    philbenson Byte Poster

    I re-installed W7 last night and now everything seems to be working fine (for now at least). So maybe it was a virus or maybe it was just some corruption within the internal workings of Windows.

    These sort of things are what makes IT fun though I guess.
    Certifications: MCP, MCP+I, MCSE, MCSA, MCTS
    WIP: CCNA(?)

Share This Page