Video Card Diagnostic Software?

Discussion in 'Hardware' started by Hello World, May 30, 2005.

  1. Hello World

    Hello World Nibble Poster

    Im almost certain my video card has gone fubar, at least thats what im hoping since its the cheapest part =p, my system decided to screw up totally a few days ago and i couldnt even get the damn thing to boot up, i had to install my OS again to fix it, and even then the install failed about 20 times before i got lucky and it managed to install before it crashed.

    Really this came at a bad time, ill go into detail about what happend in a sec if anyones interested. However the point is now i need some way to test my video card to make sure thats what the problem is, i dont have any ESD stuff here and ive never worked on a laptop, much less my own one so im not gonna go down that route unless i absolutely HAVE to. Anyways i tried the old DirectX stuff, that had no errors, but i need a more intensive test to check if theres anything wrong with my vid card... anyone know if theres any software for that about? Id like to test all the basic stuff before having to take the cover off.

    No IRQ conflicts, pretty certain DMA is the same (ive got an IR port and a Printer port overlapping, but i never use either so who knows).

    If anyones got any software stuffs for testing vid cards let me know please, its just a crappy Geforce4 440 Go 64mb.

    The thing is this couldnt have came at a worst possible time, money is tight as hell what with my college stuff being paid for, i have a huge concert i gotta take my girlfriend to too also which is bleeding me dry, i worked out i'll have less then a tenner that i dont HAVE to spend a month till this is over. So yeah, this is mega bad timing for me, also i got that broadband being fitted in a few days which pumps up the cash a few more quid a month. Gawd this sux, i figured maybe here people would be able to help, ill make a seperate post about what happend in a second.

    EDIT (J): Moved to H/W Forum.
    WIP: CCNA 1, IT Essentials 1(A+)
  2. Hello World

    Hello World Nibble Poster

    Ok here goes.


    A few days ago i was messing around with some online games, nothing graphics intensive at all. Half way through a game i get some really bad lag, i figure its my connection or the hosts and ignore it, eventually i leave the game and host one of my own just to see if its the same... I cant recall if it was or not since a few seconds in i get a blue screen crash telling me stuff that dissapears before i get to read it.

    So then everything starts up again, POST runs, just as the systems looking for boot devices and before winxp is loaded i get another crash... seems kinda strange but i restart and try again... same thing a few times in a row. I figure ill try and repair my OS install incase its that, i flip the boot order over to CD first and try again, windows gets repaired fine (winxp pro) and everything works kinda, however i figure ill do a complete OS install in the morning due to all the crap i got on there.

    So in the morning i load up windows CD... fresh install, it gets half way through the final stage (registering devices iirc) and decides to crash... so now im screwed, i cant boot in safe mode because it tells me "setup cannot be run in safe mode" and everytime i try and install windows it crashes at one stage or another, eventually i start getting superstitous (im really tired by now) and i figure if i dont touch anything at all and close my eyes it'll work... so i do that, i unplug the mouse and leave the room... when i come back its working, so i put the info in and alls fine. Eventually windows boots and loads, problem is now if i try any games (GTA3 iirc) they crash in a blue screen and the loading of the windows OS takes a while before it laods up... windows dosnt even ask me to send an error report.

    Im totally confused by this, all the error messages i got were different... one said make sure your drivers are up to date, another said contact manufacturer, another said see if bios is up to date, another said check memory ... seems random the error code i got in the blue screens.

    Anyone got any advice?

    I dont really wanna pop the cover off of this notebook as ive never actually done it before and i got no ESD stuff here, knowing my luck lately a bolt of lightning or something would come through the window and zap it the second i opened the case.

    Other then general maintanance and replacing parts i got no idea.

    I wanna try software solutions first if anyone has any, if im lucky it might just be the video card and a bunch of things just need to be pushed in correctly and cleaned a bit.
    WIP: CCNA 1, IT Essentials 1(A+)
  3. nugget
    Honorary Member

    nugget Junior toady

    You might want to try running a little program called memtest to check your memory.

    I haven't used this program but it looks like it might help a bit (or the lite version).
    Certifications: A+ | Network+ | Security+ | MCP (270,271,272,290,620) | MCDST | MCTS:Vista
    WIP: MCSA, 70-622,680,685
  4. Hello World

    Hello World Nibble Poster

    Weird how you mentioned that, i was buring the Memtest86 iso onto a disk as i made the 1st post and was coming back to tell the results..

    Memtest kept stopping on test number 7 with a crash, the test was the random number pattern test i believe. Each time a little while in led to a crash.

    I was really really doubtfull this was a memory issue, memory is supposed to be reliable =/, christ this is gonna be expensive to replace if this is the problem.

    Oh that other thingy, TT-lite needs you to DL onto a floppy, all i got is a CD drive on this thing, so no joy there.
    WIP: CCNA 1, IT Essentials 1(A+)
  5. Hello World

    Hello World Nibble Poster

    Hmm just an update, i got a ton of crashes followed by everything going fubar last night, so i messed around and re-enabled APIC?? mode and Hyperthreading, after that it loaded but everything decided to show as error code 12? i think it was 12... said that there arent enough resources to use this device, disable some stuff ecetera...

    Thing is bios still shows up my two 200 pin SODIMM PC2100 512MB DDR's, it seems to shift problem from one to the other like crazy, since its a notebook i dont fancy taking it apart to be honest, i got no idea how you control ESD on those things, just for the hell of it i tried a low level format of my PC using killdisk and reinstalled the OS 20 mins ago (the install went smooth but windows was a little jerky) ive gone out now and left the damned device drivers to auto install themselves.

    I really dont have any idea exactly what it could be ...

    1). Ram screwed?
    2). CPU Overheating?
    3). Motherboard had it?
    4). Vid card gone bye bye?

    If im lucky it might even be something silly like RAM not pushed all the way down, ideally id like to give the whole system a good clean out, wash all connectors and even the heatsink and fan... still it comes down to the ESD, laptops scare me... evil bloody things.
    WIP: CCNA 1, IT Essentials 1(A+)
  6. Phoenix
    Honorary Member

    Phoenix 53656e696f7220 4d6f64

    ok by the fact this is a GeForce Go and SODIMMS im assuming this is a laptop, in which case it wont be the cheapest part to repalce, as most laptops have thier graphics processors integrated to the mainboard eek
    you want to hope its the memory
    which it seems to be

    try removing one SODIMM at a time and trying it with just one at a time
    especially if memtest is crashing :)
    Certifications: MCSE, MCITP, VCP
    WIP: > 0

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.