VERY annoying problem in vSphere 5 - hardware status tab

Discussion in 'Virtual and Cloud Computing' started by Mikeyboy, Mar 21, 2012.

  1. Mikeyboy

    Mikeyboy Kilobyte Poster

    279
    2
    32
    Morning folks,

    Recently come across a minor (but VERY annoying) issue in my vsphere 5 setup - the hardware status tab, when I am logged into vcenter, does not show any information, just comes up with an error "The query service is not available" or words to that effect. However when I log in to each server separately, the hardware status shows up just fine, I can see each sensor status.
    I have researched this quite thoroughly, and most issues seem to be either permissions related (not applicable as the only user I log into vcenter with is the local admin account), or name-resolution related, but I have updated any names in vcenter to IP address only, added an entry in HOSTS file on the vcenter server itself, and a few other suggestions - none of which have worked.
    I am pretty sure it did work previously, but can't remember 100% if it was.
    So, any suggestions? The one suggested fix I couldn't do, was relating to ADAM ADSI edit, apparently there may be something in there relating to name rather than IP or something. But, tried to install ADAM, didnt really know what I was doing, so couldn't start the ADSI edit.

    Help, its really annoying!!
     
    Certifications: VCP,MCSA, MCP, MCDST, MCITP, MCTS, A+, N+
  2. SimonD

    SimonD Terabyte Poster Moderator

    3,668
    427
    199
    I did a post about this about a year ago, have a look at Hardware Status not displaying on vSphere Client – Fix « Everything Virtual for some pointers.
     
    Certifications: CNA | CNE | CCNA | MCP | MCP+I | MCSE NT4 | MCSA 2003 | Security+ | MCSA:S 2003 | MCSE:S 2003 | MCTS:SCCM 2007 | MCTS:Win 7 | MCITP:EDA7 | MCITP:SA | MCITP:EA | MCTS:Hyper-V | VCP 4 | ITIL v3 Foundation | VCP 5 DCV | VCP 5 Cloud | VCP6 NV | VCP6 DCV | VCAP 5.5 DCA
    WIP: VCP6-CMA, VCAP-DCD and Linux + (and possibly VCIX-NV).
  3. Mikeyboy

    Mikeyboy Kilobyte Poster

    279
    2
    32
    Hi Simon,

    Have tried this... to no avail - once i got into ADSI Edit, i notice i have two instances of vcenter, which i think might be part of the problem, not sure how this has come about... there are two instances of VIMWEBSVC, one under each, and one is pointing to name:10443, which seems to be appearing in the logs, and the other is pointing to IPaddress:8443 - so which is it! :eek: will try and show what i mean.

    am also getting entries such as this in my vws logs

    [2012-03-26 00:15:28,458 Thread-33 ERROR com.vmware.vim.health.impl.ComponentSpec] Unable to retrieve health for com.vmware.vim.sps from http://localhost/sps/health.xml
    [2012-03-26 00:15:28,458 Thread-33 ERROR com.vmware.vim.health.impl.ComponentSpec] Unable to retrieve health for com.vmware.vim.sps from any of its health URLs

    .......
    inherited from com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to an incorrect user name or password.

    [2012-03-25 23:01:52,808 Thread-39 ERROR com.vmware.vim.health.impl.ComponentSpec] Unable to retrieve health for 512e9827-cc0c-4a45-b0ae-ae111defc5ff from https://vCenter:10443/secure/health

    is it using the wrong instance of vcenter, looks as if it is trying to connect to vcenter:10443, despite me specifying ipaddress:8443 in vcenter settings - so what is the right port for this? totally confused... adsi.jpg adsi2.jpg
     
    Certifications: VCP,MCSA, MCP, MCDST, MCITP, MCTS, A+, N+
  4. Mikeyboy

    Mikeyboy Kilobyte Poster

    279
    2
    32
    Just to report back - I FIXED IT!!! yay :)

    for anyone suffering with this grief, I had to reset the Inventory Service database - the steps I followed (after messing around with ADSI Edit, probably breaking more things) can be found here

    vSphere Documentation Center

    Can go to bed now!!
     
    Certifications: VCP,MCSA, MCP, MCDST, MCITP, MCTS, A+, N+
  5. onoski

    onoski Terabyte Poster

    3,120
    51
    154
    Thanks for sharing Mike and glad to hear you sorted this issue:)
     
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.