1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Standalone box and ISA proxy and yum update

Discussion in 'Linux / Unix Discussion' started by zillah, Jan 22, 2007.

  1. zillah

    zillah Bit Poster

    With my box FC5 at work (Active Directory), I have been able to access the net , I have not logged in with my AD account , I logged in as username : root and password : forum,,,fake one (I know security implication, I have done this for test ).

    First time when I tried to open a browser, window popped up asking me username and password for authentication to use internet (I entered my username: zillah and password:ad123 my active directory account,,,fake ), then I was able to browse the net.

    When I tried to use the command below (via Terminal):

    [[email protected]]#yum install yum (yumes),,,,It did not work, I believe because of the authentication (ISA proxy) that I mentioned above.

    With the proxy , I followed the link below :


    1- I added the line below to /etc/yum.conf
    proxy=http://proxy.ewrq.au:8080,,,,,,,,,,,,,,,, because our ISA uses 8080 proxy
    proxy_username=zillah,,,,,,,,,,,,,,,,,,,,,,,,,,,fake username
    proxy_password=ad123,,,,,,,,,,,,,,,,,,,,,,,,,,,fake password
    Then I tried to use this :
    [root]#yum update yum,,,,,,,,,,,,,,,,,,I received this error :

    Loading "installation" Plugin
    Settingup Update Process
    Setting up repositories
    Can not find a valid baseurl for repo:case
    Error: Cannot find valid baseurl for repo:core

    2- I removed the configuration above and I tried these:
    http_proxy=" http://zillah:[email protected]:8080 "
    export http_proxy
    yum update
    [[email protected] # yum update yum
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    File "/usr/share/yum-cli/yummain.py", line 80, in main
    File "/usr/share/yum-cli/cli.py", line 177, in getOptionsConfig
    self.doConfigSetup(fn=opts.conffil* e, root=root)
    File "/usr/lib/python2.4/site-packages/* yum/__init__.py", line 102, in doConfigSetup
    self.conf = config.readMainConfig(fn, root)
    File "/usr/lib/python2.4/site-packages/* yum/config.py", line 567, in readMainConfig
    File "/usr/lib/python2.4/site-packages/* yum/parser.py", line 126, in read
    File "/usr/lib/python2.4/ConfigParser.p* y", line 267, in read
    self._read(fp, filename)
    File "/usr/lib/python2.4/ConfigParser.p* y", line 490, in _read
    raise e
    ConfigParser.ParsingError: File contains parsing errors: /etc/yum.conf
    [line 15]: 'export http_proxy\n'
    [line 16]: 'yum update\n'
  2. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    First - I should say that I know nothing about FC or Yum - but:

    The site you have a pointer to *doesn't* have the spaces surrounding the proxy URL. Unless this was a typo try removing them?

    This is the important line in the stack-trace I think.

    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  3. zillah

    zillah Bit Poster

    Some time if there is no space, the double quote will get changed to icon like this :biggrin
  4. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    I wondered if it was something like that. My comment on the parsing error still stands though <grin>. But I don't know the system to say why it is doing that.

    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+

Share This Page