1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems accessing a hard drive

Discussion in 'Hardware' started by Enigma, Nov 18, 2009.

  1. Enigma

    Enigma Bit Poster

    Hello All,

    I have been having problems accessing a friends hard drive after he got a virus message up on his screen. I wanted to fix it for him.
    All the options under the F8 boot menu did not work. I even tried the recovery console option. When my friend typed in his password it accepted it but the screen then went black and hung there.

    I decided to make a live CD. I burnt a copy of Slax (Linux) onto a CD. I removed the internal hard drive and put this in an external hard drive case. I booted from the CD and the operating system loaded and showed the hard drive, which was attached via a USB port. All files where still intact and could be viewed with the software that came with Slax. To try and retrive the files I attached another external hard drive which the OS picked up. I tried to copy and paste/drag and drop but the following message appeared:

    'You cannot drop any items in a directory which you do not have write permissions'.

    The persmissions for both drives looked like this:
    I was looking for a 'w' as I know this stands for write, a write permission.

    I also tried to attach the hard drive I had removed to a laptop running on Windows XP OS. When I tried to open any folders it would say 'Access denied'.

    Now I'm sure this is something to do with the way the hard drive was originally formatted in NTFS and file permissions associated.
    Is there a way round this to copy the files off the hard drive?

    Thanks in advance,
    Certifications: ITIL Foundation; Prince2 Foundation
    WIP: MCSA Windows Server 2012
  2. zr79

    zr79 Byte Poster

    With the drive attached as a second drive when in windows OS, try to take ownership of a file/folder.

    right click folder - properties - advanced - then under you user account check the box at the bottom "replace permission enteries..." then try and copy.
    Certifications: A+
  3. onoski

    onoski Terabyte Poster

    You might want to make sure the files are not being interpreted as being Linux as you'd need samba on Linux to read to Windows files.

    Another alternative, would be to run chkdsk /r, booting from a Wins XP OS CD selecting the repair option etc. Let know how you get on. Best wishes:)
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  4. dmarsh

    dmarsh Terabyte Poster

    Did you try chown or chmod ? Is the ntfs filesystem mounted as readonly ?

    Also Linux distros support reading NTFS filesystems out of the box, you don't need Samba. Modern distros often support limited NTFS write also with some caveats.

    See here :- http://en.wikipedia.org/wiki/NTFS#Linux

    You should also be able to take ownership in Windows if you are the local administrator and the files are not encrypted etc.

    Last edited: Nov 21, 2009
  5. Enigma

    Enigma Bit Poster

    Hello All,

    Thanks for all the kind replies. I put the hard drive in an external hard drive case and hooked it up to a spare laptop. I took ownership of the files/folders in Windows XP. All is working smoothly now.

    The anti-virus software on the laptop also picked up the virus on the hard drive.
    It was called pskill.exe and I deleted it.

    Enigma :)
    Certifications: ITIL Foundation; Prince2 Foundation
    WIP: MCSA Windows Server 2012

Share This Page