1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with XAMPP - localhost does not respond

Discussion in 'Web Development & Web Hosting' started by christoph hass, Dec 27, 2007.

Click here to banish ads and support Certforums by becoming a Premium Member
  1. christoph hass

    christoph hass New Member

    I set up a XAMPP configuration on my laptop (IBM thinkpad T41), running the latest XUBUNTU. The Installation went flawless. starting up the XAMPP components proceeds without any error messages, i.e. APACHE, MYSQL, PHP, FTP start running w/o any failure message.
    The problem: calling localhost in my webbrowser only yields a timeout message after a certain while.
    Pinging localhost (or or and so on) does not work, i.e. no packages returned.
    I'm completely lost on this and the problem starts to get urgent for me, so if anyone has any ideas :eek:
    btw.: I run the same set-up (xampp on Ubuntu on two other machines (Desktop computers w/o problem)
  2. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    Odd - that interface is usualy always there. Does it appear in the list produced by ifconfig -a ?

    Does loopback appear in the interfaces file? If so - what happens if you try and do an ifup on it?

    BTW - I'm assuming that XUBUNTU behaves like Debian here - if it doesn't then you'll need to find what they have done with these files!

    And welcome to CF!

    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  3. christoph hass

    christoph hass New Member

    The in-existence of the loopback I/F was my problem. The only reason I have for this is, that I did a manual edit of the /etc/network/interfaces, adding some stuff to deal with a problem wit
    h my wireless I/F (posted somewhere on another linux forum). But these modifications where unrelated to the loopback entry (provided hereafter)

    # The loopback network interface
    auto lo
    iface lo inet loopback

    Anyway, reverting to the original file solved my problems ... and ensures a smooth transition into 2008 for me :D

    Thanks for helping!!


Share This Page