1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Please insert disk in drive d:" sata dvd drive?

Discussion in 'Software' started by zr79, Dec 19, 2009.

  1. zr79

    zr79 Byte Poster

    I have a pc with a sata dvd drive and although the dvd drive is shown in my computer, every disk i try is not picked up, i get a "please insert disk into drive d:" Must be some driver or bios setting. I can boot a cd fine from the drive such as if i put in win xp and tap f12 to bring up the boot options and then choose the dvd drive then it boots the cd fine but no disk get detected.

    I did read something along the lines that the autoplay functionality may not be working but i tried the fix but nothng.

    Everythng is installed in device mamager and i have googled loads and quite a few of the same problem but no answer to it.

    Any ideas?
    Certifications: A+
  2. UKDarkstar
    Honorary Member

    UKDarkstar Terabyte Poster

    Wrong type of disk being inserted ? i.e. +R/RW when it only reads -R/RW ?

    Try installing Nero on the PC and then running the diagnostics on the drive.
    Certifications: BA (Hons), MBCS, CITP, MInstLM, ITIL v3 Fdn, PTLLS, CELTA
    WIP: CMALT (about to submit), DTLLS (on hold until 2012)
  3. JonnyMX

    JonnyMX Petabyte Poster

    Disk goes shiney side down?
    Certifications: MCT, MCTS, i-Net+, CIW CI, Prince2, MSP, MCSD
  4. zr79

    zr79 Byte Poster

    Good idea with nero, also i did try a firmware update but it wouldn't accept the firmware bin fiile will try that again.
    Certifications: A+
  5. beaumontdvd

    beaumontdvd Kilobyte Poster

    I had this too the other day? I disabled the drive then uninstalled it. Reinstalled it. Restarted pc. It then installed itself (you may need to download the driver and install it yourself) Then it displayed cd drive, when infact it was a dvd drive. So I put a dvd/r into the drive and it changed staright to dvd drive and I could read and write to it. Hope this helps, (I done this to both my dvd drives)


    Also right click drive -----> Click properties -----> Look for the recording tab (Furthest right) Click it, ----> click enable recording on this drive.
    Last edited: Jan 6, 2010
    Certifications: 070-271, 070-272, (MCDST)Level 1,2,3 NVQ
    WIP: 070-270, A+, N+, S+,MCDST 7 Upgrade

Share This Page