1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Permissions to shutdown the cluster

Discussion in 'Software' started by LukeP, Jun 7, 2010.

  1. LukeP

    LukeP Gigabyte Poster

    I have 2 host cluster which shuts down in the event of power failure.

    I'm using:
    Cluster.exe /shutdown /Y

    command to trigger the shutdown.
    It didn't work at first as UPS service was running with Local System priviledges which I suppose is not enough to shutdown the cluster. I've tested with Domain Admin credentials and it works.

    However, I don't want UPS software to run with Domain Admin credentials. Which account should I run it as?

    EDIT: Sorry should have mentioned - Windows Server 2008 R2 cluster
    Last edited: Jun 7, 2010
    WIP: Uhmm... not sure
  2. craigie

    craigie Terabyte Poster

    In relation to the required rights for the UPS, I would advise speaking to the manufacturer. However, would Local Administrator rights not be adequate?

    You could also add the following to your shutdown script:

    net stop servicename
    Cluster.exe /shutdown /f /y
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  3. LukeP

    LukeP Gigabyte Poster

    Cheers Craigie!

    Will try /f switch tomorrow.

    UPS software by default runs as Local System account and can't switch the server off.
    I'll try Local Admin account tomorrow too.

    How about Network Service account? Would this do? (I'll try that tomorrow too)

    WIP: Uhmm... not sure
  4. LukeP

    LukeP Gigabyte Poster

    Just a quick update:

    There's no /f switch for cluster.exe command. There's a -Force switch for Stop-Cluster Powershell CMDlet.

    It worked out that it wasn't a permission issue at all.
    It was 32bit UPS Management software trying to call 64bit application residing in System32 folder which get automatically redirected to SysWOW64 when 32 bit application tries to access it.
    Because there's no 32-bit cluster.exe on 2008 R2 server nothing was happening.

    The solution was to call cluster.exe using non-existant path: "C:\windows\sysnative\cluster.exe" which is only visible for 32-bit applications.
    So the batch script would look like this:
    C:\Windows\Sysnative\cluster.exe /shutdown /Y
    God this took me nearly whole day to figure out.
    You can read more on the subject here: http://www.microsoft.com/WHDC/SYSTEM/PLATFORM/64BIT/WOW64_BESTPRAC.MSPX (downloadable Word doc)
    Last edited: Jun 16, 2010
    WIP: Uhmm... not sure

Share This Page