1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Network adapters

Discussion in 'Networks' started by Johnd76, Jul 5, 2008.

  1. Johnd76

    Johnd76 Megabyte Poster

    My Brother has re-installed XP pro onto his Dell laptop because of problems he was having......he has informed me that he has no network adapters in his system after the install

    anyone got any ideas?:blink
    Certifications: MCP, MCDST
    WIP: Not a thing
  2. NightWalker

    NightWalker Gigabyte Poster

    Have a look in Device Manager, there is probably one or more devices with a yellow exclamation mark. Time for a trip to the Dell website to download all the drivers.
    Certifications: A+, Network+, MCP, MCSA:M 2003, ITIL v3 Foundation
  3. Johnd76

    Johnd76 Megabyte Poster


    Yeah he said there is a few yellow exclamations marks.....looks like im going to have to download them for him seeing as he cant get on the internet :(
    Certifications: MCP, MCDST
    WIP: Not a thing
  4. craigie

    craigie Terabyte Poster

    If you do a search with your Brothers Asset Tag or Service Tag on Dells website it should make locating the drivers a bit easier.

    I would recommend downloading them all and then installing the correct ones.
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  5. zebulebu

    zebulebu Terabyte Poster

    If you can't locate the info on what drivers you need, take a look at this. That software is always on my emergency USB stick - especially useful for those times when you have a box that has been formatted and don't know what exactly is installed in the system - or have a Dell/HP box that, when you go to their site, lists three different possible chipsets, graphics cards or NICs for that model.
    Certifications: A few
    WIP: None - f*** 'em
  6. Johnd76

    Johnd76 Megabyte Poster

    I got the drivers he needed, everything is working a treat now!

    cheers for the help guys
    Certifications: MCP, MCDST
    WIP: Not a thing
  7. The_Geek

    The_Geek Megabyte Poster

    Glad we got that one resolved.

    Now let me add a wrinkle. The in-laws have a Compaq Presario running Vista Home Basic. Suddenly they cannot access the internet. Charter says the service to the house is ok. I go to control panel, device manager and there isn't a "network adapters" listed. Since it's integrated into the mobo I added a Linksys PCI LAN card and restarted the PC. Upon startup I get the "new hardware found" message and after a few minutes I get the "your new hardware is installed and ready for use". I go back to device manager and still no listing for "network adapters". I even tried a restore from a few days ago but no luck. Any ideas?
    Certifications: CompTIA and Micro$oft
    WIP: PDI+
  8. slyuen

    slyuen Byte Poster

    going back to the motherboard architecture route, perhaps the driver for PCI bus, south/north bridge or other motherboard resources were not correctly installed.

    it's like saying it can't find my usb stick drive, but the USB controller driver wasn't correctly installed the first place.

    In most cases I've seen, re-installing the "chipset" driver package fixes it. sometimes it comes with a setup.exe, sometimes it comes with a bunch of inf files.

    don't forget other possible scenarios include 1. (I find it becoming more and more common now), the piece of hardcare is either not compatible with XP or Vista - in this case it's up to the manufacturer to release a correct driver if they haven't already done so.

    2. the piece of hardcare or chip is actually malfunctioning or detached or loose wires etc.

    good luck
    Certifications: ECDL,A+,Network+,CST,CNST,MCDST,MCSA
    WIP: MCSE, CIW, CCNA, CWNA, Others...
  9. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    Always, always, always download drivers before wiping a system... at LEAST the NIC drivers. Once you've got the NIC going, you can download everything else. :)
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  10. nugget
    Honorary Member

    nugget Junior toady


    Glad to hear that you have resolved the problem.

    Another solution, depending on how old the dell is he should have some driver setup disks. He should have been able to install the network adapter drivers from this. The second is if the dell came with the "recovery" partition where the OS is stored on a hidden partition, when you reinstall using this there is usually a "setup" choice in the all programy menu which you can then install all the necessary drivers from.
    Certifications: A+ | Network+ | Security+ | MCP (270,271,272,290,620) | MCDST | MCTS:Vista
    WIP: MCSA, 70-622,680,685
  11. juice142

    juice142 Megabyte Poster

    I find this the pup's plums, well worth twenty bucks, saves all the faffing about... :biggrin
    Certifications: BSc (Hons), A+, Network+
    WIP: 70-270, MCSA

Share This Page