1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Name resolution problem - mixed NT/2K3 environment

Discussion in 'Networks' started by zebulebu, Jul 19, 2007.

  1. zebulebu

    zebulebu Terabyte Poster

    Anyone who can help me out here? I think I'm probably overlooking something obvious here, but can't see what it is at the moment - might be because I "can't see the wood for the trees"!

    I've got a mixed NT/2K3 domain. Server in the NT domain can't ping one particular server in the 2K3 domain by hostname - but can ping it by FQDN. The other server can ping in the opposite direction by both FQDN and hostname.

    If I run NBTSTAT -a against the 2K3 server from the NT server I get 'host not found'. If I run NBTSTAT -A I get the correct WINS registrations

    NBTSTAT -a and -A both give correct WINS reg info when run from the other side.

    Seems to point to a WINS problem, but I can't find any errors in WINS and the correct RRs are present for the NT server?

    I know I'm missing something obvious, but my WINS experience is rusty to say the least - has anyone got any ideas off the top of their head to look at first?

    Cheers - in advance :oops:
    Certifications: A few
    WIP: None - f*** 'em
  2. onoski

    onoski Terabyte Poster

    Zeb, can you provide us with a dummy config of your settings to have a better picture. Judging from the info you've provided sounds like something little you might have missed out.
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  3. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    nothing in HOSTS, and nothing in LMHOSTS?
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  4. Povester

    Povester Bit Poster

    I encountered a fairly similar problem recently, albeit not the same.

    Try, at the command prompt, entering "net view \\<server>" (<server> will be the server host name of the one that you can't reach). If you receive an error stating "system error 52 has occured", then you have encountered the same problem I had and a search for that error message will display a couple of solutions.

    ....of course, it's most likely a different error that the more experienced members out there will be more skilled to answer :-)
  5. Theprof

    Theprof Petabyte Poster Premium Member

    Zeb, thats the only thing I could think of.
    Certifications: A+ | CCA | CCAA | Network+ | MCDST | MCSA | MCP (270, 271, 272, 290, 291) | MCTS (70-662, 70-663) | MCITP:EMA | VCA-DCV/Cloud/WM | VTSP | VCP5-DT | VCP5-DCV
  6. zebulebu

    zebulebu Terabyte Poster

    Yeah - sorry folks - should have posted that I'd already tried the Net View\\Servername command and got SysError 53 from it.

    No lmhosts file and nothing in hosts BM - I suppose I could get round it by creating an lmhosts file and populating it - but I'd rather get to the root cause of the issue if I can. Looking at the WINS server there's a whole load of 4101 errors - but I suspect most of them are from spurious WINS replication partners that were configured ages ago and have been long since 86ed.

    Still working on it though - if anyone has any further advice I'd welcome it!

    Certifications: A few
    WIP: None - f*** 'em
  7. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    I take it you have tried running nbtstat -RR to re-register the server with WINS?
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH
  8. zebulebu

    zebulebu Terabyte Poster

    Yeps - first thing I did. I remembered that much about WINS from years ago!

    Still no closer to resolving - problem is I don't have physical access to the server at the minute so can't install wireshark to run a trace. Hopefully I'll be able to get on there tomorrow morning - going to try and do a bit more digging tonight after the coppers go home :)
    Certifications: A few
    WIP: None - f*** 'em
  9. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    What is your WINS infrastructure like? Is it possible just to uninstall and reinstall the WINS component or is that too much drama for a Friday? :biggrin
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH
  10. zebulebu

    zebulebu Terabyte Poster


    Yes - MUCH too much drama. It's pretty complicated - we've got a mixed infrastructure - half of our servers are NT, the other are 2K3. Most of the workstations are in the AD domain, but users still log on to the NT domain. WINS and DNS are 100% essential services - which need to be running all the time - which makes performing any maintenance on them very difficult to say the least.

    I'm going to look at running the trace tomorrow and see what that throws up. I'm sure it's WINS related, but, frustratingly, there doesn't seem to be anything wrong in the WINS DB and there aren't any obvious client-side issues that would cause it. I've checked things like NetBIOS over TCP/IP running, the 'RestristAnonymous' key not being set wrong in the registry, File & Print Sharing is enabled etc etc
    Certifications: A few
    WIP: None - f*** 'em
  11. nicolinux

    nicolinux Byte Poster

    I just try to guess so don't give me off.
    I could think about something related to the name.If from Nt side you can ping by hostname all the 2k3 server but one, i suppose the
    problem is that server's name.
    Is a new server or was there before ?. If is a new server a would think about the name ( lenght > 15 char etc ).Or duplicated name,
    for example server1.subnet1.mydom.local and server1.subnet2.mydom.local. Dns can hold that but i do not know about wins which is just able to see the hostname ( server1 ), and in this case it see two server with the same name.
    Please correct me if i am wrong, is a good way to learn.
    Certifications: mcse win2k3, mcts x4. mcitp enterprise admin
    WIP: 70-680
  12. Tinus1959

    Tinus1959 Gigabyte Poster

    Hi Zeb,

    The only thing I can think off, reading the rest of the thread, is that the client is not a hybride type client.
    Most clients get their settings with DHCP, both a local setting in the register is bound to be stronger.
    You know these 4 types: Broadcast, peer to peer, mixed and hybride (with numbers 1, 2, 4 and 8 ).
    Certifications: See my signature
  13. r.h.lee

    r.h.lee Gigabyte Poster


    1. When you mention "Server in the NT domain..." what role does the NT server have?
      1. PDC?
      2. BDC?
      3. Member Server?
    2. When you mention "...can't ping one particular server in the 2K3 domain by hostname" what role is the 2K3 server?
      1. Domain Controller
      2. Application Server
      3. File & Print Server
      4. Other Server
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
  14. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    Just out of curiosity if you put a hosts value in does the name resolution work ok? Just need to make sure the whole name resolution process is working the way is should do. Like you said though it’s probably best find the root of the problem rather than going for a quick fix.

    For the two servers where are they pointing for WINS? Are they both using the same WINS server? If so is it possible to create another replication partner and use that for WINS name resolution.

    Also have you trying to compact and repair the WINS database? I had an issue with a DHCP server that would just stop (for no obvious reason) and I ended up running the jetpack.exe on the DB (can be used on a WINS DB as well) and it helped the stability of the DHCP service. Might be useful in this case or might be no help whatsoever! :biggrin

    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH

Share This Page