1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem DNS query

Discussion in 'Networks' started by HTF, Jan 27, 2010.

  1. HTF

    HTF Byte Poster


    I have DNS server (W2K3) at home which is also domain controller of 'example.local' and the name of this computer is 'server' so FQDN is 'server.example.local'.

    The problem is that sometimes it's not working by meaning that I cannot ping or RDP to the server by this name and when I run the command ipconfig with registerdns switch (after flushdns) from the clinent PC (Windows 7) everything is back to normal so I can ping and RDP by example.local or server.example.local.

    It's working and then after few hours it's stop.:dry

    Please note that I created NS, A, PTR records for both: server.example.local and example.local, additionally:
    - both names are resolved to the IP of the server and the server IP NSLOOKUP to server.example.local but I have both NS in reverse lookup zone

    Where is the problem what I'm doing wrong?

    For all help thank you in advanced.

    Last edited: Jan 27, 2010
    Certifications: A+
  2. EZE Training Instr

    EZE Training Instr Bit Poster

    Sounds like a strange one. Is DNS setup correctly on the client machine? Are you using DHCP?
    Certifications: MCT, MCITP, MCTS, VCI, VCP, CCNA, CCNP
  3. SimonD
    Honorary Member

    SimonD Terabyte Poster

    Sounds like your name resolution isn't resolving correctly, as has been asked before are you using the DNS server settings for your DC on the client machine?

    If not you should be able to make entries in your HOSTS file that points to your namespace and FQDN of the server and it should work.

    Ideally you would be using the internal DNS with DNS Forwarding pointing to your ISP's DNS servers.
    Certifications: CNA | CNE | CCNA | MCP | MCP+I | MCSE NT4 | MCSA 2003 | Security+ | MCSA:S 2003 | MCSE:S 2003 | MCTS:SCCM 2007 | MCTS:Win 7 | MCITP:EDA7 | MCITP:SA | MCITP:EA | MCTS:Hyper-V | VCP 4 | ITIL v3 Foundation | VCP 5 DCV | VCP 5 Cloud | VCP6 NV | VCP6 DCV | VCAP 5.5 DCA
    WIP: VCP6-CMA, VCAP-DCD and Linux + (and possibly VCIX-NV).
  4. craigie

    craigie Terabyte Poster

    Also, how are your computers networked, physical machines, bridged on VM's etc.
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  5. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    Also, when connection by name fails, try IP
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  6. HTF

    HTF Byte Poster


    This is really odd - about an hour ago was working, I've just tried now and example.local is not working but I can ping and RDP by server.example.local.

    Connection via IP always works fine (ping, RDP).

    Basically I have 4 PCs at home one of them is the server, all are connected to the router so it's some kind of star topology, the server is also DHCP server and it's assigning its IP as a preferred DNS server, on router I've set it as a relay DHCP.

    My laptop is in domain (example.local) and generally everything works fine, like WDS installation, DHCP ect. - apart this thing.

    Is it possible that the server is causing slow internet connection because it's quite bad from few weeks so it's look like since I've set the server but I've tested with the server turned off and wasn't better so may the server affect this? IMO should be better as the server is caching all the websites...
    Certifications: A+
  7. Big Bad JV

    Big Bad JV Bit Poster

    I would turn off any DHCP functions on the router and rely only on the server to give out IP addresses to the local network. Next check that the server is passing out the correct detail from the DHCP server setup, and the DNS is setup so that both forward and reverse lookup zones are configured. Check that under both zones you have got a referance to the server name and that your forwarders are set to point to your ISP DNS server IP addresses.

    The server network settings should point to itself for the DNS server and an nslookup from the server should show the server name as the default server

    Use nslookup from the client to see the same info as from the server. if you get an error message on either the server or client, then it is probably the reverse lookup zone in DNS not setup or no record for the server A record that is in the forward lookup. you can either manually add the reverse record or go to A record entry in the forward lookup and select the properties and tick the box for create a reverse lookup.

    DHCP and DNS are fairly straight forward but sometimes things like routers trying to do DHCP aswell as the server will cause some strange things to happen.

    Hope that helps

    Big Bad JV.
    Certifications: MCSE
    WIP: CCNA, CCNA Voice
  8. HTF

    HTF Byte Poster

    Thx for reply, basically everything is set as you suggesting and at the moment it's working but it's take some time to establish RDP connection and when I try to ping it it also take few seconds before start pinging (example.local) but server.example.local or any other domain pinging right away :dry
    Last edited: Feb 23, 2010
    Certifications: A+
  9. beaumontdvd

    beaumontdvd Kilobyte Poster

    Are all computers and servers using a hard wired connection (ethernet)?
    Certifications: 070-271, 070-272, (MCDST)Level 1,2,3 NVQ
    WIP: 070-270, A+, N+, S+,MCDST 7 Upgrade
  10. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    When this happens can you ping by IP?
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH

Share This Page