1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Display issue

Discussion in 'Gamers Hangout' started by Kopite_21, Dec 8, 2015.

  1. Kopite_21

    Kopite_21 Gigabyte Poster

    Hi Guys,

    I am in need of assistance from yourselves. I have a game that I have not played in a while Command & Conquer First Decade (Yes I know it's an old game). I've installed the game on my Laptop and when I try to launch Yuri's Revenge it pops up with a dialogue box saying "Please insert the CD". The game is a genuine copy and I don't understand why it's doing his. Any ideas?

    Also if I try and open Red Alert 2 or any of the other Command & Conquer games it launches into the game but the background just turns black with just the mouse cursor that I can see and move.

    I've tested other games on the Laptop (Footy Manager, Age of Empires etc) and it launches the other games without any issues.

    Also the last time I played C&C on the Laptop it worked perfectly. Also the operating system I am using is Windows 7.

    My little cousin has got me back into this as he wants to play me online...

    Any ideas? Thanks in advance...
    Certifications: National Diploma IT Advanced ECDL
    WIP: A+
  2. Apexes

    Apexes Gigabyte Poster

    I had the same issue with rollercoaster tycoon, fkin love that game.

    I managed to get around that by setting the executable to run in compatibility mode for Windows XP SP3 in the exe's properties. Unsure if it'd work on this but could be worth a go.

    I've downloaded a ton of old games from gog.com for about £5 a piece, currnetly making my way through theme hospital, that website has taken alot of my spare time recently :D they all run seemlessly on Win7, but have been redesigned to run on newer systems
    Certifications: 70-243 MCTS: ConfigMgr 2012 | MCSE: Private Cloud
  3. Kopite_21

    Kopite_21 Gigabyte Poster

    Thanks for your reply Apexes, have just tried this changing to XP SP3 still no look. Trying to play my little cousin online and his is fine. :twisted:
    Certifications: National Diploma IT Advanced ECDL
    WIP: A+
  4. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    Worth setting up a dual boot with XP? Providing XP will run on the newer hardware. :)
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH
  5. zxspectrum

    zxspectrum Gigabyte Poster Premium Member

    Try changing to a lower resolution, I had the same issue and after I had changed that as well as the compatability, mine worked

    Certifications: BSc computing and information systems
    WIP: 70-680
  6. Juelz

    Juelz Gigabyte Poster

    I second Eds suggestion as I have encountered the same issue and resolved it by lowering the resolution.
    WIP: A+
  7. Kopite_21

    Kopite_21 Gigabyte Poster

    I have tried lowering the resolution but still having the same issue. Going to have another try tomorrow.

    Thank you
    Certifications: National Diploma IT Advanced ECDL
    WIP: A+

Share This Page