D-link wireless router problem!!

Discussion in 'Internet, Connectivity and Communications' started by aharris, May 4, 2005.

  1. aharris

    aharris Bit Poster

    hi guy hoping somewhere out there can help me! Ive just bought a wireless d-link dsl-g604t router. Ive followed the manual and some how i must of gone wrong! It shows that it there is a signal to the pc but cant not open a web page!??? Any help would be very greatfull! I ve never used a router before and finding it hard.
    WIP: A+ N+
  2. tripwire45
    Honorary Member

    tripwire45 Zettabyte Poster

    Well, let's go back to basics. Can the PC ping the IP address of the router? Can the PC ping the IP address of an internet site? You can receive a radio signal but still not connect. Are both the PC and router on the same SSID and channel? Is WEP enabled or disabled? If you can ping your gateway and an internet site, is the router configured to connect to your ISP's DNS server?

    There are alot of reasons why you might be experiencing your current woes. Try to fill us in and let us know the answers to the above and any other symptoms you notice. Hope we can help.
    Certifications: A+ and Network+
  3. Modey

    Modey Terabyte Poster

    I'm sorry to say this aharris, but you went and picked one of the most un-userfriendly router's I have personally ever come across ( and I have setup and configured many routers). I have that model router myself, and it's working fine, but it can be a real pain to configure.

    Your first port of call (if you haven't already tried this) is to upgrade the firmware. The latest release has a new connection wizard that is much simpler than earlier releases were to setup ( although the DNS settings on it are up the wall). If the unit absolutelty won't keep it's settings, or allow you to upgrade it's firmware then it's a duffer, send it back. I bought one for my father-in-law which did this. I sent it back and it was tested faulty, so I ordered a similarly specced Netgear unit (NETGEAR DG834G), and it was like a breath of fresh air setting it up. Quite the simplest and friendliest unit I have come across.

    Anyway, firmware link here ... http://tinyurl.co.uk/w7xg

    And here is a link to a forum where people are discussing a whole raft of issues with the G604T. Have a good read through those, as there are allot of people there suggesting fixes and work arounds that have been helpful for them.


    I know it's a hassle, but my best advice would be to send it back matey, and buy the Netgear, you won't regret it.
    Certifications: A+, N+, MCP, MCDST, MCSA 2K3, MCTS, MOS, MTA, MCT, MCITP:EDST7, MCSA W7, Citrix CCA, ITIL Foundation
    WIP: Nada
  4. aharris

    aharris Bit Poster

    WIP: A+ N+

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.