1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 877W DNS problems?

Discussion in 'Routing & Switching' started by dewdneys, Aug 10, 2008.

  1. dewdneys

    dewdneys Bit Poster


    have had a running Cisco 877W configured to use Orange ISP for several months; however, something has changed over the last week as can now only get full browsing access when using default Speedtouch modem plugged into laptop rather than nice wireless using the router.

    Symptom is that while some websites (eg www.google.co.uk) work when using wireless router, most others fail. Same sites work when plugged into Speedtouch USB modem.

    ISP account settings have not changed and I hadn't changed anything on the router when problem first occurred (been tweaking and fiddling since so may have bust something!) :rolleyes:

    Noted different DNS server address from original config when connected to USB modem, so changed this on the router, enabled connection to google when wireless but no other URLs working (except orange - slow).

    May be a config error, possibly firewall?, so have attached my config to this message.

    Note several Access-lists in config - can't work out how to remove old ones, but SDM reports using 105 for info...

    Old DNS
    New DNS

    Tried removing firewall rules (ie turning it off); but this did not solve problem.

    Here's some additional debugging info:
    With USB Speedtouch modem plugged in:
    IP (Preferred)

    Browse to www.bbc.co.uk/news ok
    www.google.co.uk ok
    www.orange.co.uk ok

    Outlook sends and receives email ok

    ping www.bbc.co.uk resolves to reply 59ms
    ping www.google.co.uk resolves to reply 63ms
    ping www.orange.co.uk resolves to but does not reply

    Now with the router plugged in and wireless connection to router

    Browse to www.bbc.co.uk Website found. Waiting for reply... (never gets there!)
    www.google.co.uk works fine, including searchs, ,maps etc...links fail if follow as per bbc
    www.orange.co.uk get the orange icon, then after a 15s or so wait, rest of content appears (normally quicker than that)
    www.theiet.org loads all but one item (www.iet.tv/.../james.jpg...)
    www.transportdirect.info Waiting for http://www.transportdirect.info/...
    www.certforums.co.uk Website found. Waiting for reply...

    Outlook sends and receives email ok

    PING www.bbc.co.uk resolves to reply 59ms
    PING www.google.co.uk resolves to reply 72ms
    PING www.orange.co.uk resovles to no reply (request timed out)

    Router config attached to this message:

    Any ideas cause I'm stuck? Hopeing that it's something simple!


    Attached Files:

  2. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    Why dont you use nslookup on the PC and then type a URL of a website you havent tested (this means it wont be cached) and see if it resolves ok.
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH
  3. MacAllan

    MacAllan Byte Poster

    Differential response to websites is often a MTU issue - although I can't imagine why it should only have happened recently. Try dropping the value to 1300 and see if this works: if it does, incrementally increase it back towards the 1452 value until it stops working, then go back a step. You may also need to set it on the ATM interface.

    Certifications: A+, N+, CCNA
    WIP: CCNP, Linux+
  4. SuPaStA

    SuPaStA Nibble Poster

    Your issue is not dns related, I can see this because your dns resolution is working fine.The reason you not getting a ping response from orange.co.uk is because they dont allow icmp packet repsonses(nobody gets a repsonse when pinging it).I also dont think its a MTU issue.
    Certifications: CCNA,MCSE,ITIL,Server+,Security+,N+...
  5. dewdneys

    dewdneys Bit Poster

    Thanks for the response guys.

    Can confirm not a DNS problem - NSLOOKUP works fine

    Haven't tried tweaking MTU's, but will get back to you when have...

    My suspicion is some kind of HTTP filtering going on, but no idea what!

    Update 2
    Gave up and tried resetting router to factory defaults and re-installed everything. All worked fine, so have installed firewall - still working.
    problem gone away! :)


Share This Page