1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vista and the firewall conundrum...

Discussion in 'Software' started by NightWalker, Dec 31, 2008.

  1. NightWalker

    NightWalker Gigabyte Poster

    I run Vista Ultimate x86 on my main desktop PC. I have a NAT router between my LAN and the internet, that takes care of most of my security. I have always been a fan of running a software firewall on my PC to control program access to the net. Now on this Vista machine I have tried a couple of different versions and makes of software firewall, but they all end up getting uninstalled because of a problem I can't seem to get to the bottom of.

    I tried Zone Alarm again last time, this is what happens. Install Zone Alarm, all is good. Allow my browser and things access to the net, all is good. Surf the net for 30 - 40 minutes, all is good. Then the problem.... I loose the ability to download any more web pages, like port 80 has just closed itself. If I try any of the three browsers I have installed (firefox, IE and Chrome) they all have the same problem, can't download a web page, not a browser issue. I can successfully browse the net from another PC on my LAN, not a router or ISP issue. I can perform a successful NSLookup from the Vista box, so some ports must be open. Tried two different builds of Zone Alarm and one of Comodo, both cause the same problem, not an issue caused by a particular vendors firewall.

    I have spent ages researching (yep, I Googled it!), and still have no answer. It's like something is timing out, or hitting a threshold. After I reboot everything is fine again for 30 - 40 minutes then I loose port 80 access again. I have unselected IPv6 from my LAN adaptor, disabled the LAN and WiFi adaptors not in use, stopped the use of a DHCP flag in the registry that my router does not support, flashed my router to the latest firmware, tried various driver and software updates.... still the same problem! So has anyone seen a similar issue? (there is probably a really dumb easy fix that I have overlooked)...
    Certifications: A+, Network+, MCP, MCSA:M 2003, ITIL v3 Foundation
  2. onoski

    onoski Terabyte Poster

    Sorry dude, can't help or recommend on the above as vista on it's own has a pretty solid inbuilt firewall. It might help trying to only use the windows inbuilt software firewall as it's not that bad.

    Well best wishes and let's know what you decide.
    Certifications: MCSE: 2003, MCSA: 2003 Messaging, MCP, HNC BIT, ITIL Fdn V3, SDI Fdn, VCP 4 & VCP 5
    WIP: MCTS:70-236, PowerShell
  3. craigie

    craigie Terabyte Poster

    Have you disabled the inbuilt Windows Firewall?

    If No, run an MMC and add Windows Firewall on your local PC. This will bring up Windows Firewall Advanced. Check all of the Profiles, Domain, Private and Public to see what setting they are on. Also check your Inbound and Outbound Rules as there could be something in place causing the issues.

    Never tried this, but I believe you can Monitor the Firewall in here as well, so could be an idea to do a reboot and watch this and see if anything happens.

    I would also check the Event Logs to see any errors in these.

    Last of all, I would run a Windows Defender Update and full scan to see if anything external could be causing the issues.

    Good luck, let us know how you get on.

    Edit: Repeat the above with Windows Firewall turned on and your other Third Party turned off and see what happens as well. This will then at least could narrow down the issue.
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  4. tripwire45
    Honorary Member

    tripwire45 Zettabyte Poster

    This is a pure guess, but have you turned off the Vista on board firewall? Sounds like some sort of conflict is happening. Try as onoski suggests and use just the Vista firewall and see how that works out. Then turn off the Vista firewall and use a third-party firewall and see if your performance changes. Let us know what you find out. If there are no resources on the web about this, maybe you can write an article and publish it here with your findings.

    Good luck.
    Certifications: A+ and Network+
  5. NightWalker

    NightWalker Gigabyte Poster

    Running with just the Vista firewall I have no problems. After installing Zone Alarm I did check to see if it disabled the on board Vista firewall (it used to do it for you in XP and did the same in Vista).

    @ craigie1977, thanks for the input, I never checked to see if there was an MMC for the Windows firewall, looks promising though.
    Certifications: A+, Network+, MCP, MCSA:M 2003, ITIL v3 Foundation
  6. derkit

    derkit Gigabyte Poster

    Bit of an old, and probably useless response, but I had the same thing but with XP a few months back - ended up being a problem with Zone Alarm, a setting contained within. I set the defaults on ZA again, and all was well.
    Certifications: MBCS, BSc(Hons), Cert(Maths), A+, Net+, MCDST, ITIL-F v3, MCSA
    WIP: 70-293
  7. greenbrucelee
    Highly Decorated Member Award

    greenbrucelee Zettabyte Poster

    I had this issue with xp and a trial of Zone alarm, I couldn't find the setting to fix it so I got ESET smart security instead which imo is absolutely brilliant. It'll block everything in or out unless you set it up in the rules to be allowed.
    Certifications: A+, N+, MCDST, Security+, 70-270
    WIP: 70-620 or 70-680?
  8. Raffaz

    Raffaz Kebab Lover Gold Member

    Not sure if this will help, found it on the net.

    To get connections again take the following steps:
    1. In the ZA firewall screen, in the 'Internet security zone' section, click on the 'custom' button
    2. In the 'High security settings for internet zone', select 'allow outgoing TCP ports', and type in the 'Ports' field: 80,443,110
    port 80 is for the browsers
    port 443 is for https
    ports 25 & 110 for mail

    There are also more suggestions at http://blogs.pcmag.com/securitywatch/2008/07/microsoft_dns_patch_grounds_zo.php
    Certifications: A+, MCP, MCDST, AutoCAD
    WIP: Rennovating my house

Share This Page