1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

switchport mode trunk

Discussion in 'Routing & Switching' started by insurin, Apr 19, 2009.

  1. insurin

    insurin Bit Poster

    I have a medium size network consisting of about 60 switches and 4 6500's. As far as I know my problem is very trivial, well to everyone else it will be.

    I have a Cisco 2950 switch in one cabinet. I have multiple vlans running and 2 gigabit ports of this switch acting as trunk links going back to one of the 6500's. traffic is flowing through this switch for different vlans and different subnets on the Windows network. So the switch is functional.

    I now have a new cisco 2950 to put in an office, this will replace a standard netgear switch. I have to point out that at the moment this switch is working fine. It is coming out of port 35 on the switch mentioned above (the fully functional one) the settings on port 35 are

    switchport mode access
    switchport access vlan 10

    As is stands, all PC's connected to the netgear switch will be on vlan 10.

    So I put this new Cisco switch in the office to replace the netgear one. I give it the same IP address as what the netgear had. I assign port 1 as the following

    port 1
    switchport mode trunk
    switchport trunk encapsulation dot1q

    I also do this on the switch that is fully functional

    port 35

    switchport mode trunk
    switch trunk encapsulation dot1q

    so to summarize, both ports have been set to trunks but no matter what I do, I cannot get a green link light to come up on either switch. I cannot ping any other devices on the network from this new switch. I expect this seeing as I have no green link light on the port.

    Things I have checked

    Vlan 1 is up and operational
    no ports are shutdown

    As soon as I do a 'no shut' on the new switch, on port 1 I receive 'port 1 is up, port 1 is down' straight away. I turned on ip debugging and tried to ping another device. I got errors about encapsulation but both switches, in fact, all switches are using dot1q.

    I have tried using a different IP address within the same class C range. One that was unused.

    I have rebooted the switch a few times and it is loading up my config. I have tried an empty config from scratch and manually entered the details. I have also pasted a working config from a few months ago when I had another Cisco 2950 switch in this room. I still get no link.

    So seeing as there is nothing wrong with the physical cabling, can anyone give me some pointers
  2. albertc30

    albertc30 Kilobyte Poster


    Hello mate.
    Can you just have two computers with static IP addresses on that switch and ping between them? Have you tried this?
    Can't honestly thing of anything else other then a dodgy switch or something wrong with the switches IOS software.
    Please let us know how things go.
    Certifications: CCNA
    WIP: 220-701 - A+
  3. keconnect sparky

    keconnect sparky Nibble Poster

    Sounds all good to me,
    Only thing i can think of would be the network cable, are you using a patch cable or a cross-over ...try a cross over cable or if you have tried that already test the cable(s) -although the cable being a dud is abit of along shot.
    Certifications: MCP, CCENT, CCNA, CCNA-S
  4. Broc

    Broc New Member

    Check out port security also, it might be that you had that set up on your switch.
  5. insurin

    insurin Bit Poster

    ok guys, thanks for the input it made me re check my steps.

    It turns out I was using a dodgy crossover cable. All those times I tell people, who bothers to check the 7 layers of the OSI in order from bottom up. Note to self, check physical first.


Share This Page