1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Server 2000 Logs Me Off Immediately After Logging On

Discussion in 'Software' started by Fazza, Jun 25, 2010.

  1. Fazza

    Fazza New Member

    I'm at work at the moment and I wanted to do an ad-hoc backup of one of our servers so I logged on to the server and was immediately logged back off!

    Not even got to the desktop.

    From another server with BackupExec on it I tried to deploy the remote windows agent but it says an older version is already on it and it is unable to upgrade it. :(

    I’ve tried allsorts, tried to logon using my AD account, the admin account, the local admin account, I even connected remotely to the local users and created a new account and tried that and the same thing happened.

    I looked at the event viewer remotely and nothing appeared in any of them so something odd is going on. Even though there was nothing in the event viewer I tried to clear the applications one and after doing that things started to appear!

    I’ve just logged on (and it then logged me back off) and in the event viewer (applications) I get the following:

    Windows cannot query ProcessGroupPolicy registry entry for gptext.dll.


    Windows cannot load extension C:\WINDOWS\system32\iedkcs32.dll with (126).

    Any ideas what might be going on?

    Certifications: MCP, A+
    WIP: Apple Certified Technician
  2. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator


    Perhaps try logging in with the network cable unplugged....
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Office 365, Server 2016, CEH
  3. Bluerinse
    Honorary Member

    Bluerinse Exabyte Poster

    What happens in 'Safe Mode'?
    Certifications: C&G Electronics - MCSA (W2K) MCSE (W2K)
  4. GSteer

    GSteer Megabyte Poster

    Sounds like a bugged/corrupted userinit entry

    MS infi: http://technet.microsoft.com/en-us/library/cc939862.aspx

    Fix Info: http://www.computing.net/answers/windows-2003/cant-login-to-server-2003/7408.html

    Copied from last link:

    "I had the same problem after a virus cleanup a few years ago. Here are the notes I kept after figuring out the solution.

    This behavior indicates a problem with userinit.exe There are two possible problems.

    1. The file %SYSTEMROOT%\system32\userinit.exe is either damaged or missing. Use the Windows recovery console to replace it with another copy.

    2. The registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon should have a setting named userinit. It may have been changed by virus or spyware. In some cases the original setting is saved under OldUserinit. The correct value for this key is


    Be sure to include the comma after userinit."

    I've had this issue before on various workstations but not on a server before I must admit, it's worth checking that setting.

    You'll need to load the registry hive over the network or boot the server with a live iso that's got a reg-editor built in.
    Certifications: BSc. (Comp. Sci.), MBCS, MCP [70-290], Specialist [74-324], Security+, Network+, A+, Tea Lord: Beverage Brewmaster | Courses: LFS101x Introduction to Linux (edX)
    WIP: CCNA Routing & Switching

Share This Page