Cisco 891W Configuration

Discussion in 'Routing & Switching' started by Dinesh, May 29, 2015.

  1. Dinesh

    Dinesh New Member

    1
    0
    1
    Hi, I have a cisco 891W router and would like to set it up with 2 SSID’s, and 4 VLANS:

    Vlan 1 – DATA (native)
    Vlan 2 – LAN-WIFI
    Vlan 3 – PUBLIC-WIFI
    Vlan 4 – VOICE

    SSID LAN-WIFI
    SSID PUBLIC-WIFI

    Port fa8 is connected to the cable modem. I will also connect interface fa1 and fa2 to a different switch, and configure it as a trunk port.

    I am trying to put together a configuration script, some of which I copied from the internet. Not sure if its correct or if the codes are in sequence, or what needs to be adjusted. Can you please assist with this script, thanks.

    I am trying to get the wired part to work first before configuring the AP.

    config t

    alias exec save copy running-config startup-config
    hostname R1-891W
    username tech privilege 15 secret testlab
    enable secret testlab
    service password-encryption
    no ip domain-lookup
    ip domain name xxx
    vtp domain xxx
    vtp mode transparent
    ip http server
    no ip http secure-server
    crypto key generate rsa general-keys modulus 2048

    ip ssh version 2
    ip ssh time-out 60
    ip ssh authentication-retries 3

    ip cef
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec

    boot-start-marker
    boot system flash
    boot-end-marker

    control-plane
    bridge 1 protocol ieee
    bridge irb

    bridge 1 route ip

    no logging on
    no aaa new-model
    ip source-route
    ip dhcp excluded-address 10.0.0.1
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 10.10.50.1
    ip dhcp excluded-address 10.0.100.1

    ip forward-protocol nd

    ip dhcp pool LAN
    network 10.0.0.0 255.255.255.0
    default-router 10.0.0.1
    dns-server 4.2.2.2
    exit

    ip dhcp pool LAN-WIFI
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    dns-server 4.2.2.2
    exit

    ip dhcp pool PUBLIC-WIFI
    network 10.10.10.50 255.255.255.0
    default-router 10.10.50.1
    dns-server 4.2.2.2
    exit

    ip dhcp pool VOICE
    network 10.10.10.100 255.255.255.0
    default-router 10.10.100.1
    dns-server 4.2.2.2
    exit

    Banner motd +

    ******************************

    Unauthorized Access Prohibited

    ******************************

    +

    Line vty 0 193
    logging synchronous
    no exec-timeout
    Username tech secret testlab
    Line vty 0 193
    login
    Login local
    Transport input ssh
    Transport output telnet ssh
    exit

    line con 0
    no exec-timeout
    service password-encryption
    line con 0
    logging synchronous
    transport output telnet
    enable secret testlab
    line con 0
    login
    exit

    Line aux 0
    logging synchronous
    exec-timeout 0 0
    Username tech secret testlab
    Line aux 0
    login
    Login local
    exit

    interface fastEthernet0
    ip address dhcp
    no shut
    exit

    interface range fastEthernet1-2
    speed 100
    duplex full
    Switchport trunk encapsulation dot1q
    Switchport mode trunk
    no shutdown
    exit

    int range fastEthernet3-7
    speed 100
    duplex full
    switchport mode access
    no shut
    exit

    int fa8
    speed 100
    duplex full
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip address dhcp
    no shut

    ip nat inside source list 1 int fa8 overload
    access-list 1 permit 10.10.10.0 0.0.0.255
    ip route 0.0.0.0 0.0.0.0 fa8

    int GigabitEthernet0
    description INTERNAL SWITCH INTERFACE CONNECTING TO THE EMBEDDED AP
    duplex full
    speed 1000
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no shut
    exit

    interface BVI1
    ip address 10.10.10.200 255.255.255.0
    no ip route-cache
    no ip directed-broadcast
    no shut
    exit

    interface Vlan 1
    description LAN VLAN
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    exit

    interface Vlan 2
    description LAN WIFI VLAN
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly

    interface Vlan 3
    description PUBLIC WIFI VLAN
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    exit

    interface Vlan 4
    description VOICE VLAN
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
     
  2. SimonD
    Honorary Member

    SimonD Terabyte Poster

    3,681
    440
    199
    Not sure if you're in the right place here, it's over my head that's for sure... we are more certification that configuration orientated here.
     
    Certifications: CNA | CNE | CCNA | MCP | MCP+I | MCSE NT4 | MCSA 2003 | Security+ | MCSA:S 2003 | MCSE:S 2003 | MCTS:SCCM 2007 | MCTS:Win 7 | MCITP:EDA7 | MCITP:SA | MCITP:EA | MCTS:Hyper-V | VCP 4 | ITIL v3 Foundation | VCP 5 DCV | VCP 5 Cloud | VCP6 NV | VCP6 DCV | VCAP 5.5 DCA

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.