Cisco 887 router error Cannot ping DNS servers

Discussion in 'Routing & Switching' started by jushin100, Apr 10, 2012.

  1. jushin100

    jushin100 Bit Poster

    15
    0
    2
    I hope someone can help. A friend of mine asked me to help him configure his Cisco router. It's the first Cisco one both of us have used before.
    We cannot get internet access.
    We do get assigned our IP address from our ISP to the ATM0 interface (and this address is pingable on a client PC).
    We get the error (using Cisco Configuration Profesional) "To test connectivity, Cisco CP tries to ping the configured DNS servers. However, there is no configured route to any of the DNS servers through the selected interface"
    But we have a configured default route. The other tests all pass; interface status:up, Checking for DNS settings:Successful, Checking interface IP address:Successful... but... gives the error above on "Checking exit interface:failed".
    We cannot ping an external address from the router.
    The network is a basic single subnet to internet which needs to eventually be setup for passthrough authentication to a MS RRAS server on 192.168.1.8
    Subnet is 192.168.1.0 255.255.255.0
    ip name-server 212.69.36.3
    ip name-server 212.69.40.3 these are the ISP's external DNS servers
    ip helper-address 192.168.1.5 this is the internal DHCP server address
    192.168.1.55 is the routers IP address assigned to VLAN 10 over FastEthernet3

    I'm only really interested in getting the internet working for the moment. We are both pulling our hair out now. Please help.

    The configuration is as below:-

    Code:
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 10
    crypto pki token default removal timeout 0
    !
    !
    ip source-route
    no ip routing
    !
    !
    no ip cef
    ip domain name NLG.local
    ip name-server 212.69.36.3
    ip name-server 212.69.40.3
    no ipv6 cef
    !
    !
    controller VDSL 0
    !
    !
    interface Ethernet0
     no ip address
     ip virtual-reassembly in
     no ip route-cache
    !
    interface ATM0
     no ip address
     ip helper-address 192.168.1.5
     no ip route-cache
     no atm ilmi-keepalive
     pvc 0/38
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
    !
    interface FastEthernet0
     no ip address
    !
    interface FastEthernet1
     no ip address
     shutdown
    !
    interface FastEthernet2
     no ip address
     shutdown
    !
    interface FastEthernet3
     switchport access vlan 10
     no ip address
    !
    interface Vlan1
     no ip address
     no ip route-cache
     shutdown
    !
    interface Vlan10
     ip address 192.168.1.55 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    !
    interface Dialer1
     ip address negotiated
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     ppp chap hostname *******************
     ppp chap password 0 *********
     ppp pap sent-username ******************** password 0 *********
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    !
    ip dns server
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 192.168.1.5 25 <external ip> 25 extendable
    ip nat inside source static tcp 192.168.1.5 80 <external ip> 80 extendable
    ip nat inside source static tcp 192.168.1.5 443 <external ip> 443 extendable
    ip nat inside source static tcp 192.168.1.250 554 <external ip> 554 extendable
    ip nat inside source static tcp 192.168.1.5 987 <external ip> 987 extendable
    ip nat inside source static tcp 192.168.1.2 1024 <external ip> 1024 extendable
    ip nat inside source static tcp 192.168.1.8 1723 <external ip> 1723 extendable
    ip nat inside source static tcp 192.168.1.2 3389 <external ip> 3389 extendable
    ip nat inside source static tcp 192.168.1.250 5000 <external ip> 5000 extendable
    ip nat inside source static tcp 192.168.1.250 8080 <external ip> 8080 extendable
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 permit gre any any
    access-list 100 permit tcp any any eq 1723
    access-list 100 permit tcp any any eq smtp
    access-list 100 permit tcp any any eq 443
    access-list 100 permit tcp any any eq 987
    access-list 100 permit tcp any any eq 3389
    access-list 100 permit tcp any any eq 1024
    access-list 100 permit tcp any any eq 5000
    access-list 100 permit tcp any any eq 554
    access-list 100 permit tcp any any eq 8080
    access-list 100 permit udp any any eq 3389
    access-list 100 permit udp any any eq 1024
    access-list 100 permit udp any any eq 5000
    access-list 100 permit udp any any eq 554
    access-list 100 permit tcp any any eq www
    dialer-list 1 protocol ip permit
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     password **********
     login
     transport input all
    !
    end
     
    Last edited by a moderator: Apr 10, 2012
  2. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Could you post an output of the "show ip route" command?
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  3. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Nevermind: delete the command "no ip routing" , then try again..
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
    danielno8 likes this.
  4. jushin100

    jushin100 Bit Poster

    15
    0
    2
    Thanks for that.
    I feel such an idiot, "no ip routing" was the default and for some reason I thought it was for inter-vlan routing.

    Thanks again.
     
  5. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Was that command preconfigured on this 887? Because that's the second time someone has this problem in a short time :)
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  6. jushin100

    jushin100 Bit Poster

    15
    0
    2
    Yes, preconfigured. I might be a Cisco newbie but I'm not a routing newb. "No IP routing" was the preconfigured value so I ignored it thinking that it must be for inter-vlan routing only. This network setup was just one subnet going to the internet so I didn't need inter-vlan routing and left the setting as it was.

    I dont quite understand why the router is preconfigured to that... I mean... you buy the router to do some routing.

    You wouldn't beleive the amount of time I spent on that and the solution was to type "IP routing".
    :oops:
     
  7. Coupe2T

    Coupe2T Megabyte Poster

    590
    43
    67
    Whilst I feel for you labouring over an issue and so forth, to find out the fix is something so simple is quite amusing!!! lol.

    Exactly the sort of thing that would happen to me though, so maybe that's why I find it so amusing.

    No offence of course, I'm sure it has been very irritating.
     
    Certifications: ECDL, Does that Count!?!

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.