1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What am I doing wrong?

Discussion in 'Routing & Switching' started by albertc30, Feb 3, 2009.

  1. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello guys and girls....

    I have done this assessment for my college course in packet tracer and now something is missing or done wrong.:oops:

    I can ping R2 from any computer.
    I can ping R1 from any computer.
    I can't ping the ISP router from any computer.
    I can ping ISP from R1.

    I am using OSPF and I have set a default route that is being advertised by OSPF.

    Why can't I ping the ISP from my local computers or from my R1?

    Here's the run info of my SW and Ro...

    R1
    *********************************************************
    R1#sh run
    Building configuration...
    Current configuration : 510 bytes
    version 12.2
    no service password-encryption

    hostname R1

    ip ssh version 1

    interface FastEthernet0/0
    ip address 172.31.1.253 255.255.255.0
    duplex auto
    speed auto

    interface Serial1/0
    ip address 172.31.4.6 255.255.255.252
    encapsulation ppp
    ip ospf priority 0
    clock rate 4000000

    router ospf 1
    log-adjacency-changes
    network 172.31.1.0 0.0.0.255 area 0
    default-information originate

    ip classless
    ip route 0.0.0.0 0.0.0.0 172.31.4.5

    line con 0
    line vty 0 4
    login

    end
    R1#

    R2
    ****************************************************
    R2#sh run
    Building configuration...

    Current configuration : 901 bytes

    version 12.2
    no service password-encryption

    hostname R2

    ip ssh version 1

    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto

    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 172.31.1.254 255.255.255.0

    interface FastEthernet0/0.2
    encapsulation dot1Q 2
    ip address 172.31.2.254 255.255.255.0

    interface FastEthernet0/0.3
    encapsulation dot1Q 3
    ip address 172.31.3.254 255.255.255.0

    router ospf 1
    log-adjacency-changes
    network 172.31.1.0 0.0.0.255 area 0
    network 172.31.2.0 0.0.0.255 area 0
    network 172.31.3.0 0.0.0.255 area 0

    ip classless

    ip dhcp pool VLan1
    network 172.31.1.0 255.255.255.0
    default-router 172.31.1.254
    ip dhcp pool VLan2
    network 172.31.2.0 255.255.255.0
    default-router 172.31.2.254
    ip dhcp pool VLan3
    network 172.31.3.0 255.255.255.0
    default-router 172.31.3.254

    line con 0
    line vty 0 4
    login

    end

    R2#

    S1
    ***************************************************
    S1#sh run
    Building configuration...

    Current configuration : 1044 bytes

    version 12.2
    no service password-encryption

    hostname S1

    interface FastEthernet0/1
    switchport access vlan 2

    interface FastEthernet0/2
    switchport access vlan 3

    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/24
    switchport mode trunk
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    ip address 172.31.1.250 255.255.255.0
    !
    ip default-gateway 172.31.1.254
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end

    S1#

    S2
    *******************************************************
    S2#sh run
    Building configuration...

    Current configuration : 1067 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname S2
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    switchport access vlan 2
    !
    interface FastEthernet0/4
    switchport access vlan 3
    !
    interface FastEthernet0/23
    switchport mode trunk
    !
    interface FastEthernet0/24
    switchport mode trunk
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
    ip address 172.31.1.251 255.255.255.0
    !
    ip default-gateway 172.31.1.254
    !
    line con 0
    !
    line vty 0 4
    login
    line vty 5 15
    login
    !
    !
    end


    S2#

    I am sorry for the length of this post but I am totally clueless of what have I done wrong.
    Any help well appreciated.
    Cheers.
     

    Attached Files:

    Certifications: CCNA
    WIP: 220-701 - A+
  2. keconnect sparky

    keconnect sparky Nibble Poster

    78
    5
    34
    I cant see any mention of NAT in your config ... so traffic will be dropped at the point of it hitting the ISP's router.
     
    Certifications: MCP, CCENT, CCNA, CCNA-S
    WIP: CCNP (ROUTE)
  3. keconnect sparky

    keconnect sparky Nibble Poster

    78
    5
    34
    Sorry ignore me, helps if i actually look at your diagram and pay attention to your question! .... ignore that comment i can see you are also simulating your ISP within your lab on private IPs
     
    Certifications: MCP, CCENT, CCNA, CCNA-S
    WIP: CCNP (ROUTE)
  4. keconnect sparky

    keconnect sparky Nibble Poster

    78
    5
    34
    I presume if you can ping the ISP router from only R1 which is directly connected to it, it must be a routing issue of some kind... like no route back to your network

    Can we see the config of the ISP router?
     
    Certifications: MCP, CCENT, CCNA, CCNA-S
    WIP: CCNP (ROUTE)
  5. albertc30

    albertc30 Kilobyte Poster

    423
    1
    37
    Hello everybody.

    Gott it finally.

    Forgot to set a default route on the ISP router.

    ip route 0.0.0.0 0.0.0.0 s1/0

    Now it works fine.

    Thanks
     
    Certifications: CCNA
    WIP: 220-701 - A+

Share This Page

Loading...