1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VPNs

Discussion in 'Networks' started by philbenson, Oct 26, 2005.

  1. philbenson

    philbenson Byte Poster

    208
    1
    20
    I have a broadband internet line which connects to a Netgear DG834GT modem router.

    Needless to say, my public IP address is dynamically assigned by my ISP (Wanadoo). My router then issues private IP addresses via NAT and DHCP. My routers internal IP address is currently set to 192.168.0.1.

    I want to set up my PC - which dual boots between Windows Server 2003 and Windows XP Pro - so that I can dial into it from a friends house using VPN. I should be able to use RRAS in Windows 2k3 Server and configure a VPN connection in XP Pro. But how would I do this?

    When running in 2K3 server mode my PC uses a static IP address of 192.168.0.2. When running in XP Pro mode it picks up an IP address from the router.

    I am running DDNS on the router and have registered a domain name to be associated with whatever IP address I get from my ISP.

    I also have a broadband modem and wondered whether I need to use that instead of the router since then my public IP address will effectively become the IP address of the PC (thus permitting direct dial-in) rather than the router.
     
    Certifications: MCP, MCP+I, MCSE, MCSA, MCTS
    WIP: CCNA(?)
  2. Neall

    Neall Byte Poster

    214
    6
    0
    You will need to setup port forwarding on the router to forward a VPN connection from your router to a computer on your network.

    You can do this by logging on to your router and going to 'firewall rules' on the left hand side and add the service.

    Sorry cant be more detailed... in a rush! :)

    EDIT: Sorry, i may have misunderstood.
    Are you having problems setting up your windows xp pro computer to accept VPN connections from your mates computer?

    EDIT2: lol right 3rd time lucky.

    To setup your XP Pro to accept an incomming VPN connection go to network connections in control panel.

    Create a new connection.

    Click on - Setup an advanced connection.

    Select - Accept incomming connections.

    Ignore next screen. Click next.

    Select - Allow virtual private connections.

    Setup your premissions and that should be it.

    Setup port forwarding on the router as i said, if you are going to connect through that.

    Create a new connection on your mates computer but select 'Connect to a network at my workplace' and work through it like before.

    And that should be that. Sorry for the confusion :)

    Neall
     
    WIP: A+

Share This Page

Loading...