1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VLAN access-list help

Discussion in 'General Cisco Certifications' started by akuma6099, Apr 12, 2006.

  1. akuma6099

    akuma6099 New Member

    1
    0
    1
    I've been banging my head for a couple days now trying to get my access-list working on a vlan. I have a catalyst WS-2924XL-EN with 24 FastEthernet ports. I'm quite confused being that most of the tutorials/cbts/docs all refer to interface e0 for configuring access lists and ip specs. My switch doesn't have these options. I can't configure ip settings per fa port. The only thing I can think of is setting up a vlan and using ip access-group... commands to get my lists working. So far its pretty basic.

    interface VLAN2
    ip address 192.168.1.25 255.255.255.0
    ip access-group 100 in
    ip access-group 100 out
    !
    interface FastEthernet0/1
    switchport access vlan 2
    ..............................
    interface FastEthernet0/24
    switchport access vlan 2
    !
    ip default-gateway 192.168.1.1
    access-list 100 deny tcp any any eq www
    ............


    Can anyone clear this up? fa 0/24 is uplink.
     
  2. simongrahamuk
    Honorary Member

    simongrahamuk Hmmmmmmm?

    6,199
    125
    199
    Have you specified in your config that the switch port mode is access? i.e.

    interface FastEthernet0/10
    switchport mode access
    switchport access vlan 2

    Going from memory here, haven't configured vlans for a long time!

    :blink
     
  3. MarkN

    MarkN Nibble Poster

    79
    3
    15
    Certifications: MCSE NT4\W2K,CNE,CCEA,ASE
    WIP: CCNA
  4. r.h.lee

    r.h.lee Gigabyte Poster

    1,011
    52
    105
    akuma6099,

    Do you know if your switch uses CatOS or Cisco IOS?
     
    Certifications: MCSE, MCP+I, MCP, CCNA, A+
    WIP: CCDA

Share This Page

Loading...