1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Two public IP's from the same subnet on an ASA Version 8.0(5)

Discussion in 'Internet, Connectivity and Communications' started by oval, Jan 6, 2010.

  1. oval

    oval New Member

    1
    0
    1
    I need to use two public IP's from the same subnet on an ASA Version 8.0(5). I receive the following error: The IP address, ......, cannot overlap with the subnet of interface......
    Please help me.
     
  2. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    What do you need the two ip addresses for? If it is for nat translations or other services, just create the appropriate statics and access-list permissions. You cannot assign two ip addresses to an interface (although there are some unsupported possible workarounds).

    E.g.:
    interface e0/0
    nameif outside
    security-level 0
    ip address 10.10.10.1 255.255.255.248
    ip address 10.10.10.2 255.255.255.248

    The above does not work. Instead use the following example:

    interface e0/0
    nameif outside
    security-level 0
    ip address 10.10.10.1 255.255.255.248

    static (inside,outside) tcp 10.10.10.2 www 192.168.16.10 www netmask 255.255.255.255
    static (inside,outside) 10.10.10.3 192.168.16.20 netmask 255.255.255.255
    static (inside,outside) 10.200.200.20 192.168.16.200 netmask 255.255.255.255

    Using the above config the ASA will handle traffic destined to 10.10.10.1, 10.10.10.2, 10.10.10.3 and 10.200.200.20 that arrives inbound on the outside interface. Of course, access-lists, nat-control, etc. need to be configured.


    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE

Share This Page

Loading...