tftp-server issue

Discussion in 'Voice' started by Septima77, Oct 7, 2009.

  1. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Not really a question but something you should be aware of:
    According to the Official Exam Certification guide by Cisco on page 120 it states:
    "The alias syntax that follows the tftp-server command allows the firmware file to be requested simply by asking for the aliased filename. This is necessary in the newer CME versions which organize the firmware files into subdirectories."
    This will lead you to believe that if you don't use directories and put everything in the flash root directory, you don't need the alias command. Right?
    Wrong!

    My 7940G IP phones could not find the RingList.xml and DistinctiveRingList.xml files to set other than default ringtones. These xml files and the associated ringtone files had been placed in flash root directory (flat).

    When I turned on debug tftp events, I could see the tftp server was looking for the file, but could not find it. The IP phone showed the message: Ring List Unavailable or Distinctive Ring List Unavailable.

    The way I got it to work was by entering the following commands

    2611xm_Voice#sh run | s tftp
    tftp-server flash:P00307020200.bin
    tftp-server flash:P00307020200.loads
    tftp-server flash:P00307020200.sb2
    tftp-server flash:P00307020200.sbn
    tftp-server flash:/RingList.xml alias RingList.xml
    tftp-server flash:/DistinctiveRingList.xml alias DistinctiveRingList.xml
    tftp-server flash:/24ctu.raw alias 24ctu.raw
    tftp-server flash:/Analog1.raw alias Analog1.raw
    tftp-server flash:/Chime.raw alias Chime.raw
    tftp-server flash:/Jamaica.raw alias Jamaica.raw
    tftp-server flash:/Pop.raw alias Pop.raw

    Not sure if this is a bug. But my method is a workaround.
    I use cme 3.3. My poor old c2611xm router could not handle 4.1 as it run out of memory and crashed, corrupting flash and showing the infamous ROMMON 1> prompt of death after reboot.

    I have one more issue to solve and then I am ready to take the exam.
    Music on Hold cannot be heard between my 7940's. I can hear it on my analog phones on the FSX ports when I call from the 7940 and place the call on hold.
    I use default g.729 codec, set the multicast IP address, port and even the routes to the the 7940's. But it will not work. Have to do some deeper digging. :)
     
    Last edited: Oct 7, 2009
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  2. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Update:
    The MOH between IP phones registered on the same CME router is not supported until CME version 4.0.
    Instead, the Tone on Hold (ToH) can be heard.
    I can see now why Troubleshooting IPT is a separate course and exam.
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  3. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    What's your MoH config look like? Are you using multicast MoH? If so, what multicast addy?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  4. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Hi BosonMichael,

    The topology at my home is like the one in the book (Official Exam Certification Guide, Ciscopress.com)
    with the exception that I use one switch instead of two

    The MOH info from Cisco is here http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmemoh.html#wp1012460

    and here is my running config of the cme router

    Cisco IOS Software, C2600 Software (C2600-IPVOICE_IVS-M), Version 12.4(21a), REL
    EASE SOFTWARE (fc1)

    2611xm_Voice#sh run
    Building configuration...

    Current configuration : 4414 bytes
    !
    ! No configuration change since last restart
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 2611xm_Voice
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    clock timezone NL 2
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    username xxxxx password 5 xxxxxx
    username xxxxx password 5 xxxxxxx level 15
    !
    class-map match-all IP_PHONE_DATA
    match protocol rtp
    !
    policy-map MARK_VOICE
    class IP_PHONE_DATA
    set ip precedence 5
    !
    interface Loopback0
    ip address 192.168.3.1 255.255.255.0
    !
    interface FastEthernet0/0
    no ip address
    speed auto
    full-duplex
    !
    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 10.10.10.1 255.255.255.0
    ip helper-address 172.16.2.5
    !
    interface FastEthernet0/0.10
    description R_INTERF_VOICE_VLAN
    encapsulation dot1Q 10
    ip address 172.16.1.1 255.255.255.0
    ip access-group 101 out
    ip helper-address 172.16.2.5
    ip nbar protocol-discovery
    service-policy input MARK_VOICE
    !
    interface FastEthernet0/0.50
    description R_INTERF_DATA_VLAN
    encapsulation dot1Q 50
    ip address 172.16.2.1 255.255.255.0
    !
    interface FastEthernet0/0.100
    description TO_INTERNET_ROUTER
    encapsulation dot1Q 100
    ip address 192.168.1.230 255.255.255.0
    !
    interface Serial0/0
    bandwidth 128
    ip address 10.1.1.1 255.255.255.0
    clock rate 128000
    !
    interface FastEthernet0/1
    ip address 192.168.2.1 255.255.255.0
    ip access-group 10 in
    duplex auto
    speed auto
    !
    router rip
    network 172.16.0.0
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    ip http server
    ip http authentication local
    !
    access-list 10 permit 192.168.2.51
    access-list 101 deny ip 172.16.2.0 0.0.0.255 172.16.1.0 0.0.0.255
    access-list 101 permit ip any any
    !
    tftp-server flash:P00307020200.bin
    tftp-server flash:P00307020200.loads
    tftp-server flash:P00307020200.sb2
    tftp-server flash:P00307020200.sbn
    tftp-server flash:/RINGLIST.XML alias RingList.xml
    tftp-server flash:/DistinctiveRingList.xml alias DistinctiveRingList.xml
    tftp-server flash:/24ctu.raw alias 24ctu.raw
    tftp-server flash:/Analog1.raw alias Analog1.raw
    tftp-server flash:/Chime.raw alias Chime.raw
    tftp-server flash:/Jamaica.raw alias Jamaica.raw
    tftp-server flash:/Pop.raw alias Pop.raw
    !
    control-plane
    !
    voice-port 1/0/0
    station-id name ANALOG_PROFOON
    station-id number 3010
    caller-id enable
    !
    voice-port 1/0/1
    station-id name PHILIPS_HANDSET
    station-id number 3020
    caller-id enable
    !
    ccm-manager music-on-hold
    !
    dial-peer voice 3000 voip
    destination-pattern 3000
    session target ipv4:172.16.2.5
    !
    dial-peer voice 3010 pots
    destination-pattern 3010
    port 1/0/0
    !
    dial-peer voice 3020 pots
    destination-pattern 3020
    port 1/0/1
    !
    gatekeeper
    shutdown
    !
    telephony-service
    load 7960-7940 P00307020200
    max-ephones 4
    max-dn 12
    ip source-address 192.168.3.1 port 2000
    auto assign 1 to 5
    network-locale NL
    time-format 24
    date-format dd-mm-yy
    create cnf-files version-stamp 7960 Mar 02 2002 02:26:00
    max-conferences 4 gain -6
    moh music-on-hold.au
    multicast moh 239.1.1.55 port 2123 route 172.168.1.10 172.168.1.11

    web admin system name Admin password cisco
    dn-webedit
    time-webedit
    transfer-system full-consult
    login timeout 120 clear 23:30
    !
    !
    ephone-dn 1 dual-line
    number 1001
    name Bill
    !
    ephone-dn 2 dual-line
    number 1002
    name Ann
    !
    ephone-dn 3 dual-line
    number 1003
    name Laurence
    !
    ephone-dn 4 dual-line
    number 1004
    name Oliver
    !
    ephone-dn 5 dual-line
    number 1005
    name Meryll
    !
    ephone-dn 10
    number A100
    intercom A101 label "Manager"
    !
    ephone-dn 11
    number A101
    intercom A100 label "Assistant"
    !
    ephone 1
    mac-address 0021.8510.255B
    type CIPC
    button 1:1 8:11
    pin 0000
    !
    ephone 2
    mac-address 0021.7077.F37A
    type CIPC
    button 1:2 8:10
    pin 0000
    !
    ephone 3
    mac-address 0013.80AD.FC26
    type 7940
    button 1:1 2:11
    pin 0000
    !
    ephone 4
    mac-address 000D.29E7.74C5
    type 7940
    button 1:2 2:10
    pin 0000
    !
    alias exec traffic show ip nbar protocol-discovery stats bit-rate top-n 10
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    logging synchronous
    line vty 0 4
    login
    line vty 5 15
    login
    !
    ntp master
    ntp server 193.79.237.30
    ntp server 80.127.4.179
    !
    end
     
    Last edited: Oct 7, 2009
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  5. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    If I'm not mistaken, the route keyword of the multicast moh command requires that you specify one or more IP addresses of router interfaces. I don't see any of your interfaces that use 172.168.1.10 or 172.168.1.11.

    Even if that command works with IP addresses other than router interfaces, your addressing scheme is using 172.16.x.x and 192.168.x.x addresses - not 172.168.x.x.

    Hope this helps. :)
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  6. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Thank you for your help, much appreciated.

    You have a keen eye for details; there was indeed a typo in the route command.
    I changed it to the address of 172.16.1.1 which is the subinterface of the trunk under Fa0/0.
    That did not work, so tried 172.16.1.0 which is the subnet (according to cisco's exact wording) and that did not work either. And is not supposed to since I am on cme 3.3.

    So changed the image on the router that supports cme 4.0, but I don't have the cme 4.0 firmware files at home.

    So this has to wait until tomorrow and hope that I can find a copy at my work or maybe I can download the file since they have a smartnet contract.

    Will keep you posted.
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  7. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    T'is a necessary condition relating to the nature of my employment. ;) Glad to be of help.

    You don't HAVE to use the route command at all... it's optional. :)
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  8. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    So, changed to cme 4.0 with an advanced enterprise 12.4(9)T image on my c2611xm router (you need 48 MB flash for this) and updated the firmware and changed the moh settings to:
    multicast moh 239.1.1.1 port 2000 route 172.16.1.0

    And voila! I have MoH between my 7940G IP phones. :)

    Cisco recommends using port 2000 since it is already used for RTP.
    172.16.1.0 is the subnet address of my interface where the phones are connected. (Fa0/0.10)
    Great!
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  9. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    Excellent! Didn't know that it would work with the subnet address, but it's cool to find out that it does.

    You don't HAVE to use port 2000, but you are correct that it is what Cisco recommends. :)
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  10. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  11. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  12. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Here is another item on moh that is quit interesting:
    for those who paid attention to my config file of my cme router, you will have noticed that I did not specify the codecs on the voip dial-peers. So, G.729 is being used by default.
    This will give you moh on registered ip phones and to analog phones on the local fxs ports.

    It will not stream the moh over the wan link!
    In order to stream moh over the serial wan link you have to specify a g711 codec, alaw or ulaw, or else you will hear a garbled noise on the phones on the remote router (or PSTN).
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP
  13. BosonMichael
    Honorary Member Highly Decorated Member Award 500 Likes Award

    BosonMichael Yottabyte Poster

    19,183
    500
    414
    Is it because G.729 doesn't sample enough?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  14. Septima77

    Septima77 Nibble Poster

    72
    0
    33
    Well, that is a very good question.
    And the amount of sampling must play a roll here.
    What really puzzles me is why does it work OnNet but not OffNet?

    Cisco's cmemoh.pdf states:
    "When the phone receiving MOH is part of a system that uses a G.729 codec, transcoding is required between G.711 and G.729. The G.711 MOH must be translated to G.729. Note that because of compression, MOH using G.729 is of significantly lower fidelity than MOH using G.711. For information about transcoding, see "Configuring Transcoding Resources" on page 317. "

    Apparently, the moh.au file is G.711 native and can be locally transcoded.
    For offnet calls, I assume, you need a router with transcoding dsp's (those can be found on NM-HDV modules, works with 2800 series and up). Mind you, not sure about this.

    Page 317:
    "Transcoding Support

    Transcoding compresses and decompresses voice streams to match endpoint-device capabilities. Transcoding is required when an incoming voice stream is digitized and compressed (by means of a codec) to save bandwidth, and the local device does not support that type of compression.

    Cisco CME 3.2 and later versions support transcoding between G.711 and G.729 codecs for the following features:
    - ....
    - Music on hold (MOH)—The phone receiving MOH is part of a system that uses G.729. The G.711 MOH is transcoded into G.729 resulting in a poorer quality sound due to the lower compression of G.729. "

    I guess this will be dealt with further on in the CCVP track

    What is funny, when you study the official exam guide, everything pans out as long as you have a 2801 router and a 3550 switch. Both of them are beyond my financial capabilities. As a consequence of getting by with cheaper alternatives, you run in all kinds of obstacles that actually forces you to go beyond the stuff in the book. And maybe will make you a better admin. :)
     
    Certifications: CCNA CCNAS CCNAV
    WIP: CCVP

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.