1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

switch configs

Discussion in 'Routing & Switching' started by insurin, Feb 19, 2008.

  1. insurin

    insurin Bit Poster

    23
    0
    2
    Hello people

    I have inherited a Cisco network and although I have done my CCNA I have not had much hands on in a real live environment so am still new to this.

    Just browsing the configs of several switches, all ports within the switch have the lines

    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 200
    switchport mode trunk
    switchport voice vlan 20
    spanning-tree portfast

    for each corrsponding port

    I have a few questions.

    1. I think I undertsand the bit about native vlan, but if some could explain that would be great.

    2. the line 'switchport mode trunk' is set on every port in the config and its like this on a lot of other switches too, but some configs just have 'switchport mode access' and 'switchport access vlan vlan_number'

    what I am askin here is: I would have thought you would just make 2 ports for trunking, for example if I have 2 fibre ports, I would just set them to be the trunks and the rest of the ports would be switchport mode access.
    So if all the ports are set to ' switchport mode trunk', does this not mean that all ports are acting as trunk ports and are forwarding traffic to other switches out on all ports.

    forgive me if this reads stupid.
     
  2. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    1. The native VLAN is the management VLAN. Frames on this VLAN are not tagged.

    2. Depends on what's hooked to each port. If you've got host computers hooked to each port, you are right - those should be access ports. Trunk ports are to trunk multiple VLANs across a link, typically between switches.
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  3. insurin

    insurin Bit Poster

    23
    0
    2
    coming out of the ports are just standard hosts (PC's), so going off what you have told me, I will get 1 switch and change all these trunks to 'access' apart from 2 for trunking. The reason I started to look into the configs was because when ghostcasting whether it was multicasting or just normal ghosting, the network was operating very slow even when nobody was in.for example, I can ghost from one floor and achieve speeds of 500-600mbps but at certain points on the network I can only get around 100mbps.
    So after looking at configs and seeing as the majority are set to trunk ports is the network being pounded with more bandwidth than it should be, if all the trunk ports are sending data out on every port it must be creating a lot of traffic?
     
  4. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    One of the classic reasons for slow links is full-duplex not being set. Some switches have problems with some NICs, and often the full-duplex setting has to be set, rather than to 'auto'.

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  5. insurin

    insurin Bit Poster

    23
    0
    2
    ok, good information, I will make changes over the next couple of days and report back the results.
     
  6. insurin

    insurin Bit Poster

    23
    0
    2
    Would I be setting duplex/auto etc on the port that the ghost server resides on, on an individual basis, e.g.

    I have a 6500 catalyst core switch and a load of 3500/2900 switches. The ghost server is on the module 3/6 on the 6500 (should I make the setting to auto neg/fd/hd here on this interface?

    or

    set them all on the indivdual ports of the 3500/2900 switches
     
  7. hbroomhall

    hbroomhall Petabyte Poster Gold Member

    6,623
    115
    224
    Note that I am *not* an expert on individual switches! It is just that nearly 100% of slowdowns I have experienced at work are due to the full-duplex problem.

    It has always been fixed by setting the individual port that had the problem.

    Harry.
     
    Certifications: ECDL A+ Network+ i-Net+
    WIP: Server+
  8. insurin

    insurin Bit Poster

    23
    0
    2
    from what I have been reading from the 'Cisco config Guide' there are 2 methods for enabling trunking. I have not mentioned that I do run a load of Cisco 7940/11/60s and have pc's hooked onto these as well as just having computers running off the ports.


    > Config 1 (trunked)

    > interface FastEthernet0/2
    > switchport access vlan 200
    > switchport trunk encapsulation dot1q
    > switchport trunk native vlan 200
    > switchport mode trunk
    > switchport voice vlan 20
    > no ip address
    > spanning-tree portfast

    > Config 2 (non-trunked)

    > interface FastEthernet0/2
    > switchport access vlan 200
    > switchport mode access
    > switchport voice vlan 20
    > no ip address
    > spanning-tree portfast

    My vlan for voice is 20 and I would need the computers running off the phone to be assigned to the native vlan so it gets the right IP address from our DHCP server via ip helper address.

    Looking at the 2 configs above, would both of these work for me or would I have to use config 1 as this states the 'native vlan'
     

Share This Page

Loading...