1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SSH problem, not letting me log into the switch

Discussion in 'Routing & Switching' started by BraderzTheDog, Mar 21, 2012.

  1. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Hello peoples of CF,

    This may be a really straight forward answer to my question but i've been googling over an hour with no success! :@

    I've been studying the CCNA and have been doing switch config all morning, after setting up a user account on my 2950, and enabling SSH in the relevant VTY's still not letting me in!

    Working fine over telent but, as soon as I attempt a SSH session my username is accepted but the password im using is just thrown back. I've generated the RSA keys in both 512 and 1024k but this doesn't seem to help either.

    So frustrating but It would be awesome if you guys could point me in the right direction, I am a novice and have been working through the CBT Nuggets vid's :)

    VT prog im using is Terra Term,

    Thanks in advance,

    Brad.
     
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+
  2. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Can you post your config?
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  3. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Hey Simon, sure poped it below. Thanks!

    Code:
    Password:
    BradSwitch>en
    Password:
    BradSwitch#show runn
    BradSwitch#show running-config
    Building configuration...
    
    Current configuration : 1751 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname BradSwitch
    !
    enable secret 5 $1$FwfV$9b82z4LJixBrbKVRRVbmq1
    !
    username Brad password 7 0236050E5E115F3348
    username Administrator password 7 0306490A02
    ip subnet-zero
    !
    ip domain-name cbtnuggets.com
    ip ssh time-out 120
    ip ssh authentication-retries 3
    ip ssh version 2
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    !
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface Vlan1
     ip address 192.168.0.30 255.255.255.0
     no ip route-cache
    !
    ip default-gateway 192.168.0.1
    ip http server
    banner motd ^C
    ******************************************
    BRAD Network Switch, Unauthorised access
    is strickly prohibited. Authorised users
    accept logon terms by entering credentials
    ******************************************^C
    !
    line con 0
     password 7 073F20191B1E491713
     login
    line vty 0 1
     password 7 073F20191B1E491713
     login
     transport input telnet ssh
    line vty 2 4
     login
     transport input telnet ssh
    line vty 5 15
     login
    !
    !
    end
     
    Last edited by a moderator: Mar 22, 2012
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+
  4. toshiba145

    toshiba145 Nibble Poster

    54
    1
    15
    add this line
    aaa authentication ssh console LOCAL
     
    Certifications: A+, CCNA
    WIP: MCITP
  5. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Have you generated your RSA keys already?

    crypto key generate rsa

    BTW: I have two 2950's in my home lab, but they didn't support SSH afaik.
     
    Last edited: Mar 23, 2012
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  6. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Thanks for the advise guys, however still not able to work. I've generated the RSA keys under 512Kb encrypton still not working :@

    I think you might have hit it Simon if you have the same switches and they dont support SSH! Dayum If I'd have read the specs I might not have wasted all this time.

    Thanks for all your help guys, turns out to be a 'blonde' moment as it were.

    Regards,
    Brad.
     
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+

Share This Page

Loading...