1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Resolved SBS2008 Auto Discover

Discussion in 'Software' started by westernkings, Oct 13, 2010.

  1. westernkings

    westernkings Gigabyte Poster

    1,432
    60
    107
    Hi guys,

    Can someone explain WHAT steps are supposed to be taken when setting up an SBS2008 box in order to make AutoDiscover (and therefore, out of office in Outlook 2007) work? What exactly is supposed to be set up if a company doesn't want any external email access through a website.

    Right now, this is the second box that has had the problem of Outlook 2007 + not being able to set out of office on.

    [​IMG]

    That's the current issue for only Outlook 2007 and Above users. There was nothing out of the ordinary at set up that could of done it, updates were performed etc. What has been missed exactly?

    Also, how on earth does this get fixed now?
     
    Last edited: Oct 14, 2010
    Certifications: MCITP:VA, MCITP:EA, MCDST, MCTS, MCITP:EST7, MCITP:SA, PRINCE2, ITILv3
  2. ianconscious

    ianconscious Bit Poster

    39
    5
    37
    To enable Outlook to communicate with Exchange Web Services properly, thereby allowing access to the Out of Office Assistant; Free/Busy information; the Offline Address Book; enabling editing of Shared Calendars, etc. you need to tick this box within the Outlook profile settings:

    [​IMG]

    Doing so, however, will result in nagging warning messages when you open Outlook and periodically throughout the day as you use the software as the Exchange Server does not have a properly configured Subject Alternate Name (SAN) Certificate on it.

    Versions of Outlook prior to Office 2007 used a different (less secure) method of connecting to Exchange, so this issue does not occur for users of Outlook 2003 (for example). Outlook 2007 relies on HTTPS connections to the Exchange Web Services!

    What you need to do is configure an internal Certification Authority (CA) on your network, generate a SAN Certificate for Exchange, bind it to the relevant Exchange Virtual Directories and import this Certificate to the Trusted Certificate Store on each PC with Outlook installed. If you have a third-party SSL Certificate, leave it on the server for inbound connections to Remote Web Workplace, you'll need to carefully adjust the settings to ensure the two will happily co-exist.

    There’s a fair bit of work involved in correcting this. It is not particularly difficult to do, however due to the complexities of the software components involved, careful planning and thorough testing will be necessary.

    Let me know if you need a hand, and good luck!
     
    Certifications: MCSE; MCITP; CCA, etc.
    WIP: JNCIS-FWV
  3. westernkings

    westernkings Gigabyte Poster

    1,432
    60
    107
    That box was already ticked. However it now appears to be working, I did quite a lot of tinkering earlier today as did 2 other engineers. It really is an odd one, it's something you take for granted as well and not one of them features that you think "there something that needs to be set up".

    With SBS 2008, are you expected to run through all of the wizards in the SBSConsole (IE Set up internet domain presence) etc?

    Autodiscover still comes up with the same message as above, except out of office actually turns on and doesn't respond with server unavailable. Any insight?

    Cheers mate.
     
    Certifications: MCITP:VA, MCITP:EA, MCDST, MCTS, MCITP:EST7, MCITP:SA, PRINCE2, ITILv3
  4. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  5. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,191
    299
    319
    Gah! I had the same problem when I did a full Windows Server 2003 domain migration to SBS 2008.

    <thinks> :oops:

    Now what did I do again? :biggrin
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  6. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,191
    299
    319
    Ok, it was the autodiscover virtual directory in IIS not having SSL enabled that was the problem.

    Edit: also make sure the URL you have in there resolves correctly to the SBS on the LAN.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  7. dazza786

    dazza786 Megabyte Poster

    758
    30
    67
    YES :dry

    I've had this problem many a time. Solved by running configure sites, ensure the cert is correct and throwing exchange SP2 on
     
    Last edited: Oct 13, 2010
    Certifications: MCP (271, 272, 270, 290, 291, 621, 681, 685), MCDST, MCTS, MCITP, MCSA, Security+, CCA(XA6.5)
  8. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,191
    299
    319
    SP3, no? :biggrin
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  9. westernkings

    westernkings Gigabyte Poster

    1,432
    60
    107
    Well, I rolled out SP2 after going through and configuring all of the settings manually via EM Shell and IIS Management. Seems to be fully fixed now. Interesting that you can't actually install SP2 without the special installation tool because it doesn't work.

    Thanks all of the help gents.
     
    Certifications: MCITP:VA, MCITP:EA, MCDST, MCTS, MCITP:EST7, MCITP:SA, PRINCE2, ITILv3

Share This Page

Loading...