1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Routing traffic between GE0/0 and GE0/1

Discussion in 'Networks' started by aserapig, Jan 23, 2012.

  1. aserapig

    aserapig New Member

    4
    0
    1
    I managed to get my hands on a 2901 series router but without any added modules. Can I route traffic between the GE0/0 and GE0/1 interfaces?

    I.E. Can I assign the GE0/0 interface a public IP (77.77.77.77 for example) and GE0/1 a private IP (10.1.1.1 for example) and pass traffic from a device with 10.1.1.2 plugged into GE/01 to a device with 77.77.77.78 plugged into GE0/0?
     
  2. Cunningfox

    Cunningfox Byte Poster

    219
    6
    27
    One word answer: yes :).
     
    Certifications: CCNP, CCNA, MCP
    WIP: ??
  3. aserapig

    aserapig New Member

    4
    0
    1
    I can't even begin to say how great a relief this is. The long part of the story is that I am a professor in my first year and have been tasked with setting up a practical lab. I convinced them that we really would benefit from having hands on equipment rather than relying on simulators like so many other schools. As always happens, you want to shoot for the best, but then funding doesn't allow.... I was pretty scared I would have to go back again and say we needed to purchase an HWIC at a few hundred extra...

    Either way, my practical background is with Fortigate routers from Fortinet, and other SOHO (Small Office / Home Office) Routers like SonicWall and WatchGurad and the like. I have been in a fair amount of Cisco stuff, but always troubleshooting and adding features and rules, not from scratch setup. I know my way around routers, but need to get specialized on these products to best teach some skills. Hopefully I can find enough time to get myself a cert along the way as well....

    Thanks again - hopefully I can contribute to this forum in my own way soon.....
     
    Last edited: Jan 23, 2012
  4. aserapig

    aserapig New Member

    4
    0
    1
    Trying to get this to work.... Please help!

    In general:
    GE0/0 is 77.77.77.77
    GE 0/1 is 10.1.1.1
    I can generate a ping from 10.1.1.1 and get reply from 77.77.77.77
    I can not get response in pinging 77.77.77.78 (PC plugged into GE0/0 that does respond to pings...)
    I have set the default route to use GE0/0

    So how come I can't ping from 10.1.1.1 to 77.77.77.78?


    AGS#show config
    Using 1576 out of 262136 bytes
    !
    ! Last configuration change at 01:54:31 UTC Tue Feb 21 2012 by admin
    ! NVRAM config last updated at 02:08:51 UTC Tue Feb 21 2012
    ! NVRAM config last updated at 02:08:51 UTC Tue Feb 21 2012
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname AGS
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 5 $1$n9TK$fXXMUtJopTrV3iwPLXyPW0
    enable password cisco
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    no ip routing
    no ip cef
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    !
    license udi pid CISCO2901/K9 sn FTX1601819R
    !
    !
    username admin privilege 15 password 0 Rajah424!
    !
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
    no ip address
    no ip route-cache
    shutdown
    !
    interface GigabitEthernet0/0
    description $ES_WAN$
    ip address 77.77.77.77 255.255.255.0
    no ip route-cache
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    description $ES_LAN$
    ip address 10.1.1.1 255.255.255.0
    no ip route-cache
    duplex auto
    speed auto
    no mop enabled
    !
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    !
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
    !
    !
    !
    snmp-server community public RO
    !
    control-plane
    !
    !
    !
    line con 0
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    password no
    login
    transport input all
    !
    scheduler allocate 20000 1000
    end
     
  5. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Are your PC devices plugged directly into the router? You might need a crossover to get that connection working.

    Also, did you setup your client devices with the correct IP settings, specifically the default gateway?
     
    Last edited: Feb 21, 2012
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  6. aserapig

    aserapig New Member

    4
    0
    1
    Yes, client with the 77.77.77.78 address has the 77.77.77.77 interface set as it's gateway. Also, it can ping to the 77.77.77.77 address.

    I have a putty session tot he config, but also the http GUI up and connecting to it on the 77.77.77.77 address from that client so I think that would rule out the cross over cable.

    Have to drop the kids at school and head into my school, so will give it a try once I get to my office.

    Does the config look OK though?
     
  7. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Last edited: Feb 21, 2012
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  8. jonny7_2002

    jonny7_2002 Byte Poster

    191
    9
    37
    the "no ip routing" will be your problem as the router is NOT routing.
    To confirm this, if you type a "show IP route" it will not show a gateway of last resort at the top or any other routing information for that matter!

    Go into global config mode and tyope "ip routing"
    Then do a "show ip route" and you should see comething like this.....
    877#show ip rout
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    x.x.x.x/32 is subnetted, 1 subnets
    C x.x.x.x. is directly connected, Dialer1
    x.x.x.x/32 is subnetted, 1 subnets
    C x.x.x.x is directly connected, Dialer1
    10.0.0.0/24 is subnetted, 2 subnets
    C 10.172.3.0 is directly connected, Vlan1
    192.168.1.0/30 is subnetted, 1 subnets
    S* 0.0.0.0/0 is directly connected, Dialer1


    Something along those lines!

    Good luck!
    Jon
     
    Certifications: CCNA R&S, CCNP R&S, CCDA, CCNA Voice, CCNA Wireless & CCNA Security
    WIP: CCIE V5 (when its out)

Share This Page

Loading...