1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router login issue over telnet for SDM

Discussion in 'Routing & Switching' started by BraderzTheDog, Apr 16, 2012.

  1. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Hello there,

    I've been recently studying the CCENT as some may know and have come across problems no end when setting up security be it on a switch or router now.

    I believe my setup doesn't actually support SSH as when trying to setup an account for SDM on my router I can only setup the HTTP services and not HTTPS (no biggie, im using 2600 series cheap from ebay so im guessing it doesn't support SSH access).

    Anyway im trying to configure DHCP via the SDM as its required for the exam im sitting in a week, but the user account I created for telent sessions will not allow me to even login can someone tell me where im going wrong?

    Im using the username: admin / password:password (super simple) and when telnetting to the router is just giving me invalid credentials prompt!@!

    My config is below, im sure you guys will find the error somewhere :)

    Thanks!

    R01#
    R01#
    R01#
    R01#en
    R01#conf t
    R01#conf terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    R01(config)#line vty ?
    <0-15> First Line number

    R01(config)#line vty 0 15
    R01(config-line)#login ?
    local Local password checking
    tacacs Use tacacs server for password checking
    <cr>

    R01(config-line)#login local
    R01(config-line)#do show running-config
    Building configuration...

    Current configuration : 1137 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R01
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$Jrrv$GnbBPu1LN0dIVkRgM7pTm.
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    ip domain name home.com
    !
    !
    username admin password 0 password
    !
    !
    !
    interface Ethernet0/0
    description ETHERNET SWITCH PORT
    ip address 192.168.0.1 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface BRI0/0
    no ip address
    encapsulation hdlc
    shutdown
    !
    ip http server
    ip http authentication local
    ip classless
    !
    !
    banner motd ^C
    ****************************************************
    This is a secure router any unauthorised access is
    DENIED!
    ****************************************************
    ^C
    !
    line con 0
    exec-timeout 30 0
    password Pa55w0rd
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 20 0
    password Pa55w0rd
    logging synchronous
    login local
    transport input telnet
    line vty 5 15
    exec-timeout 20 0
    password Pa55w0rd
    logging synchronous
    login local
    transport input telnet
    !
    !
    end

    R01(config-line)#
     
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+
  2. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    Instead of "login local", could you just try the usual "login" command under the line vty 0 to 4 ?
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  3. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Sorted the problem, thanks for putting me in the right direction Si :)
     
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+
  4. Simonvm

    Simonvm Kilobyte Poster

    472
    13
    41
    What config was causing it? :)
     
    Certifications: MCITP: EST, MCDST, MCTS, A+, N+, CCNP, CCNA Wireless
  5. BraderzTheDog

    BraderzTheDog Kilobyte Poster

    276
    2
    49
    Well I tried using login, but it didn't request me for a username only a password. So I ripped the config and re added it.

    *Username Brad privilege 15 password password*

    Then jumped under the VTY lines and used login local and worked! :)

    I think the problem was the first time round I didn't specify the privilege level of the user account.

    Thanks anyway Simon, made me realise in the end!

    Rep +

    Regards,
    Brad.
     
    Certifications: CCNA R&S, CCNA-SEC, CCSA, JNCIA FWV, MCITP, MCTS, MTA, A+

Share This Page

Loading...