1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Router Config help please!

Discussion in 'Routing & Switching' started by HayleyK, Oct 24, 2007.

  1. HayleyK

    HayleyK New Member

    3
    0
    1
    Hi

    I've recently started working with routers so at he moment my experience is very limited. I've been given a config to look over as it's not connecting to the internet. I can't see anything jumping out at me as wrong, would anyone else mind taking a look and giving me any advice they have?

    Here's the config:

    *******#sh run
    Building configuration...

    Current configuration : 2341 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    service password-encryption
    !
    hostname dummyuser
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret **********.
    !
    no aaa new-model
    !
    resource policy
    !
    no ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.215.1.1 10.215.1.50
    !
    ip dhcp pool company name
    import all
    network 10.215.1.0 255.255.255.0
    default-router 10.215.1.1
    dns-server 10.1.1.1 10.1.1.3
    netbios-node-type b-node
    lease 0 23 59
    !
    !
    ip cef
    ip tftp source-interface Loopback10
    no ip domain lookup
    !
    !
    !
    username <username> password **********
    !
    !
    !
    !
    !
    interface Loopback10
    no ip address
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0/38
    ubr 288
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 10.215.1.1 255.255.255.0
    !
    interface Dialer1
    bandwidth 2000
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    no cdp enable
    ppp chap hostname dummyusers@companyname.com
    ppp chap password **********************
    !
    interface Dialer0
    no ip address
    !
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    ip http server
    no ip http secure-server
    !
    access-list 101 permit ip any any
    !
    control-plane
    !
    banner exec ^CCCC
    *********************************************

    Company name
    -------------------
    Dummy users MX user

    *********************************************



    ^C
    banner motd ^CCCC




    THIS DEVICE IS PART OF A
    ------------------------

    PRIVATE NETWORK
    ---------------


    ************************************************
    * Unauthorised access or use of this equipment *
    * is prohibited and constitutes an offence *
    * under the Computer Misuse Act 1990. *
    * If you are not authorised to use this *
    * system, terminate this session now. *
    ************************************************


    ^C
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password ***********
    login
    !
    scheduler max-task-time 5000
    end

    dummyuser#


    Thanks in advance,
    Hayley
     
  2. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    My rates are $80/hr.

    Just kidding... what can't you do? We need more info... does the router not attempt to make the connection? Does the router connect, but you can't get connectivity out? Does the router have connectivity, but host devices not have connectivity?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  3. HayleyK

    HayleyK New Member

    3
    0
    1
    Apologies for the lack of info, I don't actually have the router with me to test - just the config to look over :oops:

    In answer to your questions, when you say 'Does the router attempt to make a connection' the answer is yes, it's going via the Dialer0 interface but no packets are being received.

    I have another config, with interface summaries if that is useful?

    Thanks again,
    Hayley
     
  4. greenbrucelee
    Highly Decorated Member Award

    greenbrucelee Zettabyte Poster

    14,283
    254
    329
    Now I am not as experience as Mike, he will be able to answer your question better than me as will others, but if no packets are being received then this sounds like a firewall issue to me.

    But I would wait for a better answer than that, like I said I am not that experienced.
     
    Certifications: A+, N+, MCDST, Security+, 70-270
    WIP: 70-620 or 70-680?
  5. BosonMichael
    Highly Decorated Member Award

    BosonMichael Yottabyte Poster

    19,136
    462
    374
    No, I don't need more configuration info... I need to know what's happening and what's not happening... I don't yet understand what you can and can't do.

    So is a connection ever established? You say "it's going"... what is "it"? Web traffic? Authentication packets? What?

    No packets are being received... by the router? by the hosts?

    What is shown when you debug the ppp traffic?

    Is the ISP not providing any assistance?
     
    Certifications: CISSP, MCSE+I, MCSE: Security, MCSE: Messaging, MCDST, MCDBA, MCTS, OCP, CCNP, CCDP, CCNA Security, CCNA Voice, CNE, SCSA, Security+, Linux+, Server+, Network+, A+
    WIP: Just about everything!
  6. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    You are missing several things from the configuration:

    - Under the interface Dialer1, you should use a dialer-group. E.g.:
    int di1
    dialer-group 1

    Then add a dialer-list to select traffic for the dialer-group you just associated with the interface, e.g.:

    dialer-list 1 protocol ip permit

    - Next you will need to set up nat. There are some other threads in this area of the forums that give some sample nat configurations that will work. Basically, you need an inside nat interface (vlan1), an outside nat interface (dialer1) and a nat statemment that tells the router what to nat.

    Finally, give the loopback a suitable ip address, and put an access-list on the vty lines to restrict access to the router. That should get you started!

    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  7. Stoney

    Stoney Megabyte Poster

    731
    23
    69
    I've been trying to get an ADSL connection going on a router at work all day, i've been working through this document to start. This should at least point you in the right direction. 8)
     
    Certifications: 25 + 50 metre front crawl
    WIP: MCSA - Exam 70-270
  8. HayleyK

    HayleyK New Member

    3
    0
    1
    Hi

    Thanks again for replying.

    The router isn't even connecting to the internet. Packets are not being received to the router. After speaking to the person who is testing the router they said this to me:

    The interface for the ATM0 is showing packets sent and received but nothing on the Dialer0 interface. However, this is bound to Virtual Access 2, which is showing as 'up', but line protocol 'down'

    I'm sorry if I'm not answering your questions properly or not giving you the correct info, like I said this is all very new to me :oops:

    No assistance from the ISP. They've tested the user account their end and they can connect fine - meaning it's a problem with the configuration of our hardware. This is something we need to sort out our end.

    Many thanks for all the other replies. Spice_Weasel that is very useful - I will add those bits in and see if it makes a difference. Also thanks for that link Stoney, just about to have a read!

    Cheers,
    Hayley
     

Share This Page

Loading...