1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Remote Desktop Problem

Discussion in 'Networks' started by Boycie, May 26, 2006.

  1. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    Have been asked to look at a PC for someone. Although they only live around the corner i can't leave the house at the moment.....

    Anyhow, the strange thing is i cannot get in via RDP over the net. I can just about get in via wireless but it drops out due to being on the weakest signal ever! I can access their router and have made sure port 3389 is forwarding, their is an exception on the router firewall and windows is set-up for remote desktop and windows firewall.
    I can access their desktop via their LAN address (via the wireless) but not computer name or the most important thing; internet.
    Google and MS come up with errors like the screen dropping out, or slow response etc....

    Error attached :thumbleft
     

    Attached Files:

    • rdp.JPG
      rdp.JPG
      File size:
      19 KB
      Views:
      17
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  2. d-Faktor
    Honorary Member

    d-Faktor R.I.P - gone but never forgotten.

    810
    0
    39
    so when you are talking about wireless, that is their wireless router that you can access (although barely) because they live around the corner, right?

    okay, so when you setup the port forwarding, did you forward to an ip address, or a wins/dns name? if ip address, is it a static address? if wins/dns name, is there a wins/dns server in the lan?

    and when you try to access via the internet, do you use their external ip address, or a dns name? if dns name, is it an existing host name?
     
  3. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Mate you gotta make sure the client is enabled to recieve Remote desktop and that you have the rights for that ie Admin rights on the remote PC. The other option is for the cremote client to send you a Remote Assistance email again it needs to be enables. Both these things can be found on the Remote tab of the System Properties.

    HTH
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  4. d-Faktor
    Honorary Member

    d-Faktor R.I.P - gone but never forgotten.

    810
    0
    39
    well, he said he could access it via the internal ip address when connected to the wireless router, so i assume your points are pretty much covered.
     
  5. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    You are quite right d- but it's always worth checking :dry
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  6. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    Thanks for the input. :thumbleft

    Yes, i have an admin account on their machine. I am using the IP address of the machine, not the computer name
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  7. The_Geek

    The_Geek Megabyte Poster

    772
    13
    64
    I had a very similar problem a few months back. It was the .dll file on the machine.



    To register remotepg.dll:

    Click Start, Run and type this command:

    regsvr32 %systemroot%\system32\remotepg.dll

    Worth a shot anyway.
     
    Certifications: CompTIA and Micro$oft
    WIP: PDI+
  8. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Thinking about it d- has hit the nail on the head I think. You need to make sure that the router is forwardung to an IP address rather than a computer name unless there is a dns serv er on the network.
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  9. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    Thanks for the input guy's, ive just figured it out; the firewall.

    I knocked it off all together (via wireless) and bingo! The exception was LAN to LAN instead of WAN to LAN.
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT
  10. AJ

    AJ Administrator Administrator

    6,771
    102
    221
    Just goes to show how wrong you can be :oops:
     
    Certifications: MCSE, MCSA (messaging), ITIL Foundation v3
    WIP: Looking at doing ..................
  11. Boycie
    Honorary Member

    Boycie Senior Beer Tester

    6,281
    85
    174
    the error message was vague to say the least. The reason i suspected the firewall in the end was because i knew there were a few exceptions you can create for individual rules;

    WAN-Router
    WAN-LAN
    LAN-WAN
    LAN-Router
     
    Certifications: MCSA 2003, MCDST, A+, N+, CTT+, MCT

Share This Page

Loading...