Problem Problem with OSPF in Packet Tracer

Discussion in 'Networks' started by jamesbond007, Aug 14, 2011.

  1. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    Dear Users,


    i have a problem generating an OPSF network in the Cisco Packet Tracer. The picture below shows the situation.
    If only the routers are connected with the serial connections and i load my configuration for each router i'm able to send ICMP packets to each router. If i add the switches and computers some serial connections were broken. I can not send ICMP packets from one computer into another network end device.

    Any suggestions? Thanks in advance.

    ospf-model.jpg


    Code:
    !
    version 12.4
    no service password-encryption
    !
    hostname RouterA
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface Loopback1
     ip address 192.168.2.1 255.255.255.255
     ip ospf priority 0
    !
    interface FastEthernet0/0
     ip address 192.168.0.1 255.255.255.240
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
     shutdown
    !
    interface Serial0/0/0
     ip address 192.168.1.1 255.255.255.252
     ip ospf cost 4
     ip ospf priority 50
     clock rate 64000
    !
    interface Serial0/0/1
     ip address 192.168.1.5 255.255.255.252
     ip ospf cost 2
     clock rate 64000
    !
    interface Vlan1
     no ip address
     shutdown
    !
    router ospf 1
     log-adjacency-changes
     network 192.168.1.1 0.0.0.0 area 0
     network 192.168.1.5 0.0.0.0 area 0
     network 192.168.1.0 0.0.0.3 area 0
     network 192.168.1.4 0.0.0.3 area 0
     network 192.168.0.0 0.0.0.15 area 0
    !
    router rip
    !
    ip classless
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
     login
    !
    !
    end
    
    
     
  2. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    Upload the packet tracer file and i'll have a look.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  3. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
  4. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    It seems the issue lay in the fact you gave all routers the same loopback address, and this was being used as the router ID. I changed the loopback interface addresses to each be unique, and reloaded the routers and they now all show neighbours in the FULL state rather than ExStart. You will need to reload the routers (remember to save config beforehand) after the change to sort this, as packet tracer doesn't have the ability to issue the command "clear ip ospf".

    I also noticed some dodgy network statements (router A) so you might want to check that too.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  5. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    Thanks for the solution.

    I thought it is an virtual interface so i'm able to use it with the same adress on each router without other router in neighbourhood being involved.
    Where can I find this information?

    I used an old challenge from school, so our teacher was setting the names at that time.
     
  6. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    Once you read up more on OSPF, you'll read about how the router chooses it's router ID.

    show ip ospf neighbor

    it's not the actual router name, it's the network statements under OSPF on router A.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  7. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    I've read it, but I thought that the router only chooses by priority. It's a mistake in my script, the looback is optional in there.

    me too, the state is FULL, but the OSPF is still not working, same problems. I noticed, the clock rate is missing on the interfaces with the brocken connection.
     
  8. cisco lab rat

    cisco lab rat Megabyte Poster

    679
    88
    116
    Indeed it does, each OSPF process you enable on a router will select it's own unique Router ID (RID).

    1. Manual RID
    2. Highest Loopback
    3. Highest Physical

    The point of the RID needing to be unique in OSPF is so that when the Router creates and floods Link State Updates (LSU) which contain the Link State Advwertisments (LSA) they will all have the originating routers RID.

    The LSA's will contain the RID are then processed by other routers to get a picture of the network, this operation is like taking a jigsaw puzzle numbering all the pieces with each piece also having information about which other RID ID that particular interface peers with. it makes it easier to piece the jigsaw puzzle together again. The OSPF router does the same.

    A router seeing it's own RID will reject the LSA thinking that there is a loop in the network, so the RID is used to get a picture of the network and to prevent loops occuring in the topology.

    There's a lot more to RID's and LSA operation than above but in a shell of a nut...

    Hope it helps
     
    Last edited: Aug 20, 2011
    Certifications: Yes I pretty much am!!
    WIP: Fizzicks Degree
  9. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    Thanks for the explanation.

    The problem still exists after correction of the loopback addresses. As I said in my last post, the OSPF curcuit is completely on FULL, but using ping shows that the connections only partly reachable. It's still the same problem like in the picture i've uploaded.
     
  10. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    What do you mean only partly reachable? After changing the loopback address i get FULL neighbour relationship and OSPF routes in each router. There are some errors, like both LAN subnets on Router D and Router C are in the same subnet.

    What exactly can't you do?
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  11. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2

    If I try to send a icmp packet from a computer in one subnet to a computer in another subnet over the the ospf network the icmp packet fails. And if i try to send a icmp from routerA to routerB it fails, but if i send from routerA to routerG it's working. That's what i mean with "partly working connections".
     
  12. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    Tell me the exact addresses you are trying to ping, that don't work. Also, note what i said regarding the LAN subnets of Router D and C.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  13. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    I've checked all my subnets and I can't find the errors you told me. Both Subnets are different, I post my subnet calculation.

    subnets.jpg

    The icmp-ping which doesn't work: 192.168.0.2/28 -> 192.168.0.19/28
     
  14. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    Looks like they are all going to be wrong then, as /28 gives you 14 available host addresses, rather than 8 as you seem to have configured.
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  15. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    Oh ****, you're right. I was looking so often on my IP-table so I didn't see the mistake. It was so clear. I will rearrange it and post when it works.
     
  16. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    Hello,

    I've corrected the mistake in the LAN-IP-configuration. Now I can send ICMP-packets from "LAN G" to "LAN A" and the other way round. But my OSPF still doesn't works properly. I tried to ping the components via ping from a computer in "LAN G" and all ping-requests work. I can reach all my components via ping, but when I try to send an ICMP to the components it doesn't work. Could it be an mistake in the packet tracer?


    Greets

    Sascha
     
  17. danielno8

    danielno8 Gigabyte Poster

    1,306
    49
    92
    I'm not sure what you mean...what do you mean by components? And what do you mean you can ping but can't icmp?
     
    Certifications: CCENT, CCNA
    WIP: CCNP
  18. jamesbond007

    jamesbond007 Bit Poster

    10
    0
    2
    I used a computer in any LAN-network and open the command-prompt. In there I used the ping-command and pinged any network component. This ping-command worked. But if I tried the ICMP-packet symbol on the right side of the packet tracer windows, it worked only for one or two connections as I wrote in my post before.


    Greetz
    Sascha
     
  19. billyr

    billyr Kilobyte Poster

    262
    20
    35
    Be careful when you use the pre-formed ping packet supplied in Packet Tracer, unlike when you use the command prompt from one of the client devices (PCs), it does not send 4 ICMP Echo requests it only sends a single request. Therefore a lot of the time your ping will not appear to get through. This can be a particular problem especially if your P.Cs arp table was empty to start with.
     
    Certifications: CCNP, CCSI, MCSE W2k/W2k3, MCITP_SA
    WIP: Taking it easy for a while.

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.