1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with dhcp service in packet tracer

Discussion in 'Networks' started by dopler, May 26, 2011.

  1. dopler

    dopler Bit Poster

    10
    0
    2
    hey all of you !! i have a problem with my testlab in packet tracer . i installed dhcp on a r router in packet tracer . i get an ip address for my client, for defaultgateway,subnetmask, but no ip for dns server .

    commands i used in ios:

    #configure terminal
    (config)ip dhcp pool p3
    (dchp-config)#network 192.168.5.0 255.255.255.0
    (dhcp-config)#default-router 192.168.5.1
    (dhcp-config)#dns-server 192.168.3.10
    (dhcp-config)#exit
    (config)#ip dhcp exclude 192.168.5.2 192.168.5.15
    ctrl z
    %SYS-5-CONFIG_I: Configured from console by console
    :blink

    you can download my testlab from 2shared server with this url:
    http://www.2shared.com/file/wH21ar6p/vervolg_op_oef_op_extended_acl.html
     
    Last edited: May 26, 2011
  2. melhiore

    melhiore Bit Poster

    38
    1
    37
    I understand you use these virtual PCs from PT?? Have you tried to /release&/renew??
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  3. dopler

    dopler Bit Poster

    10
    0
    2
    yup and it didn t work . any other possible solution ??
     
  4. melhiore

    melhiore Bit Poster

    38
    1
    37
    DHCP helper?? How these PCs are connected to DHCP machine??
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  5. dopler

    dopler Bit Poster

    10
    0
    2
    #configure terminal
    (config)ip dhcp pool p3
    (dchp-config)#network 192.168.5.0 255.255.255.0
    (dhcp-config)#default-router 192.168.5.1
    (dhcp-config)#dns-server 192.168.3.10
    (dhcp-config)#exit
    (config)#ip dhcp exclude 192.168.5.2 192.168.5.15
    ctrl z
    %SYS-5-CONFIG_I: Configured from console by console

    this is how i configuret the router of my lanfragment
     
  6. melhiore

    melhiore Bit Poster

    38
    1
    37
    That's fine. Are these PCs directly connected to Ethernet interfaces on router or they going via something else??
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  7. dopler

    dopler Bit Poster

    10
    0
    2
    no theres a switch between the end devices and the router .all connected with thaight trough .
     
  8. melhiore

    melhiore Bit Poster

    38
    1
    37
    Just for testing - can you please use different DNS. Try 8.8.8.8 f.e. and see if that's makes any difference. It should not however I have seen many things...
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  9. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    try taking out pool p1

    also why do you have ip helper addresses on those interfaces? wouldn't think that would be needed because those dhcp requests don't need to be forwarded - the machines are connected to the subnet where the dhcp service is located.
     
    Last edited: May 29, 2011
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  10. melhiore

    melhiore Bit Poster

    38
    1
    37
    Where do you see DHCP helper?? I can not see it unless it is not present only in configs shown...

    If there is DHCP helper you obviously right. That was the reason I was asking about way PCs are connected up to the router...
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  11. gosh1976

    gosh1976 Kilobyte Poster

    337
    18
    35
    Here is part of the config for router 5 which I assume is what he is looking at:

    hostname the
    !
    !
    !
    !
    ip dhcp excluded-address 192.168.5.1 192.168.5.10
    ip dhcp excluded-address 192.168.5.2 192.168.5.15
    !
    ip dhcp pool p1
    network 192.168.5.0 255.255.255.0
    default-router 192.168.5.1
    ip dhcp pool p3
    network 192.168.5.0 255.255.255.0
    default-router 192.168.5.1
    dns-server 192.168.5.20
    !
    !
    !
    !
    !
    !
    !
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.5.1 255.255.255.0
    ip helper-address 192.168.1.2
    duplex full
    speed auto
    !
    interface Serial0/0
    ip address 192.168.4.1 255.255.255.0
    ip helper-address 192.168.1.2
    ip helper-address 192.168.3.6
    tx-ring-limit 1
    clock rate 9600
    !
    interface Serial0/1
    ip address 192.168.6.1 255.255.255.0
    ip helper-address 192.168.1.2
    ip helper-address 192.168.3.6
    tx-ring-limit 1
    !
    router rip
    network 192.168.1.0
    network 192.168.3.0
    !
    ip classless
    ip route 192.168.3.0 255.255.255.0 192.168.4.2
    ip route 192.168.1.0 255.255.255.0 192.168.6.2
    ip route 192.168.3.0 255.255.255.0 192.168.6.2
    ip route 192.168.1.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.6.2
    ip route 192.168.8.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.4.2
    ip route 192.168.8.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.4.2
    !
    !


    looks like to me there are a number of incorrect or unnecessary commands that have been entered. but if he wants the PC's on the 192.168.5.0 network to get the DNS settgins from dhcp - just enter the command: no ip dhcp pool p1

    Also what is doing DHCP for the 192.168.1.0 and 192.168.3.0 networks? as far as I can tell DHCP shouldn't be working for those networks but it is????
     
    Certifications: A+, Net+, MCDST, CCENT, MCTS: Win 7 Configuring, CCNA
  12. melhiore

    melhiore Bit Poster

    38
    1
    37
    You're right. IP helper needs to be set up ONLY if we forwarding DHCP requests beyond local VLAN. I have no PacketTracer installed so I made my assumptions only on configs shown. My mistake.

    There should be also only one DHCP helper address per interface/VLAN. Using more is theoretically possible for redundancy but needs to be set up really well with excluded ranges etc.
     
    Certifications: CompTIA A+, CCENT
    WIP: CCNA, CCNA Security, CompTIA N+,S+, CWTS/CWNA
  13. dopler

    dopler Bit Poster

    10
    0
    2
    this is the startup-conf now, and i still get 0.0.0.0 for def
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname the
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.5.1 255.255.255.0

    duplex full
    speed auto
    !
    interface Serial0/0
    ip address 192.168.4.1 255.255.255.0
    wp-config.php.
    tx-ring-limit 1
    clock rate 9600
    !
    interface Serial0/1
    ip address 192.168.6.1 255.255.255.0
    ip helper-address 192.168.1.2
    ip helper-address 192.168.3.6
    tx-ring-limit 1
    !

    !
    ip classless
    ip route 192.168.3.0 255.255.255.0 192.168.4.2
    ip route 192.168.1.0 255.255.255.0 192.168.6.2
    ip route 192.168.3.0 255.255.255.0 192.168.6.2
    ip route 192.168.1.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.6.2
    ip route 192.168.8.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.4.2
    ip route 192.168.8.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.4.2
    !
    !
    !
    ip dhcp excluded-address 192.168.5.1 192.168.5.10


    ip dhcp pool p3
    network 192.168.5.0 255.255.255.0
    default-router 192.168.5.1
    dns-server 8.8.8.8
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end

    ault and dns-server
     
  14. dopler

    dopler Bit Poster

    10
    0
    2
    on router 4 and 5 i entered the command "no ip dhcp pool p"x" . and i stil dont get a dns address on the 192.168.5.0 network . is there someone ho has some input ??8)
     
    Last edited: Jun 1, 2011
  15. dopler

    dopler Bit Poster

    10
    0
    2
    no one ?
     
  16. dopler

    dopler Bit Poster

    10
    0
    2
    this is the startup-conf now, and i still get 0.0.0.0 for default and dns-server
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname the
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip name-server 0.0.0.0
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.5.1 255.255.255.0

    duplex full
    speed auto
    !
    interface Serial0/0
    ip address 192.168.4.1 255.255.255.0
    wp-config.php.
    tx-ring-limit 1
    clock rate 9600
    !
    interface Serial0/1
    ip address 192.168.6.1 255.255.255.0
    ip helper-address 192.168.1.2
    ip helper-address 192.168.3.6
    tx-ring-limit 1
    !

    !
    ip classless
    ip route 192.168.3.0 255.255.255.0 192.168.4.2
    ip route 192.168.1.0 255.255.255.0 192.168.6.2
    ip route 192.168.3.0 255.255.255.0 192.168.6.2
    ip route 192.168.1.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.6.2
    ip route 192.168.8.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.6.2
    ip route 192.168.9.0 255.255.255.0 192.168.4.2
    ip route 192.168.8.0 255.255.255.0 192.168.4.2
    ip route 192.168.7.0 255.255.255.0 192.168.4.2
    !
    !
    !
    ip dhcp excluded-address 192.168.5.1 192.168.5.10


    ip dhcp pool p3
    network 192.168.5.0 255.255.255.0
    default-router 192.168.5.1
    dns-server 8.8.8.8
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    !
    end
     
  17. dopler

    dopler Bit Poster

    10
    0
    2
    ok problem solved . the problem whas that in the startup conf there were ip helper commads id din't saw en so din't erase and that there whas anonther dhcp server on the same segment where i installed dhcp on te router . i deleted the server and rebooted the router and finaly there whas my ip address of my dns . thanx melhiore and host 1976 !
     

Share This Page

Loading...