1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

print spooler service!

Discussion in 'Software' started by brizzoluk, Jun 29, 2009.

  1. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    Hi..
    I have tried to install my canon lide 90 scanner using software downloaded from the canon website as i cant find the original software and basically my scanner wouldnt work so i thought i would uninstall it and re install it.
    When i try to uninstall it i get an error message come up....

    "processing cannot be continued because the print spooler service has been stopped. Restart the computer to start the print spooler service and then try again"

    I have restarted and am getting the same message!

    can anyone help?
     
    Certifications: ECDL, A+
    WIP: Network+
  2. ben_westbrom

    ben_westbrom Bit Poster

    31
    1
    15
    go to run

    type "services.msc"

    find print spooler, then restart the service.
     
    Certifications: A+, MCDST, 70 - 290
    WIP: 70-291
  3. ericrollo

    ericrollo Megabyte Poster

    524
    11
    64
    Its like a question straight from the A+
     
    Certifications: MOS Master, A+, MCP 271
    WIP: HND, Programming, Another Job
  4. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Well the OP has said he has already restarted the PC which should restart the service if it is configured correctly.

    Check the service is running as said mate.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  5. craigie

    craigie Terabyte Poster

    3,020
    173
    155
    Restart the PC check Services.msc for Print Spooler, make sure its running then uninstall the printer.

    If its Vista, I would recommend rebooting then re-installing.

    I have had exactly the same issue, using the same drivers, on the same hardware, on Vista where 10 machines work fine and one doesn't. Go figure!
     
    Certifications: CCA | CCENT | CCNA | CCNA:S | HP APC | HP ASE | ITILv3 | MCP | MCDST | MCITP: EA | MCTS:Vista | MCTS:Exch '07 | MCSA 2003 | MCSA:M 2003 | MCSA 2008 | MCSE | VCP5-DT | VCP4-DCV | VCP5-DCV | VCAP5-DCA | VCAP5-DCD | VMTSP | VTSP 4 | VTSP 5
  6. Modey

    Modey Terabyte Poster

    2,397
    99
    154
    Good answer, repped. :)
     
    Certifications: A+, N+, MCP, MCDST, MCSA 2K3, MCTS, MOS, MTA, MCT, MCITP:EDST7, MCSA W7, Citrix CCA, ITIL Foundation
    WIP: Nada
  7. Ence

    Ence Kilobyte Poster

    338
    8
    30
    me me up arm up :biggrin read other day

    CMD \ net start spooler
     
  8. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    I tried that but i cant restart it, it is saying
    "failed to read description. Error code 2"

    It is just a problem with my scanner software as my printer is working fine.

    By the way it is vista i am running.
     
    Certifications: ECDL, A+
    WIP: Network+
  9. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Rule 1: Always read the question carefully everyone. :biggrin


    Did you plug the scanner into the PC mate? Sometimes this can cause problems if the driver is not loaded correctly first....
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  10. Ence

    Ence Kilobyte Poster

    338
    8
    30
    this on Vista ? I just goggled - Error code 2 print spooler

    Im not c&p from other forums
     
  11. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    yes i did plug the scanner in first because i thought i already had the software installed.
     
    Certifications: ECDL, A+
    WIP: Network+
  12. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    This can in some cases cause problems. Is there an uninstall utility you can download from the Canon website?
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  13. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    yes the uninstall utility comes with the software i downloaded but when i try to run it, it goes back to the original error message :(
     
    Certifications: ECDL, A+
    WIP: Network+
  14. Modey

    Modey Terabyte Poster

    2,397
    99
    154
    Or try a system restore from before the installation.
     
    Certifications: A+, N+, MCP, MCDST, MCSA 2K3, MCTS, MOS, MTA, MCT, MCITP:EDST7, MCSA W7, Citrix CCA, ITIL Foundation
    WIP: Nada
  15. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    yes that was my last resort to do a system restore, i would have liked to have got to the bottom of the problem tho.
    Thanks for all the replies people im gonna do a system restore to hopefully sort it out.
     
    Certifications: ECDL, A+
    WIP: Network+
  16. Sparky
    Highly Decorated Member Award

    Sparky Zettabyte Poster Moderator

    10,189
    296
    319
    Let us know how it goes mate.
     
    Certifications: MSc MCSE MCSA:M MCSA:S MCITP:EA MCTS(x5) Security+ Network+ A+
    WIP: Exchange 2007\2010
  17. Mr.Cheeks

    Mr.Cheeks 1st ever Gold Member! Gold Member

    5,369
    85
    190
    system restore seems a bit harsh for this!
     
  18. brizzoluk

    brizzoluk Kilobyte Poster

    260
    0
    36
    ok system restore done and the software is gone, but im still getting the error on the spooler (failed to read description. Error code 2)
    I have tried googling this error but all the answers seem to do with printer problems when my printer is doing fine!
     
    Certifications: ECDL, A+
    WIP: Network+
  19. ben_westbrom

    ben_westbrom Bit Poster

    31
    1
    15
    At work if we get this (i know it relates to printers) we just remove the print drivers and reinstall them. May be worth a try?
     
    Certifications: A+, MCDST, 70 - 290
    WIP: 70-291
  20. ThomasMc

    ThomasMc Gigabyte Poster

    1,507
    49
    111
    You could try cleanspl.exe from the Server 2003 resource kit although i would urge caution with this tool

    have a mess about with the tool in a vm before attempting to run in on the effected machine, be carefull not to remove USB or TCP/IP registry values :twisted:
     
    Certifications: MCDST|FtOCC
    WIP: MCSA(70-270|70-290|70-291)

Share This Page

Loading...