1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pivot Table Formating

Discussion in 'Microsoft Office Specialist (MOS)' started by Nelix, Aug 10, 2006.

  1. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    HI All

    I've been digging around in Excel to try and figure this one out, to no avail I might add........hence I am asking this question to all you MOS out there.

    I have a spreadsheet that contains a Pivot table, everytime I refresh the data in the table the column length reverts back to the original setting for the table, this makes it so that you have to scroll along to the right to see the last few columns of data, Is there anyway that I can specify the Column width so that it does not change when it's refreshed, I have tried the "preserve formatting" checkbox and it does not work, it only retains the Cell formating.

    I am using Office Excel 2003.

    Thanks in advance

    Nelix
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  2. zebulebu

    zebulebu Terabyte Poster

    3,748
    330
    187
    Hi there

    I've never found a completely satisfactory answer to this problem, but I've used a workaround as follows:

    EITHER

    Format the 'data' area of the table with a suitable format - either a load of spaces or some other character (an underscore perhaps?)

    OR

    Apply the following format to the rows/columns of the table:
    @" " (change the number of spaces to suit or, as above, amend the spaces to the character of your choice)

    Not the most elegant of solutions, but they've been OK for me in a pinch. Can't remember exactly where I got the tip from - it might have been one of the Excel forums on the net?
     
    Certifications: A few
    WIP: None - f*** 'em
  3. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    Whats the best way to apply the above?

    Cheers
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294
  4. Nelix
    Honorary Member

    Nelix Gigabyte Poster

    1,412
    3
    82
    I sorted this

    I simply went into the table options (right click on table) and deselected the "Auto Format Table" option, I had to tweek the table afterwards i.e. Bold tect etc, but it works. Now when I refresh the data the column widths dont change.

    Thanks for all the help

    Derek
     
    Certifications: A+, 70-210, 70-290, 70-291
    WIP: 70-294

Share This Page

Loading...