1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networking 2500 routers

Discussion in 'Routing & Switching' started by raggedranger, Apr 13, 2008.

  1. raggedranger

    raggedranger New Member

    4
    0
    1
    I have 2 routers in my home lab, one connects to my ISP, and the ethernet interface gets an IP via DHCP from my cable modem, can ping out, and resolve dmains by DNS from a pre-set DNS server. However I have been struggling when connecting this ISP oriented router to my second router, also 2500 sderies.

    I am able to ping from the 2nd route to the internal and external IP addresses of the ISP facing router, however it doesnt go further. I have a feeling i've missed some needed routing settings as when i connect a host to router 2, i can only png the gateway and nothing further.

    Can someone who undoubtably knows more than I, take a look at my 2 configs and advise further please, been tearing my hair out almost over the weekend trying to get this to work, and from my readings getting the connection to the ISP was the hard part over, but low and behold....


    IP facing router config

    Building configuration...

    Current configuration : 695 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CableRouter
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$P.dh$2Ejg1ZK1ozF22vMgZQWFE/
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0
    ip address dhcp client-id Ethernet0
    !
    interface Serial0
    ip address 192.168.0.1 255.255.255.0
    clock rate 64000
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface TokenRing0
    no ip address
    shutdown
    !
    router rip
    version 2
    network 82.0.0.0
    network 192.168.0.0
    network 192.168.1.0
    !
    no ip http server
    ip classless
    !
    !
    !
    !
    line con 0
    password cisco
    login
    line aux 0
    line vty 0 4
    login
    !
    end

    CableRouter#sh ip int br
    Interface IP-Address OK? Method Status Protocol
    Ethernet0 82.36.255.18 YES DHCP up up
    Serial0 192.168.0.1 YES manual up up
    Serial1 unassigned YES NVRAM administratively down down
    TokenRing0 unassigned YES NVRAM administratively down down

    CableRouter#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 82.36.255.1 to network 0.0.0.0

    80.0.0.0/32 is subnetted, 1 subnets
    S 80.235.128.125 [254/0] via 82.36.255.1, Ethernet0
    82.0.0.0/24 is subnetted, 1 subnets
    C 82.36.255.0 is directly connected, Ethernet0
    C 192.168.0.0/24 is directly connected, Serial0
    R 192.168.1.0/24 [120/1] via 192.168.0.2, 00:00:06, Serial0
    S* 0.0.0.0/0 [254/0] via 82.36.255.1

    =================================================================

    2nd Router config:

    Current configuration : 689 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname TopRouter
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$P.dh$2Ejg1ZK1ozF22vMgZQWFE/
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    !
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    ip address 192.168.0.2 255.255.255.0
    !
    interface TokenRing0
    no ip address
    shutdown
    !
    router rip
    version 2
    network 192.168.0.0
    network 192.168.1.0
    !
    no ip http server
    ip classless
    !
    !
    !
    !
    line con 0
    password cisco
    login
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    end


    Interface IP-Address OK? Method Status Protocol
    Ethernet0 192.168.1.1 YES NVRAM up up
    Serial0 unassigned YES NVRAM administratively down down
    Serial1 192.168.0.2 YES manual up up
    TokenRing0 unassigned YES NVRAM administratively down down

    TopRouter#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    R 82.0.0.0/8 [120/1] via 192.168.0.1, 00:00:29, Serial1
    C 192.168.0.0/24 is directly connected, Serial1
    C 192.168.1.0/24 is directly connected, Ethernet0


    Many thanks to any advice.
     
  2. Spice_Weasel

    Spice_Weasel Kilobyte Poster

    254
    45
    45
    Yes, you're correct, it is a routing problem. The second router has no default route, and only knows the directly connected networks and the 82.0.0.0/8 from router 1.

    Add a default route to router 2 pointing to router 1, e.g.:

    ip route 0.0.0.0 0.0.0.0 192.168.0.1

    Also, you will need to configure nat in order to reach any internet hosts from inside. And I would suggest removing rip from the external interface of router 1.


    Spice_Weasel
     
    Certifications: CCNA, CCNP, CCIP, JNCIA-ER, JNCIS-ER,MCP
    WIP: CCIE
  3. raggedranger

    raggedranger New Member

    4
    0
    1
    Many thanks, thats helped loads :)
     

Share This Page

Loading...